Kernel panic - not syncing: No working init found

I am getting this message when I boot into kernels 5.0.1-1 , 4.20.15-2, 4.19.28-1:

The error differs with 4.18.16-rt9 and 4.14.105-1 but still has no working init found.

are you using manjaro grub??
do a grub update using sudo update-grub
you may try the fallback kernel from advanced options in grub menu.sometimes fallback kernels work.
try the linux51 although its rc version but worth a try.install from mhwd.

See here


and once you have done that, update grub as suggested above.

Sorry, just to clarify this is on my laptop, the issue with manjarowish is on my desktop.

Yeah I also tried a few fallback kernels which also didn't work.

you might try chrooting with live usb and update the installation.

1 Like

Yeah I'm using GRUB. I can also enter GNU GRUB 2.03 BASH but don't know how to use it, so other than that there's booting from a bootloader.

chroot using any manjaro live cd/usb
install this package
sudo pacman -S mhwd-chroot
in live environment.it will appear in menu.
then when you open mhwd-chroot in menu.it will open an terminal and in terminal type
sudo pacman-mirrors -f0 && sudo pacman -Syyu

Ok, that's done. I'm updating grub. Done. Ran manjaro-settings-manager and installed kernel 5.1rc1.d03... I rebooted but it isn't showing under advanced options in Grub 2.03.

I'm confused about what I should do here.

Should I try to delete those parts from the kernel parameters, and if so, how? How can I successfully install the latest kernel from chroot and boot into it?

Ah, just realised I forgot to update grub after installing 5.1.

Okay yeah that didn't work: 5.1 not showing after installing and updating grub with live-usb https://imgur.com/a/8xrXG6l.

when chrooted you cant use gui normal way.
to install kernel in chrooted system use command

sudo mhwd-kernel -i linux51

in the terminal of chroot.

1 Like

Success! I've booted into 5.1. Thanks for your help.

However, I still can't reboot into 5.0.7-1, 4.20, 4.19.34-1, 4.14.111-1, getting the same init not found error, but can into the recently installed 5.0.7-rt, 4.19.31-rt and 4.9.

remove all kernels except working and running ones
and after few reboots install those kernels again

1 Like

then

sudo mkinitcpio -P

OK, I removed the above 4 not working kernels, rebooted 4 times and ran sudo mkinitcpio -P. I have booted into 5.0.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by