Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0) (working on initramfs)

Hello everyone!
I am new to the Manjaro environnement, but with a Debian/Ubuntu background.
I tried to install Manjaro next to an existing LXLE (some kind of Lubuntu).

Laptop : Asus GL551J
Processor : i5-4200H @ 2.80 GHz
GPU : Nvidia 960M

Manjaro version : 17.1.10
Desktop : KDE Plasma 5.12.5
Linux kernel : 4.14.48-2
Booting via UEFI

I have the following error when booting on the first Manjaro boot entry (it works with the fallback initramfs entry) :


Here is the grub entry for Manjaro :

	menuentry 'Manjaro Linux (on /dev/sda6)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-/boot/vmlinuz-4.14-x86_64--371222d2-4b1d-4193-9607-42ef744b1c48' {
		insmod part_gpt
		insmod ext2
		set root='hd0,gpt6'
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt6 --hint-efi=hd0,gpt6 --hint-baremetal=ahci0,gpt6  371222d2-4b1d-4193-9607-42ef744b1c48
		  search --no-floppy --fs-uuid --set=root 371222d2-4b1d-4193-9607-42ef744b1c48
		linux /boot/vmlinuz-4.14-x86_64 root=UUID=371222d2-4b1d-4193-9607-42ef744b1c48 rw quiet resume=UUID=fea4ff0e-b7d1-4b60-8ee6-4f6a8dd1628a
		initrd /boot/intel-ucode.img

What I have tried so far :

  • Booting through fallback initramfs and issuing the following :
    • sudo mkinitcpio -P : rebuilt successful, but no success in rebooting
    • sudo update-grub : update from within Manjaro successful, but no success in rebooting

Which edition and image?

That's a Debian/Ubuntu kernel version number; the Manjaro kernel mentioned in the screenshot is 4.14.48-2.

Looks much like this

I know it is not exactly the same as you have it installed but something tells me that the kernel read from disk fails - maybe bad sectors?

Hi, thanks for replying.
There is no mention about a successful initramfs boot in this topic, and no viable answer either.

I know it is not identical but as the resolve in that regard was to rewrite the installation media - then bad sectors come to mind.

Also you can boot the fallback - again an indication that your primary is flawed in some way.

My bad! Thanks for the correction!

fdisk on /dev/sda is running OK

Given the fallback works, please return the output of df -h and ls -l /boot

(as text, not a screenshot)

Thanks for your time.
Here is the output to the commands you required :

[kingdom ~]# df -h
Filesystem      Size  Used Avail Use% Mounted on
dev             3,9G     0  3,9G   0% /dev
run             3,9G  1,2M  3,9G   1% /run
/dev/sda6        21G   12G  8,0G  61% /
tmpfs           3,9G   29M  3,9G   1% /dev/shm
tmpfs           3,9G     0  3,9G   0% /sys/fs/cgroup
tmpfs           3,9G  8,0K  3,9G   1% /tmp
/dev/sda1       256M  2,7M  254M   2% /boot/efi
tmpfs           787M   12K  787M   1% /run/user/0
[kingdom ~]# ls -l /boot
total 74769
drwxr-xr-x 5 root root      512  1 janv.  1970 efi
drwxr-xr-x 6 root root     4096 23 juin  12:24 grub
-rw-r--r-- 1 root root 22609416 23 juin  12:22 initramfs-3.16-x86_64-fallback.img
-rw-r--r-- 1 root root  7416087 23 juin  12:22 initramfs-3.16-x86_64.img
-rw-r--r-- 1 root root 28216559 23 juin  12:22 initramfs-4.14-x86_64-fallback.img
-rw-r--r-- 1 root root  7694803 23 juin  12:22 initramfs-4.14-x86_64.img
-rw-r--r-- 1 root root  1670656  7 mai   23:11 intel-ucode.img
-rw-r--r-- 1 root root       22  8 juin  22:56 linux316-x86_64.kver
-rw-r--r-- 1 root root       22  8 juin  22:29 linux414-x86_64.kver
drwxr-xr-x 2 root root     4096  7 mai   20:43 memtest86+
-rw-r--r-- 1 root root  4092624  8 juin  22:56 vmlinuz-3.16-x86_64
-rw-r--r-- 1 root root  4835088  8 juin  22:29 vmlinuz-4.14-x86_64

Next thing is to try some different kernels. 4.4 and 4.17 are a good starting point.

sudo mhwd-kernel -i linux44 linux417
1 Like

Thanks for your suggestion.
I tried both entries (install was successful, and grub-update as well), plus a 3.x kernel, but no success either.

You still haven't said which edition of Manjaro you've installed, but there's this old thread:

which suggests you have a non-standard /etc/mkinitcpio.conf.

If you pasted that somewhere it might help.

Manjaro version : 17.1.10 KDE Plasma

I've seen this topic, and my HOOKS field is fine :

# cat /etc/mkinitcpio.conf 
# vim:set ft=sh
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES=(piix ide_disk reiserfs)

# This setting includes any additional binaries a given user may
# wish into the CPIO image.  This is run last, so it may be used to
# override the actual binaries included by a given hook
# BINARIES are dependency parsed, so you may safely ignore libraries

# This setting is similar to BINARIES above, however, files are added
# as-is and are not parsed in any way.  This is useful for config files.

# This is the most important setting in this file.  The HOOKS control the
# modules and scripts added to the image, and what happens at boot time.
# Order is important, and it is recommended that you do not change the
# order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
# help on a given hook.
# 'base' is _required_ unless you know precisely what you are doing.
# 'udev' is _required_ in order to automatically load modules
# 'filesystems' is _required_ unless you specify your fs modules in MODULES
# Examples:
##   This setup specifies all modules in the MODULES setting above.
##   No raid, lvm2, or encrypted root is needed.
#    HOOKS=(base)
##   This setup will autodetect all modules for your system and should
##   work as a sane default
#    HOOKS=(base udev autodetect block filesystems)
##   This setup will generate a 'full' image which supports most systems.
##   No autodetection is done.
#    HOOKS=(base udev block filesystems)
##   This setup assembles a pata mdadm array with an encrypted root FS.
##   Note: See 'mkinitcpio -H mdadm' for more information on raid devices.
#    HOOKS=(base udev block mdadm encrypt filesystems)
##   This setup loads an lvm2 volume group on a usb device.
#    HOOKS=(base udev block lvm2 filesystems)
##   NOTE: If you have /usr on a separate partition, you MUST include the
#    usr, fsck and shutdown hooks.
HOOKS="base udev autodetect modconf block keyboard keymap resume filesystems fsck"

# Use this to compress the initramfs image. By default, gzip compression
# is used. Use 'cat' to create an uncompressed image.

# Additional options for the compressor

What's your root FS type?

My root fs is ext4.

That isn't the same as what I have for my Manjaro system.

This line specifically:

should also reference the kernel's initramfs image.

Can you verify that you are running update-grub from within Manjaro, and that Manjaro's GRUB is the one installed to the disk's MBR?

1 Like

I tried :

# grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck
# update-grub

from within Manjaro, but somehow grub's title is still ubuntu.
Thanks again for your time.

If that's the command you used you haven't installed it to a device. You need something like /dev/sda on the end.

You use Ubuntu grub, that's why you have the problem.

Use this tutorial to boot to Manjaro and follow the advice included to fix boot order, setting Manjaro option first.


Thanks a lot ! Those two steps I missed (for EFI) did the trick :

sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo efibootmgr -c -d /dev/sda -p 1 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"

Now I still have a problem to login to my user, but hey I'm moving forward !
Thanks to @jonathon, @AgentS and @linux-aarhus, you are great people ! Do have a great day :slight_smile:


Forum kindly sponsored by