Kernel Panic, System not booting

I was trying to install something using yum/yaourt, I don't know what I did wrong but after I restarted my pc, it didn't boot up.

I'm getting a kernel panic message saying that

/sbin/init: /usr/lib/libc.so.6: version 'GLIBC_2.28' not found (required by /usr/lib/libdev.so.1)
/sbin/init: /usr/lib/libc.so.6: version 'GLIBC_2.28' not found (required by /usr/lib/libsystemd.so.0)
/sbin/init: /usr/lib/libc.so.6: version 'GLIBC_2.27' not found (required by /usr/lib/libsystemd.so.0)

Is there any way to fix this problem without doing a reinstall?

Yum is for rpm systems why do you use it? Yaourt was deprecated a long time ago it is neither in the repos nor in the AUR anymore and should not be used. Use an alternative AUR helper like pamac yay or trizen instead.
I think you should also take a look what the AUR is https://wiki.archlinux.org/index.php/Arch_User_Repository. You should know how a package build process work before you access the AUR.
Concerning your issue I think it could be some sort of partial update you performed with installing dependencies (glibc). Partial updates are not supported. Here are some first steps you could do:

and

3 Likes

I meant pacman, not yum, sorry. I am gonna check those thread now, thanks for the help.

Read both of the threads, downloaded the latest version of manjaro-deepin, made a live usb drive, tried to do auto chroot using

manjaro-chroot -a

Getting an error saying:

/bin/bash: error while loading shared libraries: libreadline.so.7: cannot open shared object file: No such file or directory

:frowning:

Did you somehow cancel system updating?
I think you restarted your computer in mid of system updating.

Nope, I was trying to install a matlab-alternative, octave, using yaourt, installed it but when I tried to open the gui, I got an error saying some .so file was missing, I don't remember what file it was exactly, but I think it was libreadline, tried installing the package name I got by searching it on Google using pacman and blindly said yes to everything, did a restart after that because couldn't open my file manager, terminal, or any other app .. It didn't boot after that, kernel panic.

Tried doing a chroot from a live usb, got that error, so I mounted the drive manually to /mnt, and copied the libreadline.so.7 from the live usb to /mnt/usr/lib .. chroot worked, but started getting other errors, regarding different files, and because I'm dumb, I kept replacing files from live usb to /mnt/usr/lib whenever I got an error, did a restart to see if this fixed anything, but now I got no errors but the system wasn't booting either, it was stuck at the drives check .. Rebooted to live usb, did a chroot again, started getting segmentation fault whenever I ran "sudo", So, I replaced the sudo binary too :man_facepalming: .. Now at this point, I think the system is beyond "repair", so I'm just gonna backup the /home folder and do a reinstall.. Thanks.

I'm afraid this seems to be the case.

Please do not take this personal, I am trying to point to the things that might have lead to this situation and to tell you how to do it better the next time.

That's in the repos why bother with an AUR-helper?

As I said it's deprecated and should not be used. This was in the update announcements several times in March/April

  1. This is very likely the case because you did not update all packages before installing octave. If you install or update anything you should update all pending updates as well

  2. Why do you not use pacman to search for the package? Its capable of that: https://wiki.archlinux.org/index.php/Pacman#Search_for_a_package_that_contains_a_specific_file

This is very likely where you actually borked the system. Never run commands you do not fully understand and never blindly say yes to anything those questions are there for a reason.

The rest did not make things any better. Chances were really low to repair that system.

Things you should have learned from this case:

  1. On a rolling release do not perform partial upgrades, i.e. perform all pending updates before installing
  2. Check the update announcements and act accordingly
  3. Make backups
  4. Check commands you find online before you run them or be sure about what they do
  5. Do not blindly confirm questions with yes
  6. If you do not know what to do ask sooner here
2 Likes

Why did you pick that one? There isn't a recent image available.

Use one of the 18.1 official editions instead (Xfce, GNOME, KDE) as these are updated and known to work.

1 Like

Definitely, lessons learnt. No more yaourt from now on or yes-ing everything. :smiley: Thanks for the tips and all the help, really appreciate it.

1 Like

Because deep down I knew that I might have to do a reinstall, and I love DDE. :man_shrugging:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by