Key issue : From lockscreen to login screen

Hi,

After pressing Super+L to lock my screen, if I want to unlock it I have to press "Ctrl+Alt+F1" instead of "any key" in order to reach login screen. I don't remember changing anything that could impact that, so I would like to know if this was normal and how to put it back to default behavior.

inxi -Fxz
System:
  Host: tmartin-Manjaro Kernel: 4.19.32-1-MANJARO x86_64 bits: 64 
  compiler: gcc v: 8.2.1 Desktop: Gnome 3.32.0 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Dell product: Precision 5530 v: N/A serial: <filter> 
  Mobo: Dell model: 066WMR v: A00 serial: <filter> UEFI: Dell v: 1.6.0 
  date: 11/02/2018 
Battery:
  ID-1: BAT0 charge: 97.0 Wh condition: 97.0/97.0 Wh (100%) 
  model: LGC-LGC8.33 DELL 5XJ288B status: Full 
CPU:
  Topology: 6-Core model: Intel Xeon E-2176M bits: 64 type: MT MCP 
  arch: Kaby Lake rev: A L2 cache: 12.0 MiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 65112 
  Speed: 800 MHz min/max: 800/4400 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800 
Graphics:
  Device-1: Intel vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 
  Device-2: NVIDIA GP107GLM [Quadro P1000 Mobile] driver: N/A 
  bus ID: 01:00.0 
  Display: x11 server: X.org 1.20.4 driver: intel 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel HD Graphics (Coffeelake 3x8 GT2) 
  v: 4.5 Mesa 18.3.5 direct render: Yes 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel 
  v: kernel bus ID: 00:1f.3 
  Sound Server: ALSA v: k4.19.32-1-MANJARO 
Network:
  Device-1: Intel Wireless-AC 9260 driver: iwlwifi v: kernel port: efa0 
  bus ID: 3b:00.0 
  IF: wlp59s0 state: down mac: <filter> 
  Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 
  bus ID: 4-1.2:3 
  IF: ens20u1u2 state: down mac: <filter> 
  Device-3: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 
  bus ID: 4-1.4:4 
  IF: ens20u1u4 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 476.94 GiB used: 19.54 GiB (4.1%) 
  ID-1: /dev/nvme0n1 vendor: SK Hynix model: PC401 NVMe 512GB 
  size: 476.94 GiB 
Partition:
  ID-1: / size: 468.16 GiB used: 19.54 GiB (4.2%) fs: ext4 
  dev: /dev/nvme0n1p2 
Sensors:
  System Temperatures: cpu: 58.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 2496 fan-2: 2506 
Info:
  Processes: 318 Uptime: 9m Memory: 31.06 GiB used: 1.67 GiB (5.4%) 
  Init: systemd Compilers: gcc: 8.2.1 Shell: zsh v: 5.7.1 inxi: 3.0.32 

Thanks

When you press Super+L what does the screen look like? Is it the same screen if you use Menu->Lock? Or something else?

Yes it's the same. Just a wallpaper with current date and hour.

as with any other issue with gnome, disable any/all extensions, test again. if that fixes it, turn each extension back on 1 at a time until it breaks again.

Ok so the extension doing this was "gnome-shell-extension-arc-menu". I removed it and now it works. I don't really see any difference after removing it so I guess I won't install it back yet.

Thanks

1 Like

gnome's latest release has issues with some extensions. glad it worked out for you.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by