Keyboard and mouse don't work after first boot


ever since I installed kernel 4.19 and later also 4.20 my system stops recognizing my keyboard and mouse once the OS is finally loaded. During the grub menu I can still use both, but after that nothing... when I restart the system however, everything works great again. But the next time I start my pc from ground up the issue starts allover :confused:
Before those two newer kernel versions I run kernel 4.18 and those before... and everything worked wonderfully...
after I installed 4.19 and 4.20 respectively the first times and the problem began I downgraded back to 4.18 both times and it just worked again. But a couple weeks ago I somehow had to update from 4.18 because of some driver issues. Now I am on 4.20.11-1-MANJARO and my issue won't stop.

can someone help me out? I hope its just a driver issue

thank you very much in advance!

greetings marvin

Does kernel 4.14 boot properly for you. If 4.14 works, then simply use it till the bugs are ironed out on the newest kernel.

If that's not a workable solution, you might be able to do a workaround. A startup service that restarts your USB bus may correct this for you, There is lots of information on the forum about writing services.

I believe that service did correct this issue for the one person I recommended it to.

thank you very much for your quick response!
but unfortunately this didn't resolve my issue. upon boot a just got an error "reboot usb failed" or something like that and once i entered the system the peripherals again didn't work.
After I restarted the PC, I this time did not get the "reboot usb failed" message and everything worked.

do you have an idea what might went wrong or what else could do it for me?

greetings marvin

I'm guessing it may be a kernel issue.

Have you tested older kernels?

What type of mouse & kb are you using?

Please post:

systemctl status usb-restart.service

I also think that it is kernel related since it works with all kernels before 4.19

I'm using a Logitech G502 mouse and a Trust GTX280 keyboard.

systemctl status usb-restart.service

[marvin@marvin-pc ~]$ systemctl status usb-restart.service
● usb-restart.service - Restart USB
   Loaded: loaded (/etc/systemd/system/usb-restart.service; enabled; vendor preset: disabled)
   Active: active (exited) since Mon 2019-03-04 22:57:48 CET; 28min ago
  Process: 778 ExecStart=/usr/bin/sudo -E /usr/local/bin/ (code=exited, status=0/SUCCESS)
 Main PID: 778 (code=exited, status=0/SUCCESS)

Mär 04 22:57:06 marvin-pc systemd[1]: Starting Restart USB...
Mär 04 22:57:07 marvin-pc sudo[778]:     root : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/usr/local/bin/
Mär 04 22:57:07 marvin-pc sudo[778]: pam_unix(sudo:session): session opened for user root by (uid=0)
Mär 04 22:57:48 marvin-pc sudo[778]: pam_unix(sudo:session): session closed for user root
Mär 04 22:57:48 marvin-pc systemd[1]: Started Restart USB.

Well what is the problem then?

Simply use 4,14 till the bug is fixed.

File a kernel bug report if you cannot find that it has already been reported.

BTW, please do not post requests for command outputs as text. Outputs should always be text searchable.

Please post all terminal commands as text with code tags, (not as pics).

Information on how to properly post hardware specs and logs:

Please format any terminal output with three backticks before and after, as shown in this picture:

when i was on 4.18 I had issues updating the nvidia packages. and since it was somehow kernel related it kinda forced me to update the kernel. :expressionless:

but thank you very much for your help anyway!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by