Keyboard CTRL ALT META keys work like SHIFT key

Hello everyone! I've installed Manjaro 3 days ago and I have been having this problem ever since

My CTRL, ALT, META keys all work like the SHIFT key.

I ran sudo showkey to which i get this response on pressing different keys

keycode  42 press            //for shift
keycode  42 release
keycode  42 press            //for ctrl
keycode  42 release
keycode  42 press            //for alt
keycode  42 release
keycode  42 press            //for meta
keycode  42 release

Running usb-devices gives me this for my keyboard

T:  Bus=02 Lev=02 Prnt=02 Port=00 Cnt=01 Dev#=  3 Spd=1.5 MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=1c4f ProdID=0059 Rev=01.00
S:  Manufacturer=SIGMACHIP
S:  Product=USB Keyboard
C:  #Ifs= 2 Cfg#= 1 Atr=a0 MxPwr=98mA
I:  If#=0x0 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=01 Prot=01 Driver=usbhid
I:  If#=0x1 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=01 Prot=00 Driver=usbhid

I searched for help online where I found someone having my exact issue. The people there told them to install AZIOKBD's drivers.

But since it is for Ubuntu I don't know how to install it on Manjaro. And after some grievous attempts of Google-ing I came back down here to get help from you guys.

Also I am pretty certain this is not a hardware issue because in Windows my keys work just fine. How do I install AZIOKBD drivers?

I got to a post here saying they tried to install the same drivers but unfortunately the post has gone private. Help please?

I dual-boot from Windows so as to not reinstall all of my games. But thinking about switching to full time Manjaro.

Unlike the other question that has been posted here, my CTRL ALT META keys don't work on either sides.

Also this is the AZIOKBD's drivers, here! Any help is appreciated!

Guys can anyone please help? I still don't know what to do....

Hello again everyone! My problem has been fixed. After searching for aziokbd's drivers not working for me, I tried multiple drivers but to no avail.

Until I found this link HERE!
This driver when installed solved my problems! Thank you!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by