Keyboard shortcuts suddenly not working

hi manjaro GEEKS. Suddenly my super+d(show desktop) & super+l(lock) hotkeys stoped working. Maybe you know what can be the matter?

1 Like

Do you still have the package khotkeys installed?

Is your system fully up-to-date and have you rebooted since your last update?

And if the above fails: have you checked whether the sortcuts are still in your system settings after said reboot?

:innocent:

tnx for reply. both are true.

yeah i checked it image
looks like my system doesn't recognize meta(win) keyboard.

Sorry for asking, but is the meta key actually working on your keyboard?
(I.E. have you tried another keyboard?)

sorry for late answer. As you can see in the picture I can change hot key kombinations, but I can't use meta(win for me) key....yes, and I tried another keys that maybe can be meta but I didn't find

@Fabby I aplogize you my friend. Hot key began work as suddenly as it started not to work.

1 Like

It must've been a breadcrumb error (breadcrumb stuck under meta key!)

:joy:

1 Like

now it's not working again after reboot,I don't think it is breadcump.

1 Like

Looks like a hardware error: change the keyboard first... (Do you have a friend you can borrow one from?)

(I've also removed the "solution" as it doesn't seem to work any more)

it's laptop with me, but I have another keyboard

Hook that bitch up! :grin: (USB or PS/2 connector? Preferably not a wireless one)

USB connector...o my god it works!!! But I can't believe problem is in the keyboard, laptop is new.

Return it if under warranty!

Definitely a hardware error!

but the several keyboards don't work in usb keyboard also, maybe I should change some driver or standart? i can't return it)))

Huh? I don't understand: does the meta key work or not with an external keyboard connected? Can you elaborate on:

Drivers under Linux fall into two categories

  • Modules: built into kernel (This is the case here)
  • Drivers: external to kernel, needs support from the hardware manufacturer in the best case or the community if the hardware manufacturer doesn't provide good support

So there is nothing else to do but to repair the keyboard AFAIC see

no I you are right, I checked it wrong. tnx

1 Like

Sorry for late check :grimacing:, but it works on windows(second boot). Doesn't It show that issue can't be in hardware?

This looks like an intermittent issue, so I'm coming back to my first assumption:

so yes: hardware error.

Forum kindly sponsored by