KGet is broken

Lately, I've been usually getting on startup a notification that says "Download finished: /home/[username]/.local/share/kget/transfers.kgt", and pressing it will open the transfers.kgt file, which content is:

<!DOCTYPE KGetTransfers>
<Transfers>
  <TransferGroup DefaultFolder="" DownloadLimit="0" Icon="bookmark-new-list" UploadLimit="0" Status="Running" RegExpPattern="" Name="My Downloads"/>
</Transfers>

I found this weird and so a few days ago I tried to open KGet. It didn't open, and as of now it still doesn't. I also can't open it from the terminal.

Opening it during the journalctl -f log outputs the following error message:

XCB error: 3 (BadWindow), sequence: 7418, resource id: 39848626, major code: 18 (ChangeProperty), minor code: 0

 

Trying to open from the terminal as superuser gives:

QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root' "Session bus not found\nTo circumvent this problem try the following command (with Linux and bash) \nexport $(dbus-launch)"

I followed the suggestion and it also does nothing.

And I also reinstalled KGet, of course. It still doesn't open. And right now I don't really know what I'm doing, to be honest.

Seems weird.
I would remove that transfers file and reinstall. Also gonna sort mirrors and update first.

sudo pacman-mirrors -f && sudo pacman -Syyu
rm ~/.local/share/kget/transfers.kgt
sudo pacman -Rn kget && sudo pacman -S kget

Any difference?

[just wanna start here to be double sure ... then we can move on]

kget

[lets see the output from terminal .. I dont think you need sudo]

I'm gonna sort the mirrors in the weekend, since by then I will be in a place with a faster connection for the Syyu update. Btw, the kget package in the mirror that I currently use (only one in my country) is from December 14th. If it's still important that I sort them, I guess we should wait till then.

Meanwhile I did the rest of what you said and it stays the same. Except the transfers file wasn't even automatically recreated.

Do you happen to have saved sessions or similar?

What do you mean? Sessions of what?

Desktop sessions. Lots of DE, including plasma, have the ability to save your 'session' so that all of your work (and processes) pop back up when you return. Sometimes such a feature can cause issues.

Nah I don't do that.

Executed the mirrors command and ran sudo pacman -Syyuu (extra -u because of the systemd update). And did the file removal and KGet reinstall all over again.

No, it doesn't work.

Some DE's like KDE, does it by default.

Never noticed, tbh. @cscs (or anyone), does this fact mean anything in terms of resolution?

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by