Kodi-Manjaro-nvidia nonfree

@bogdancovaciu , I'm not trying to permanently switch to any resolution but to let Kodi to switch resolution freely depending on the content. So desktop and Kodi interface in 1920x1080 switching on 4K 23.xxx hz resolution and refresh rate when watching 4K movie or TV Show and back to full HD after finishing the movie. Switching Manjaro desktop to 4K is not a solution because movies with lower resolution watched in 4K is not good experience.

You can use Manjaro Settings Manager, or mhwd .

@AgentS thanx, but I just can't see where in Manjaro Settings Manager one can choose the version of driver.

Here
or
Installed

mhwd --pci -li

Available

mhwd --pci -l

OK, I understand, but what if i need version not listed, for example 384.111 version.

You mean "if you want", I guess. If you want an older working driver than 390xx, you go for 340xx. No matter the right/tail number.
If you want something else, AFAIK you have to build/find it yourself. Sorry..
I suggest you try 340xx

@AgentS
This what I get in Manjaro Settings Manager screenshot

> 0000:01:00.0 (0300:10de:1402) Display controller nVidia Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
          video-nvidia            2018.05.04               false            PCI
    video-nvidia-390xx            2018.05.04               false            PCI
           video-linux            2018.05.04                true            PCI
            video-vesa            2017.03.12                true            PCI


> 0000:04:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
         network-r8168            2016.04.20                true            PCI



`
on mhwd -l -d

@AgentS, Actually, I can't see 340.xxx version

First, please, repair your previous post with long code. Place them in code blocks (select the code and press </>.
Why did you use the -d flag?

Then your card may not have this option.
I have

> 0000:01:00.0 (0300:10de:1244) Display controller nVidia Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
    video-nvidia-390xx            2018.05.04               false            PCI
    video-nvidia-340xx            2018.05.04               false            PCI
    video-nvidia-304xx            2018.05.04               false            PCI
           video-linux            2018.05.04                true            PCI
            video-vesa            2017.03.12                true            PCI

@AgentS, I really have no idea how that d letter appear. I've updated previous post.

@AgentS. Hmm, I think that maybe because today I've installed unstable Manjaro KDE and its related with new kernel I'm using now.

The point was taken already: you have no downgrade option as mhwd detects.
I suggest you ask the Kodi forum people, they might have more experience.
It might be just a little thing, that I have not enough experience to guess it.

Thank you petsam.

Or study the Books
http://us.download.nvidia.com/XFree86/Linux-x86/390.48/README/installationandconfiguration.html
http://us.download.nvidia.com/XFree86/Linux-x86/390.48/README/xconfigoptions.html

I don't know if this would help your issue, but you might try a combination and share your experience

I'm using dual boot now, Linux Mint with Kodi and everything media related an Manjaro KDE unstable for learning Linux. So I'm OK. But thank you.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by