kwin problems ?

Hello!

Trying out Manjaro , so fresh install

sometimes a program crash and can't re-open again , I execute it , icon appear (like opening the program ) and then it closes

Looking at logs I can see that every time I close a window and when a program crash (and cant re-open it) it give me the same log

Kwin_x11
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 47645, resource id: 100663341, major code: 18 (ChangeProperty), minor code: 0

Kwin_x11
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 24886, resource id: 38685682, major code: 3 (GetWindowAttributes), minor code: 0

Kwin_x11
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 43446, resource id: 38687686, major code: 2 (ChangeWindowAttributes), minor code: 0

and it repeats again and again when close every window or trying to re-open a crashed app

I got 99 problems, but kwin aint one.

So lets start with basics:

Updated with system info , any log in specific ? thanks

  • Which ISO did you use to install from?
  • Is your system up-to-date?
  • Have you rebooted since you last updated? I get those errors when some parts of plasma are at different versions than other parts.

ok , didn't reboot since last update , omw

what do you mean with wich ISO ? , the one from the download page (https://manjaro.org/download/official/kde/)?

-- update --

did the reboot but same logs , when open and close folders

if I open and then close VLC player then I can't reopen

qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 24360, resource id: 4194431, major code: 18 (ChangeProperty), minor code: 0

kde.dataengine.mpris: "org.mpris.MediaPlayer2.vlc.instance3853" does not implement org.freedesktop.DBus.Properties correctly Error message was "org.freedesktop.DBus.Error.NoReply" "Message recipient disconnected from message bus without replying"

kde.dataengine.mpris: Failed to find working MPRIS2 interface for "org.mpris.MediaPlayer2.vlc.instance3853"

They aren't related, vlc is just buggy. First hit doing a forum search

Don't worry about the kwin messages, they're informational and kwin spits an error everytime a gentle breeze blows by.

Thanks for the reply !

I just want to check if I got something wrong because the web browser (chrome,firefox and brave) make the fans at maximum speed when scrolling (and CPU (htop) ) , and that log is the only one I found so far (learning on Manjaro) coming from Debian and the performance was better so I think I might have something miss configured or not right

thanks for the messages <3

Try switching to kernel 5.5 or 4.19.

Do I have to downgrade/upgrade (programs versions) or do something else apart from installing the other kernel version? txn

You need to be fully up to date before installing anything.

-note-
Please be aware that outside of very particular circumstances and knowledge-level you should pretty much only use mhwd/manjaro-settings-manager for any driver or kernel change.
@bitxor

airtight , thanks , for the reply's , going to test with the 5.5 and 4.19

didn't find much difference between 5.5 or 4.19 :confused: haven't test that much but going to check if I can find another sign , also i get the same log errors

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by