Kwin seems to force enable vsync after a suspend/resume cycle

Hi there,

I've started noticing an issue with my fps after suspending my pc. With a freshly booted pc, my fps maintains around 100 (according to the Show FPS tool) regardless of what's on my desktop (games, videos, text). After suspending/resuming, as soon as I play a video or animation, the FPS suddenly drops to around 60 and stays there until I stop playing the video. If I restart kwin, the FPS goes back to a steady 100 regardless of if I'm playing a video or not. I feel like this just started recently but I cannot confirm. I have a 144hz and 60hz monitor so I usually keep vsync disabled but the way that the fps just locks in at 60 really seems like it gets force enabled somehow.

My specs:

Operating System: Manjaro Linux
KDE Plasma Version: 5.19.4
KDE Frameworks Version: 5.72.0
Qt Version: 5.15.0
Kernel Version: 5.6.19-2-MANJARO
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-6700K CPU @ 4.00GHz
Memory: 15.6 GiB of RAM
Graphics Processor: GeForce GTX 1080 Ti/PCIe/SSE2

I also have the latest proprietary nvidia drivers (440.100).

Any suggestions on what might be causing this issue? Thanks.

Forum kindly sponsored by