kworker_kacpid CPU 100%

My CPU usage suddenly started to spike to 100% usage on a single thread, persisting through reboots.
I've narrowed it down to kworker_kacpid process, which I gathered from other sources is a Kernel worker process.
I executed the following commands:
perf record -g -a sleep 10
perf report
And I get the following:

Does anyone know what is causing this? I've tried uninstalling GPU drivers since they always cause problems, and even downgraded to an earlier kernel, nothing worked.

I managed to fix it.
I used grep . -r /sys/firmware/acpi/interrupts/ to find the interrupt that was causing the issue.
In my case it was gpe61.
Then I used echo "disable" > /sys/firmware/acpi/interrupts/gpe61.
The echo command has to be executed as superuser, however su did not do the trick for me, only sudo -s.

2 Likes

Hello!

I was having this very same problem, and following your directions seemingly fixed it! Thank you!

But this problem seems to be OS-agnostic, since it's also manifesting itself in my Windows system.

Could you explain what I've just did so I can try to find a similar solution to apply on Windows?

This topic was automatically closed after 180 days. New replies are no longer allowed.

Forum kindly sponsored by