Laptop boots to grub rescue instead of grub menu

Hey all,
Relevant background:
I tried to reinstall ubuntu and the installer kept crashing so I decided I would switch to manjaro. Manjaro installed fine but the laptop still boots to grub rescue. I can get into Manjaro's grub menu by using chainloader to find the efi file and run the installed OS and the dual-booted Windows 10 but it would be nice not to have to use chainloader every time. I followed the steps given here: Using livecd v17.0.1 (and above) as grub to boot OS with broken bootloader to try and repair the problem but it persisted. Here are the details below:

[akady@deck ~]$ efibootmgr -v
BootCurrent: 0000
Timeout: 5 seconds
BootOrder: 0000,3000,0002,0001,0000,2001,2002,2004
Boot0000* ubuntu	HD(1,GPT,3414906a-5276-47b3-be04-947c7e14c40a,0x800,0x82000)/File(\EFI\ubuntu\shimx64.efi)
Boot0001* manjaro	HD(1,GPT,3414906a-5276-47b3-be04-947c7e14c40a,0x800,0x82000)/File(\EFI\manjaro\grubx64.efi)
Boot0002* Windows Boot Manager	HD(1,GPT,3414906a-5276-47b3-be04-947c7e14c40a,0x800,0x82000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...a................
Boot0003* manjaro	HD(1,GPT,3414906a-5276-47b3-be04-947c7e14c40a,0x800,0x82000)/File(\EFI\Manjaro\grubx64.efi)
Boot2001* EFI USB Device	RC
Boot2002* EFI DVD/CDROM	RC
Boot3000* Internal Hard Disk or Solid State Disk	RC
[akady@deck ~]$ sudo parted -l
Model: ATA WDC WD10JPVX-60J (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                          Flags
 1      1049kB  274MB   273MB   fat32        EFI system partition          boot, esp
 2      274MB   408MB   134MB                Microsoft reserved partition  msftres
 3      408MB   490GB   489GB   ntfs         Basic data partition          msftdata
 4      490GB   616GB   126GB   ntfs         Basic data partition          msftdata
 7      616GB   895GB   279GB   ext4
 8      895GB   976GB   80.5GB  ext4
 5      976GB   977GB   767MB   ntfs         Basic data partition          hidden, diag
 6      977GB   1000GB  23.6GB  ntfs         Basic data partition          hidden, diag


[akady@deck ~]$ sudo blkid 
/dev/sda1: UUID="3EF7-5DD8" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="3414906a-5276-47b3-be04-947c7e14c40a"
/dev/sda2: PARTLABEL="Microsoft reserved partition" PARTUUID="6fa47347-500c-4dc2-9d58-fcca01811800"
/dev/sda3: LABEL="Windows" UUID="3206661B0665E079" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="97d5f2d2-9684-49cc-875d-554350c58e2b"
/dev/sda4: LABEL="New Volume" UUID="9A88AD0C88ACE7C9" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="e2724219-8afe-44f2-a77e-49104022278f"
/dev/sda5: LABEL="WINRE" UUID="D26E37356E371229" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="51645045-899a-43ea-b43d-762040481eba"
/dev/sda6: LABEL="RECOVERY" UUID="2E9029469029163D" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="9f6b4cb3-73b1-4a0d-8704-9ca9f7a73ff1"
/dev/sda7: UUID="67a81fa0-e5e1-4ea7-939e-726a56754034" TYPE="ext4" PARTUUID="76aad85f-09af-46e3-9206-b9775821d36c"
/dev/sda8: UUID="994b57cf-682b-4c03-ab96-87865fe560ff" TYPE="ext4" PARTUUID="bc7943a3-b138-4677-9228-daa224a020f9"
[akady@deck ~]$ findmnt -s
TARGET    SOURCE                                    FSTYPE OPTIONS
/boot/efi UUID=3EF7-5DD8                            vfat   umask=0077
/         UUID=994b57cf-682b-4c03-ab96-87865fe560ff ext4   defaults,noatime
[akady@deck ~]$ findmnt /boot/efi
TARGET    SOURCE    FSTYPE OPTIONS
/boot/efi /dev/sda1 vfat   rw,relatime,fmask=0077,dmask=0077,codepage=437,iocharset=iso8859-1,shortname=mix
[akady@deck ~]$ 

The laptop is a HP Pavillion Notebook.

you can use efibootmgr to change the boot order, or just get manjaro booted and run grub-install which should make manjaro first

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck
sudo update-grub

you can use efibootmgr to change the boot order, or just get manjaro booted and run grub-install which should make manjaro first

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck
sudo update-grub

Hey, thanks for the reply. I tried that and there were no errors but I am back to the grub command line when I restart. I tried both the methods you mentioned, when I restart the boot order reverts back with the ubuntu before manjaro. Is it okay to just delete the ubuntu?

have you used grub-customizer recently? (im in no way suggesting you should)

HP sometimes does funny things like making bios only look for bootloaders in certain non uefi standard locations. has manjaro grub ever worked for you in the past?

but first go back into bios and make sure both secure boot and fast boot are disabled, ubuntu grub can work with secure boot enabled but manjaro grub does not

Never used grub-customizer but I have read some horror stories.

HP sometimes does funny things like making bios only look for bootloaders in certain non uefi standard locations. has manjaro grub ever worked for you in the past?

Never used Manjaro before this.

but first go back into bios and make sure both secure boot and fast boot are disabled, ubuntu grub can work with secure boot enabled but manjaro grub does not

I disabled secure boot though I could have sworn it was disabled, my laptop always blinked "booting insecurely" or some such so I was surprised to see it enabled. Changing the boot order after that still reverted back though I think it was a piece of the puzzle. I think deleting the ubuntu boot-loader thing is my best bet but I don't want to break anything.

Try this.
You may have to use the [More Complicated Setup] section.
Don't forget to do the [Additional UEFI commands]

Hey, I had done that before posting. I didn't need to use a livekey though and I can boot into installed os simply using chainloader /efi/Boot/bootx64.efi. I did it again in case disabling secure boot helped and changed boot order but after rebooting I still get the old boot order:

[akady@deck efibootmgr
BootCurrent: 0000
Timeout: 5 seconds
BootOrder: 0000,0003,0001,0000,0000,2001,2002,2004
Boot0000* ubuntu
Boot0001* manjaro
Boot0002* Windows Boot Manager
Boot0003* Windows Boot Manager
Boot0004* manjaro
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
Boot3000* Internal Hard Disk or Solid State Disk

UEFI seems to 'forget' boot order every time

sudo efibootmgr -o 0004,0000,0003

check which is correct bootentry for ubuntu and windows for above
If this 'forgets' again and confirmed when rebboted with 'efibootmgr'
then go to the bios set up (F2) and see if you can do that.
Some HP's are difficult to set uefi boots.
Have a look at the section [Some Difficult UEFI Setups] under HP and see if any of the links help.

Let us know which help or if you have to do your own method, explain it here with screen shots so others can refer to it.

Good luck.

Okay, solved it! This tipped me off:https://github.com/rhboot/efibootmgr/issues/19

I add, that it resets on reboot to order, that I see in EFI control utility (BIOS) in boot priority list. When I change order here, it really changes and Linux boots first. But changing it by efibootmgr does no effect, as on reboot it resets to order in BIOS.

I changed the priority list through BIOS and that change seems to have taken while efibootmgr was unable to change the order and it would revert back to the original order in BIOS. I can now access manjaro grub without having to chainload it.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by