Laptop not booting after installing proprietary drivers

Hello everyone,

after installing proprietary drivers using hardware configuration, I was unable to boot after grub and got stuck at hp logo.
unlike most people I'm not getting error messages

I was able to boot into terminal and restore my system using timeshift CLI

I've tried installing the drivers using command line from the live session using manjaro-chroot following this wiki, same result.

tried uninstalling the free drivers, nothing changed.

I've read somewhere that adding acpi_oci=! acpi_osi="Windows 2009" would help, well it did not.

When first installing manjaro I had to add nouveau.modeset=0 to run the live session and the installed manjaro (don't know what it actually does but it worked)

I am dual booting with windows 10, so i don't want to change bios configurations in a way that will affect windows.

So what I want to do is to install the proprietary drivers without affecting windows or know if that's not possible.

I want to use cuda and cudnn, is it possible without the proprietary drivers?

Thanks in advance.

System:    Host: yazan-pc Kernel: 4.19.24-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Console: tty 0 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: HP product: HP Pavilion Gaming Laptop 15-cx0xxx v: Type1ProductConfigId serial: CND824584R 
           Mobo: HP model: 8478 v: 70.33 serial: PHJTQF2MYAYFHM UEFI: Insyde v: F.06 date: 05/11/2018 
Battery:   ID-1: BAT1 charge: 9.5 Wh condition: 51.0/52.8 Wh (97%) model: Hewlett-Packard PABAS0241231 status: Discharging 
CPU:       Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 9216 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 53004 
           Speed: 800 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 801 
           9: 800 10: 800 11: 800 12: 800 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] vendor: Hewlett-Packard driver: N/A bus ID: 01:00.0 
           Display: server: X.Org 1.20.3 driver: intel unloaded: modesetting resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) v: 4.5 Mesa 18.3.3 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Sound Server: ALSA v: k4.19.24-1-MANJARO 
Network:   Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter vendor: Hewlett-Packard driver: r8822be v: kernel 
           port: 4000 bus ID: 02:00.0 
           IF: wlo1 state: up mac: 74:40:bb:2f:73:3d 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard driver: r8168 
           v: 8.045.08-NAPI port: 3000 bus ID: 05:00.0 
           IF: eno1 state: down mac: 10:62:e5:87:81:d3 
Drives:    Local Storage: total: 1.03 TiB used: 110.54 GiB (10.5%) 
           ID-1: /dev/nvme0n1 vendor: LITE-ON model: CA1-8D128-HP size: 119.24 GiB 
           ID-2: /dev/sda vendor: HGST (Hitachi) model: HTS721010A9E630 size: 931.51 GiB 
Partition: ID-1: / size: 95.86 GiB used: 25.73 GiB (26.8%) fs: ext4 dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 44.0 C mobo: 29.8 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 252 Uptime: 32m Memory: 15.55 GiB used: 1.41 GiB (9.0%) Init: systemd Compilers: gcc: 8.2.1 Shell: bash 
           v: 5.0.0 inxi: 3.0.30 

If you want to use your nvidia gpu as the primary gpu on an optimus laptop you need to manually setup nvidia prime, just installing the nvidia driver won't work.

Another option is optimus manager, which also needs to be manually setup.

The other option is bumblebee, but I don't think that supports cuda so won't suit your needs.

Welcome to the world of nvidia optimus and Linux ... which nvidia doesn't officially support.

1 Like

(is acpi_oci=! just a typo or is this how your typed it previously?)
the format of how this is used is dependent on where its being implemented. if adding it to
/etc/default/grub and then updating grub it would look like this:

GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=\"!Windows 2009\" resume=UUID=0227c9e1-2b79-484b-9e4f-92afaefd161f"


GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=\"!Windows 2009\"" 
GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=\"!Windows 2013\""
GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=\"!Windows 2015\""
try each and run `sudo update-grub`  after each one.

if you do this instead from grub at boot, it would look like this:

acpi_osi=! acpi_osi='Windows 2009' nouveau.modeset=0
acpi_osi=! acpi_osi='Windows 2013' nouveau.modeset=0
acpi_osi=! acpi_osi='Windows 2015' nouveau.modeset=0
(with or without the nouveau.modeset=0)
notice the difference of " and '

also the 1050ti is known for being problematic with bbswitch, so bumblebee may not be what your looking for, if performance is your goal then the prime tutorial that @sueridgepipe suggested is the way to go using the video-nvidia drivers.

optimus-manager also uses bbswitch so this might not be the way to go for you. (i think you can also use the nouveau drivers instead of bbswitch but not sure)

optimus-switch is something new i put together, does not use bbswitch. when in nvidia mode it is set up exactly the way prime is. when in intel-only mode the nvidia gpu is completely powered down and removed from sight as to avoid any lockups/hangs or break suspend/sleep cycles. switching is done with sudo or sudo this also only uses the video-nvidia drivers.

1 Like

Thank you,
I've tried the optimus manager, and with some configurations I think it is currently working .
I need more time to be sure that everything is good.

sorry it was a typo

I am aware of the format, I believe I got that right

it looks like that currently the default is nouveau default optimus manager config

I had optimus manager with default configurations except for:


and keeping nouveau.modeset=0 in GRUB_CMDLINE_LINUX_DEFAULT

it's working currently,.
is there anything wrong doing that?

Thank you for the recommendation I'll try that if anything goes wrong.

afaik , i dont think there should be anything wrong with doing it that way, but i dont have much experience with optimus-manager since i was never able to make it work consistently. if it works for you then thats all that matters. what i said about bbswitch was repeated from what i've read in arch wiki and past experience of it only ever causing me problems and im using a nvidia 960m. if the nouveau switching method works for you then you should use it.

do you get any hangs/lockups before or after sleep/suspend?

suspending didn't cause problems.
The only problem I got until now is that fonts are smaller in nvidia mode, but that's something I can live with.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by