Laptop screen is too bright

Hey Guys.
So I got this Asus Tuf A15 a couple weeks ago and I installed Manjaro on it today (as it was too buggy before). But the problem is, Manjaro can't adjust my screen brightness. It's always at full and I can't change it. When it is booting it gives this error:

[FAILED] Failed to start Load/Save Screen Backlight Brightness of backlight:acpi_video0
See 'systemctl status systemd-backlight@backlight:acpi_video0.service' for details.

and when I'm normally shutting down my computer it gives me just the first lines and gets stuck there so I need to press the power button to shut it down. When I run the commad on the second line I get this:


● systemd-backlight@backlight:acpi_video0.service - Load/Save Screen Backlight Brightness of backlight:acpi_video0
     Loaded: loaded (/usr/lib/systemd/system/systemd-backlight@.service; static; vendor preset: disabled)
     Active: failed (Result: exit-code) since Fri 2020-06-12 23:28:32 +03; 28min ago
       Docs: man:systemd-backlight@.service(8)
    Process: 967 ExecStart=/usr/lib/systemd/systemd-backlight load backlight:acpi_video0 (code=exited, status=1/FAILURE)
   Main PID: 967 (code=exited, status=1/FAILURE)

Haz 12 23:28:32 kaan-laptop systemd[1]: Starting Load/Save Screen Backlight Brightness of backlight:acpi_video0...
Haz 12 23:28:32 kaan-laptop systemd-backlight[967]: Failed to get backlight or LED device 'backlight:acpi_video0': No such device
Haz 12 23:28:32 kaan-laptop systemd[1]: systemd-backlight@backlight:acpi_video0.service: Main process exited, code=exited, status=1/FAILURE
Haz 12 23:28:32 kaan-laptop systemd[1]: systemd-backlight@backlight:acpi_video0.service: Failed with result 'exit-code'.
Haz 12 23:28:32 kaan-laptop systemd[1]: Failed to start Load/Save Screen Backlight Brightness of backlight:acpi_video0.

As I said I am using Asus Tuf A15 FA506II
-Ryzen 4600H with Radeon Graphics
-GTX 1650Ti
-8G 3200MHz
-256 NVMe

Thanks in advance :slight_smile:

This device is super brand new like less than a month ago, right? Chance are you'll need to wait a couple of months (or years) until everything works out of the box, just like what happened to my GL503VD. However, workaround for certain problems might be available.

so probably the backlight isn't handled by acpi_video0, let's see what it has:

$ ls /sys/class/backlight/

come back with the result and see where we can proceed.

1 Like

:+1: Welcome to Manjaro! :+1:

On top of leledumbo's excellent advice above, please also read this:


and post some more information (an inxi --full --verbosity=7 --filter --no-host at a minimum) so we can see what's really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies...

:innocent:

More than likely you'll need to add a kernel parameter to your /etc/default/grub file: acpi_backlight=vendor.

For example:

GRUB_CMDLINE_LINUX_DEFAULT="udev.log_priority=3"
GRUB_CMDLINE_LINUX="acpi_backlight=vendor"
1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by