Laptop won't suspend

Hello. I have a problem with manjaro. I have tried different kernels but the problem stays. When I try to suspend my laptop, only screen shut down, but procesorr and ssd is still on, i can hear them.
And then, I cant turn screen on, so only solution is to force shutdown laptop and start it again.
Any help?

Have you tried hibernate?
What is the terminal output of:
cat /sys/power/mem_sleep

Often writing a systemd service will correct this problem, see:

There are many other posts on this topic if you search the forum.

Here are some external links with excellent systemd reference material:

The ArchWiki - systemd

Red Hat - systemd-targets

Red Hat - systemd unit files

Systemd manpage

1 Like

Which kernels?

You need to provide more details in a help request.

Please post the input/outputs of all requested commands via the terminal as text, (not as pics).

inxi -Fxxxz

Information on how to properly post hardware specs and logs:

Please format any terminal output with three backticks before and after, as shown in this picture:

1 Like

Yes, I have tried hibernate, everything is the same.
I typed in terminal what you said and got

s2idle [deep]

Thank you very much for your help. I have tried many different solutions for the past one month (not everyday, but when I catch the time).
Last link you provided works perfectly for me. (


Awesome news. Glad to help. Nice work getting it fixed up.

If it won't go back into suspend, after already suspending, remove this line:


This topic was automatically closed after 180 days. New replies are no longer allowed.

Forum kindly sponsored by