Latest Manjaro Community Openbox Edition

Openbox Community Edition

Reworking and tweaking the experience - making hard decisions on content - the Openbox Edition has now officially reached v19.

Changes

To name one - the Openbox edition will - from now on - only be available as a minimal edition.

NOTE: Due to the comments in this thread - my previous decision to exclude the proprietary drivers has been reverted. The ISO contains the proprietary drivers as well as the free drivers.

ADDENDUM: Booting the ISO using the proprietary drivers is only recommended as a last resort. Please use the opensource -AKA free - whenever possible.

The complete list of packages is available using the link below.

Why?

Good question - the primary reason is - keeping the ISO size down.

Another reason - strongly inspired by the original PacBang - the edition is slimmed down because users going for this edition are assumed to be long time users - knowing exactly how the system shall be - and previous editions had to some extent taken that choice away.

The current ISO - as of today - does not include unnecessary applications - hopefully you agree :slight_smile:.

Much thought has gone into this revision - but it will take too long to explain what have changed.

Screen shots

jg-menu

login

root-menu

thunar

The following bare-metal systems has been tested to work OOB using an ISO without proprietary drivers.

Laptop Yepo Tbao model: A116H (Intel HD500)
manjaro@manjaro-openbox Linux 5.5.7-1-MANJARO x86_64 19.0.2 Kyria
~ >>> inxi -F                                                                                                                                                                                                                                 
System:    Host: manjaro-openbox Kernel: 5.5.7-1-MANJARO x86_64 bits: 64 Desktop: Openbox 3.6.1 Distro: Manjaro Linux 
Machine:   Type: Laptop System: YEPO product: A116H v: N/A serial: <root required> 
           Mobo: Tbao model: A116H v: .A003 serial: <root required> UEFI: A116H.YEPO.P3.1k.A003 v: 5.12 date: 01/22/2019 
Battery:   ID-1: BAT0 charge: 48.0 Wh condition: 48.0/48.0 Wh (100%) 
CPU:       Topology: Quad Core model: Intel Celeron J3455 bits: 64 type: MCP L2 cache: 1024 KiB 
           Speed: 2139 MHz min/max: 800/2300 MHz Core speeds (MHz): 1: 1950 2: 2128 3: 2071 4: 2068 
Graphics:  Device-1: Intel HD Graphics 500 driver: i915 v: kernel 
           Display: x11 server: X.Org 1.20.7 driver: intel unloaded: modesetting resolution: 1920x1080~60Hz 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     Device-1: Intel Celeron N3350/Pentium N4200/Atom E3900 Series Audio Cluster driver: snd_hda_intel 
           Sound Server: ALSA v: k5.5.7-1-MANJARO 
Network:   Device-1: Intel Wireless 3165 driver: iwlwifi 
           IF: wlp2s0 state: down mac: ce:9f:94:fa:cc:72 
           Device-2: Realtek RTL8152 Fast Ethernet Adapter type: USB driver: r8152 
           IF: enp0s21f0u1 state: up speed: 100 Mbps duplex: full mac: 16:09:01:04:b8:ec 
Drives:    Local Storage: total: 238.47 GiB used: 3.86 GiB (1.6%) 
           ID-1: /dev/sda model: BORY R500 256G size: 238.47 GiB 
Partition: ID-1: / size: 224.77 GiB used: 3.86 GiB (1.7%) fs: ext4 dev: /dev/sda2 
           ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 34.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 170 Uptime: 1m Memory: 7.63 GiB used: 700.1 MiB (9.0%) Shell: zsh inxi: 3.0.37 
Laptop Clevo model: N14xWU (Intel UHD620)
manjaro@manjaro-openbox Linux 5.5.7-1-MANJARO x86_64 19.0.2 Kyria
~ >>> inxi -F                                                                   
System:
  Host: manjaro-openbox Kernel: 5.5.7-1-MANJARO x86_64 bits: 64 
  Desktop: Openbox 3.6.1 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Notebook product: N14xWU v: N/A 
  serial: <root required> 
  Mobo: Notebook model: N14xWU serial: <root required> 
  UEFI: American Megatrends v: 1.05.02 date: 03/26/2018 
Battery:
  ID-1: BAT0 charge: 31.5 Wh condition: 32.3/35.3 Wh (92%) 
CPU:
  Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP 
  L2 cache: 8192 KiB 
  Speed: 700 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 700 2: 700 
  3: 700 4: 700 5: 700 6: 700 7: 701 8: 700 
Graphics:
  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel 
  Display: x11 server: X.Org 1.20.7 driver: intel unloaded: modesetting 
  resolution: 1920x1080~60Hz 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel 
  Sound Server: ALSA v: k5.5.7-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8169 
  IF: enp58s0f1 state: up speed: 1000 Mbps duplex: full 
  mac: 80:fa:5b:60:c4:53 
  Device-2: Intel Wireless-AC 9260 driver: iwlwifi 
  IF: wlp59s0 state: down mac: 42:e3:23:5f:7e:bc 
Drives:
  Local Storage: total: 473.03 GiB used: 52.4 MiB (0.0%) 
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 500GB 
  size: 465.76 GiB 
  ID-2: /dev/sda type: USB vendor: Kingston model: DataTraveler 2.0 
  size: 7.27 GiB 
Partition:
  ID-1: / size: 11.64 GiB used: 52.4 MiB (0.4%) fs: overlay source: ERR-102 
Sensors:
  System Temperatures: cpu: 35.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 204 Uptime: 1m Memory: 15.52 GiB used: 473.2 MiB (3.0%) 
  Shell: zsh inxi: 3.0.37 

Laptop ASUS model: N56VJ (Intel/Nvidia GT 635M)
manjaro@manjaro-openbox Linux 5.5.7-1-MANJARO x86_64 19.0.2 Kyria
~ >>> inxi -F                                                                   
System:
  Host: manjaro-openbox Kernel: 5.5.7-1-MANJARO x86_64 bits: 64 
  Desktop: Openbox 3.6.1 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: ASUSTeK product: N56VJ v: 1.0 serial: <root required> 
  Mobo: ASUSTeK model: N56VJ v: 1.0 serial: <root required> 
  UEFI: American Megatrends v: N56VJ.203 date: 08/29/2012 
Battery:
  ID-1: BAT0 charge: 0.8 Wh condition: 15.9/57.2 Wh (28%) 
CPU:
  Topology: Quad Core model: Intel Core i7-3630QM bits: 64 type: MT MCP 
  L2 cache: 6144 KiB 
  Speed: 1197 MHz min/max: 1200/3400 MHz Core speeds (MHz): 1: 1197 2: 1197 
  3: 1197 4: 1198 5: 1197 6: 1197 7: 1197 8: 1198 
Graphics:
  Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel 
  Device-2: NVIDIA GF108M [GeForce GT 635M] driver: nouveau v: kernel 
  Display: x11 server: X.Org 1.20.7 driver: intel,nouveau 
  unloaded: modesetting resolution: 1920x1080~60Hz 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio 
  driver: snd_hda_intel 
  Device-2: NVIDIA GF108 High Definition Audio driver: snd_hda_intel 
  Sound Server: ALSA v: k5.5.7-1-MANJARO 
Network:
  Device-1: Qualcomm Atheros AR9485 Wireless Network Adapter driver: ath9k 
  IF: wlp3s0 state: down mac: a6:8d:ce:b8:8b:7b 
  Device-2: Qualcomm Atheros AR8161 Gigabit Ethernet driver: alx 
  IF: enp4s0 state: down mac: 50:46:5d:33:5c:12 
  Device-3: IMC Networks Atheros AR3012 Bluetooth 4.0 Adapter type: USB 
  driver: btusb 
Drives:
  Local Storage: total: 230.84 GiB used: 52.4 MiB (0.0%) 
  ID-1: /dev/sda vendor: OCZ model: AGILITY3 size: 223.57 GiB 
  ID-2: /dev/sdb type: USB vendor: Kingston model: DataTraveler 2.0 
  size: 7.27 GiB 
Partition:
  ID-1: / size: 5.43 GiB used: 52.4 MiB (0.9%) fs: overlay source: ERR-102 
Sensors:
  System Temperatures: cpu: 43.0 C mobo: N/A gpu: nouveau temp: 43 C 
  Fan Speeds (RPM): cpu: 1800 
Info:
  Processes: 205 Uptime: 2m M
Laptop LENOVO model: 20CKCTO1WW (Intel HD5500/Nvidia 940M)
manjaro@manjaro-openbox Linux 5.5.7-1-MANJARO x86_64 19.0.2 Kyria
~ >>> inxi -F                                                                   
System:
  Host: manjaro-openbox Kernel: 5.5.7-1-MANJARO x86_64 bits: 64 
  Desktop: Openbox 3.6.1 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: LENOVO product: 20CKCTO1WW v: ThinkPad T550 
  serial: <root required> 
  Mobo: LENOVO model: 20CKCTO1WW v: SDK0E50512 STD serial: <root required> 
  UEFI: LENOVO v: N11ET48W (1.24 ) date: 03/20/2019 
Battery:
  ID-1: BAT0 charge: 30.8 Wh condition: 39.2/44.4 Wh (88%) 
  ID-2: BAT1 charge: 20.4 Wh condition: 66.9/71.3 Wh (94%) 
CPU:
  Topology: Dual Core model: Intel Core i7-5600U bits: 64 type: MT MCP 
  L2 cache: 4096 KiB 
  Speed: 798 MHz min/max: 500/3200 MHz Core speeds (MHz): 1: 798 2: 798 
  3: 798 4: 798 
Graphics:
  Device-1: Intel HD Graphics 5500 driver: i915 v: kernel 
  Device-2: NVIDIA GM108M [GeForce 940M] driver: nouveau v: kernel 
  Display: x11 server: X.Org 1.20.7 driver: intel,nouveau 
  unloaded: modesetting resolution: 2880x1620~60Hz 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:
  Device-1: Intel Broadwell-U Audio driver: snd_hda_intel 
  Device-2: Intel Wildcat Point-LP High Definition Audio 
  driver: snd_hda_intel 
  Sound Server: ALSA v: k5.5.7-1-MANJARO 
Network:
  Device-1: Intel Ethernet I218-LM driver: e1000e 
  IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: 54:ee:75:52:4c:dc 
  Device-2: Intel Wireless 7265 driver: iwlwifi 
  IF: wlp3s0 state: down mac: f2:f1:54:28:6e:15 
  IF-ID-1: wwp0s20u4 state: down mac: c6:80:53:01:0b:d6 
Drives:
  Local Storage: total: 484.21 GiB used: 52.4 MiB (0.0%) 
  ID-1: /dev/sda vendor: Samsung model: MZ7LN512HCHP-000L1 size: 476.94 GiB 
  ID-2: /dev/sdb type: USB vendor: Kingston model: DataTraveler 2.0 
  size: 7.27 GiB 
Partition:
  ID-1: / size: 11.64 GiB used: 52.4 MiB (0.4%) fs: overlay source: ERR-102 
Sensors:
  System Temperatures: cpu: 32.0 C mobo: 0.0 C 
  Fan Speeds (RPM): cpu: 0 
Info:
  Processes: 163 Uptime: N/A Memory: 15.52 GiB used: 461.3 MiB (2.9%) 
  Shell: zsh inxi: 3.0.37 

Workstation LENOVO model: 30A3001FGE (Intel Xeon)
manjaro@manjaro-openbox Linux 5.5.7-1-MANJARO x86_64 19.0.2 Kyria
~ >>> inxi -F                                                                   
System:
  Host: manjaro-openbox Kernel: 5.5.7-1-MANJARO x86_64 bits: 64 
  Desktop: Openbox 3.6.1 Distro: Manjaro Linux 
Machine:
  Type: Desktop System: LENOVO product: 30A3001FGE v: ThinkStation E32 
  serial: <root required> 
  Mobo: LENOVO model: SHARKBAY v: 0B98401 PRO serial: <root required> 
  UEFI: LENOVO v: FBKTDBAUS date: 12/24/2019 
CPU:
  Topology: Quad Core model: Intel Core i5-4570 bits: 64 type: MCP 
  L2 cache: 6144 KiB 
  Speed: 998 MHz min/max: 800/3600 MHz Core speeds (MHz): 1: 923 2: 968 
  3: 904 4: 927 
Graphics:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics 
  driver: i915 v: kernel 
  Display: x11 server: X.Org 1.20.7 driver: intel unloaded: modesetting 
  resolution: 1920x1080~60Hz, 1920x1080~60Hz 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio 
  driver: snd_hda_intel 
  Device-2: Intel 8 Series/C220 Series High Definition Audio 
  driver: snd_hda_intel 
  Device-3: Logitech HD Webcam C525 type: USB driver: snd-usb-audio,uvcvideo 
  Sound Server: ALSA v: k5.5.7-1-MANJARO 
Network:
  Device-1: Intel Ethernet I217-LM driver: e1000e 
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: fc:4d:d4:f4:44:73 
Drives:
  Local Storage: total: 2.06 TiB used: 52.4 MiB (0.0%) 
  ID-1: /dev/sda vendor: Samsung model: SSD 840 EVO 500GB mSATA 
  size: 465.76 GiB 
  ID-2: /dev/sdb vendor: Samsung model: SSD 840 PRO Series size: 476.94 GiB 
  ID-3: /dev/sdc vendor: Kingston model: SHPM2280P2H 480G size: 447.13 GiB 
  ID-4: /dev/sdd vendor: A-Data model: SX300 size: 238.47 GiB 
  ID-5: /dev/sde vendor: A-Data model: SX300 size: 238.47 GiB 
  ID-6: /dev/sdf vendor: Samsung model: SSD 840 EVO 250GB mSATA 
  size: 232.89 GiB 
  ID-7: /dev/sdl type: USB vendor: Kingston model: DataTraveler 2.0 
  size: 7.27 GiB 
Partition:
  ID-1: / size: 22.73 GiB used: 52.4 MiB (0.2%) fs: overlay source: ERR-102 
Sensors:
  System Temperatures: cpu: 36.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 190 Uptime: N/A Memory: 30.31 GiB used: 418.3 MiB (1.3%) 
  Shell: zsh inxi: 3.0.37
Workstation CB Intel model: DX58SO (Nvidia GT 640)
manjaro@manjaro-openbox Linux 5.5.7-1-MANJARO x86_64 19.0.2 Kyria
~ >>> inxi -F                                                                   
System:
  Host: manjaro-openbox Kernel: 5.5.7-1-MANJARO x86_64 bits: 64 
  Desktop: Openbox 3.6.1 Distro: Manjaro Linux 
Machine:
  Type: Unknown Mobo: Intel model: DX58SO v: AAE29331-702 
  serial: <root required> BIOS: Intel v: SOX5810J.86A.5600.2013.0729.2250 
  date: 07/29/2013 
CPU:
  Topology: Quad Core model: Intel Core i7 950 bits: 64 type: MT MCP 
  L2 cache: 8192 KiB 
  Speed: 1622 MHz min/max: 1596/3060 MHz Core speeds (MHz): 1: 1624 2: 1622 
  3: 1645 4: 1694 5: 1621 6: 1622 7: 1622 8: 1623 
Graphics:
  Device-1: NVIDIA GK208 [GeForce GT 640 Rev. 2] driver: nouveau v: kernel 
  Display: x11 server: X.Org 1.20.7 driver: nouveau unloaded: modesetting 
  resolution: 1920x1080~60Hz 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:
  Device-1: NVIDIA GK208 HDMI/DP Audio driver: snd_hda_intel 
  Sound Server: ALSA v: k5.5.7-1-MANJARO 
Network:
  Device-1: Intel 82567LM-2 Gigabit Network driver: e1000e 
  IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: 70:71:bc:17:f8:87 
Drives:
  Local Storage: total: 2.40 TiB used: 52.4 MiB (0.0%) 
  ID-1: /dev/sda vendor: Kingston model: SSDNow V Series 128GB 
  size: 119.24 GiB 
  ID-2: /dev/sdb vendor: Seagate model: ST31000528AS size: 931.51 GiB 
  ID-3: /dev/sdc vendor: Samsung model: HD154UI size: 1.36 TiB 
  ID-4: /dev/sdh type: USB vendor: Kingston model: DataTraveler 2.0 
  size: 7.27 GiB 
Partition:
  ID-1: / size: 11.72 GiB used: 52.4 MiB (0.4%) fs: overlay source: ERR-102 
Sensors:
  System Temperatures: cpu: 37.0 C mobo: N/A gpu: nouveau temp: 45 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 201 Uptime: 2m Memory: 15.63 GiB used: 506.0 MiB (3.2%) 
  Shell: zsh inxi: 3.0.37 
Laptop LENOVO model: 80QL (Intel HD515)
manjaro@manjaro-openbox Linux 5.5.7-1-MANJARO x86_64 19.0.2 Kyria
~ >>> inxi -F                                                                   
System:
  Host: manjaro-openbox Kernel: 5.5.7-1-MANJARO x86_64 bits: 64 
  Desktop: Openbox 3.6.1 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: LENOVO product: 80QL v: Lenovo ideapad MIIX 700-12ISK 
  serial: <root required> 
  Mobo: LENOVO model: Chelsea v: SDK0J40709WIN serial: <root required> 
  UEFI: LENOVO v: DFCN52WW date: 12/13/2016 
Battery:
  ID-1: BAT0 charge: 0.0 Wh condition: 36.0/40.6 Wh (89%) 
CPU:
  Topology: Dual Core model: Intel Core m7-6Y75 bits: 64 type: MT MCP 
  L2 cache: 4096 KiB 
  Speed: 500 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 500 2: 500 
  3: 500 4: 500 
Graphics:
  Device-1: Intel HD Graphics 515 driver: i915 v: kernel 
  Display: x11 server: X.Org 1.20.7 driver: intel unloaded: modesetting 
  resolution: 2160x1440~60Hz 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:
  Device-1: Intel Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Imaging 
  Unit 
  driver: ipu3-imgu 
  Device-2: Intel driver: ipu3-cio2 
  Device-3: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel 
  Sound Server: ALSA v: k5.5.7-1-MANJARO 
Network:
  Device-1: Intel Wireless 8260 driver: iwlwifi 
  IF: wlp1s0 state: down mac: 1e:de:7a:32:1d:11 
  Device-2: Huawei ME906s LTE M.2 Module type: USB 
  driver: cdc_ether,option,option1 
  IF: wwp0s20f0u9c2 state: down mac: 02:1e:10:1f:00:00 
Drives:
  Local Storage: total: 245.75 GiB used: 52.4 MiB (0.0%) 
  ID-1: /dev/sda vendor: Samsung model: MZNLN256HCHP-000L2 size: 238.47 GiB 
  ID-2: /dev/sdb type: USB vendor: Kingston model: DataTraveler 2.0 
  size: 7.27 GiB 
Partition:
  ID-1: / size: 5.76 GiB used: 52.4 MiB (0.9%) fs: overlay source: ERR-102 
Sensors:
  System Temperatures: cpu: 37.5 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 155 Uptime: N/A Memory: 7.69 GiB used: 735.8 MiB (9.3%) 
  Shell: zsh inxi: 3.0.37

So without further comments I present the latest:

Manjaro Openbox Community Edition

NB: Manjaro is default configured to use silent boot and will display the manufacturer logo (if available) while booting an EFI system. A virtual machine often uses BIOS/MBR which cannot display the logo.

dl-button

13 Likes

I tried the iso inside a virtualbox, and I have 2 comments:

  1. The calamares screen is too big and cannot be de-maximize.
  2. After the installation finished successfuly, I tried to boot into the new system, and all I got was a black screen. No boot, nothing.
    I tried to install grub, thinking this might be the problem, but still nothing.

Thank you for your comment.

The Calamares window is fullscreen - it is a choice and this is due to some quirks when booting a VM which loads at 800x600 - but it should not present a big issue - of course - the bigger the screen - and using a 4K monitor :slight_smile: .

The ISO do not contain any non-free drivers - due to the unified grub for Manjaro editions it is still possible to select non-free - that said - I have only a few different hardware types - and they all install as expected.

This is disappointing, and this post is personal.
I chose Manjaro in the beginning because it had an Openbox edition. I am not an expert. I expect the system to work for me, not the other way.

I always use virtual machine to test a distro or edition before daring to install them on an actual hardware.

As it looks now, either I need to learn a great deal about drivers, or find some edition that doesn't have this constrain.

I believe Manjaro editions should all be friendly to non-experts, even if long-time users, not only the full desktop editions.

It is one thing to slim down applications, and another to take away a basic part that is required to run the system.

I do hope you'll reconsider this decision.

1 Like

My opinion is that we should have the ISO contain both the non-free and free drivers, because not all NVIDIA GPU users can use their GPUs with the free drivers.

1 Like

my goodness. we should all be grateful for the dedication and commitment maintainers have put into the free community editions.
I started using Linux 6 months ago and chose Manjaro specifically because it was a rolling distribution and expects its members to support each other and continuous learning.
from what I can tell open box was due for an update and design decisions will never please everyone or work on hardware all over the planet "out of the box"
I am very new to the Linux world, but it strikes me as odd one would choose Manjaro and then protest the need to install packages or drives to suit one's taste.
thank you maintainers for all your hard work !

5 Likes

That is quite a long post considering you don't actually say what it is you think is missing. Are you referring to the omission of the non-free drivers? If so, virtualbox shouldn't require any non-free drivers, did you try using the VBOXSVGA graphics adapter in virtualbox?

Some nvidia hardware is painfully difficult to boot on nouveau drivers so you are definitely raising the difficulty level for some users with that decision.

Is there a benefit in not including the non-free drivers?

Because in this current situation, it means that the person might not even be able to boot in to use the LiveISO to install.

I didn't know that - the intention was not to raise the difficulty that high.

My hope is that the issues stemming from choosing the non-free graphics would be removed if only the free drivers were included.

I have intentionally left out drivers and software which creates the most issues for users booting Manjaro ISO. Packages deliberately left out

  1. tlp
  2. proprietary drivers

I have a range of different hardware to test from and I will reconsider the inclusion of non-free drivers.

Apologies I don't understand.

Aren't people who use non free GPU drivers people who don't have a choice?

I am quite certain that most systems will boot just fine using the free drivers - which are all available on the ISO.

Of cource some edge cases will need extra work - it has always been so - and some systems will work better with the proprietary driver.

What's wrong with simply providing the drivers on the ISO, and having it be an option in grub to boot using free or non-free like on the Manjaro ISOs?

There is absolutely nothing wrong with that.

This is a design decision - cutting off several 100MB from the ISO.

The two topmost issues with booting Manjaro ISOs is

  • tlp
  • proprietary drivers

I am simply trying to avoid those initial issues.

All my testcases works OOB with the free drivers - two of those are having dual graphics Intel/Nvidia and one only Nvidia - so IMO the drivers are - initially not needed - but as Manjaro Settings Manager and mhwd is available - it should be a piece of cake to install them afterwards if so desired.

Based on the feed back - I am reconsidering.

I have rebuild and tested the ISO countless times - every time in VirtualBox - I don't know what happened for you.

I have added seven (7) bare metal test cases - all using the ISO from the download page.

General requests has been made to include the proprietary NVIDIA drivers on the ISO - so am in the process of adding an ISO which contains these drivers.

Not an option on my 5.2 virtualbox. I haven't upgrade to 6.

Exactly why I posted. That is my situation. black/ blank screen after installing the live ISO.

Perhaps it's the vbox 5.2 that is the reason.
I don't upgrade to higher vbox before I absolutely must.
It's because of previous years experience.

I think you are correct. When you install Manjaro in VirtualBox the guest related packages are installed by mhwd.

As these packages are all using the latest VirtualBox - this could make your VM dysfunctional - even non-functional.

This is very uncommon:
I tried to start the new installed VM again, and this time waited.

It took about 12 seconds before anything was displayed on screen.
Then the system started as usual.

Always until now with any distro or with any Windows version I installed, the boot will start immediately.

On 2nd thought, if this was deliberately made, to hide the initial messages, maybe you should consider some info to let the user something is happening.

So, it was false alarm and I am sorry for it.

The Manjaro boot is hidden by default. You can change that by editing the /etc/default/grub and remove the kernel args which controls it.

Save and generate grub config.

The kernel bootsplash only works when system is booted using EFI. The default on VirtualBox is using MBR so there is the black screen - until you hit the display manager.

Exactly what happened. My point is, if there was some indication, this whole misunderstanding would not have happened.
Once I thought that was the cause, I could look into it, but it took a full thread before that happened....
Anyway, thanks.

Forum kindly sponsored by