Latest Update Killed the System-26th Feb

Just installed the latest update 10 minutes ago. All went OK. I rebooted & now the system hangs at "Started TLP system startup/shutdown".

It does give errors but I can't figure out how to pause the startup to read them.

Any clues on what to try next?

Switch to a text console with CTRL-ALT-F2, log in as normal, then run

sudo pacman-mirrors -f 3
sudo pacman -Syyu

Also, there is no 26th February update. I assume you're talking about

There's also this item in the Known Issues post:

Yep that's the one. Already Monday over here. :sunglasses:

Will give it a go & see what happens.

Finally figured out where to hit Ctrl+alt+f2.

When I do it changes to the login but only for a split second. It then goes straight back to “Started TLP system startup/shutdown”.

Am I missing something?

Got to text mode using this>

Ctrl+alt+f2 would not do it.

Ran sudo pacman-mirrors -f 3
sudo pacman -Syyu

Rebooted. Same issue. Stuck at “Started TLP system startup/shutdown”.

Tried again. Noticed that after -Syyu I got a warning. Python-pyparted 3.11.1-1 newer than 3.10.7-2.
Nothing was updated.

Rebooted. Still no go.

Hmmmmmmm. On unstable python-pyparted is only version 3.10.7-2. Have you added an Arch (or other third-party) repo by any chance?


sudo pacman -Syyuu

to bring your packages back in line with the Manjaro repos.

Still no go. Got rid of the error though. Still nothing to update.

I did have extra added to pacman.conf but I have edited all changes back to default.

If this is too much of a hassle I can load a backup, edit the pacman.conf & try updating again.

Restored the latest backup I had. Booted up OK. Ran the update again. Same problem.

I have no idea what's going on.

The only added repo is arch for yaourt.

Also at the start of updating I get a warning about Python-pyparted 3.11.1-1 being in the update.

Yaourt is in the manjaro repo's. Shouldn't be needed!

Can't keep up with the changes. Was in manjaro repo, got taken out, now it's back in.

I'll see what happens reinstalling it using the right way. :thinking:

edit: Removed arch from pacman.conf. Removed yaourt from the system. Still get the warning about Python-pyparted 3.11.1-1.

yaourt was never removed. It only stopped being included in the new .iso's.

You either changed branches or or got it from upstream or something similar. If you want to get back than just
sudo pacman -Syyuu
(this should not be randomly used, but should be used if a package is newer than in repos)

Also to note - You're allowed to have yaourt. It shouldnt break anything. Mixing foreign repos on the other hand could.

Was thinking about that at a later time. Have now just done it & Python-pyparted 3.11.1-1 is getting downgraded.

I ran -Syyuu earlier today & all it did was downgrade Python. This time it downloading an update also. Will see what happens when I reboot.

if it gets stuck on tlp them try masking its service from a terminal using sudo systemctl mask tlp-service if that doesnt work remove tlp and try again

This is driving me nuts. Same thing.

I tried startx & got 'unable to connect to X server. server terminated with error (1)'.

I'm about to give up for today but will try that sudo systemctl mask tlp-service later.

Thanks for the help everyone.

The message says "Started TLP" therefore TLP has nothing to do with this, it's simply the last message that is displayed.

I suspect OP has broken the install by mixing Arch and Manjaro repos.

1 Like

Quite possibly that's the issue. Going to wipe & start again Thanks again everyone.

1 Like

Back up & running. Updated OK. Note to self......don't be a doofus.

Again thanks to everyone. :star_struck:

Found out where python-pyparted 3.11.1-1 is coming from.

yaourt mintstick-git

Aborted the install. Hopefully nothing has messed up.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by