Lenovo C940 - not hibernating/going hot in bag

Hello

I have Dual booted Manjaro for around 4 days, and have for the great majority been very happy. I have followed some of the instructions on https://wiki.archlinux.org/index.php/Lenovo_Yoga_c940 ie. removed xf86-video-intel package because of extremely pronounced graphical errors(difficulty selecting buttons), now completely gone and seemingly stable.

I have also installed OneDrive from the package-maneger: https://github.com/abraunegg/onedrive
OneDrive

My one big problem now is that something is going wrong when i suspend the laptop(maybe only when closing the lid) I have two times taken my laptop out of my bag very hot and running what seems like full tilt. Below I have pictures of my power settings but in general I have Hybrid sleep for battery and sleep for AC.

Also if someone has best practices for laptops when it comes to power management they are more than welcome to comment.

Here I have the output from inxi -Fx
inexi-Fx

And pictures of my power settings:
AC_power
Battery
Low

1 Like

have you read the arch wiki for you laptop?
https://wiki.archlinux.org/index.php/Lenovo_Yoga_c940

with that cpu i would give 5.5 a try, you can have more than 1 kernel installed at a time.

sudo mhwd-kernel -i linux55

reboot after and select the 5.5 kernel from the grub advanced options menu

2 Likes

also, make sure any external usb pointing device is turned off. they can trigger the laptop to wake again even with the lid closed.

2 Likes

Hey tanks dgit I'll try that and udpate the post in a days time to help others out with the C940, if it seems to solve it.

And thanks antikythera great to remember

Hello I have tried to use Kernel55 by using:

sudo mhwd-kernel -i linux55

and used Grub to select Kernel 5.5 kernel from advanced options menu

However I still have the hibernating problems and with kernel55 and I also have audio problems. I figured out that I had setup my hibernation file wrong so there was at least to things wrong. I had followed SwapFile and omitted step 04:

To make the change permanent open the /etc/fstab file and append the following line:
/swapfile swap swap defaults 0 0

Which I have done now. There still seems to be a problem every time the PC goes into hibernation where it can't turn on and the caps lock keeps blinking such that I have to turn it off and on to use it

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by