Lenovo Ideapad 5 14are05 suspend and Backlight do not function correctly.

Hello,
I've been using the lenovo ideapad 5 14are05(Amd ryzen 4500u) for about a week now and support for it is seemingly perfect. Only to issues stand in the way.

The first and most jarring one is that the suspend function does not really work. I've looked it up on other Forums, but there wasn't a post about this. I have enough swap for hibernation but when I try to suspend/hibernate the laptop does not really get into that mode and is softlocked. I don't know how to give more information on this, if you know how I could provide more information, tell me.

The second issue is, that the backlight does not function correctly. The archwiki article on the 15" model does also list this problem but it wasn't fiexd after I tried the mainline kernel.(I've used a software fix through a gnome extension to change the alpha channel).

Any help on this would be massively appreciated

I also have similar suspend problem. If I manually suspend for like 1 minute, it can resume properly. But if I close the laptop lid and let it suspend for like 10 minutes, when I reopen the laptop lid, the screen will still in black and have no response.

My machine is Lenovo ideapad 5 14" (with AMD 4600u). The BIOS version is DTCN18WW, and I have updated kernel to 5.7.7. Originally I use Pop OS 20.04 (based on Ubuntu), but I then try Manjaro Gnome, the suspend issue is still there.

After checking cat /sys/power/mem_sleep , it shows that I'm in [s2idle]. I think this is the default S0 suspend mode (S0iX modern standy mode). From my past experience with Dell XPS laptop (which also has this kind of suspend no response when resume issue), it seems that I need to change to suspend to memory mode [s2idle] deep (which is S3 deep suspend). But after I edit grub file with mem_sleep_default=deep , it still remains unchanged in [s2idle] mode.

Then I check dmesg | grep ACPI | grep supports , it shows [ 0.387996] ACPI: (supports S0 S4 S5) . It seems that there is no S3 suspend (suspend to memory) support available. So maybe we need to enable S3 in ACPI DSTS setting. I found that some Lenovo X1 Carbon users have done the ACPI patch to fix the same S3 suspend problem (source), it is done by editing ACPI DSDT table.

I have check this machine's ACPI DSDT, seems that it does include S3 suspend mode in Lenovo's original setting. But for some reasons, the S3 just doesn't show up in support suspend mode list. Maybe we can try to patch a few line of code to get S3 works.

But my knowledge to ACPI patching is limited, I have tried several modification and just can't get it work. So maybe someone can help this part to patch the ACPI.

Summarize the potential solution to suspend problem:

  1. Keep using [s2idle]S0iX modern standby mode, and try to fix the "no response while resume" problem.
  2. Try to patch ACPI DSTS table, so that we can enable [s2idle] deep S3 suspend to memory mode.
  3. Try to use hibernate option rather than suspend, since machine does support S4 suspend to disk mode.

Well this is a great step in the right direction. My knowledge on linux is sadly limited. I will update if I find some new sources or anything else.

After switching to the testing branch and choosing kernel 5.7.7-1 brightness now works. I have no Idea why it didn't work on mainline but sure it works now xD

The kernel opens up a new problem. I have to switch to a tty and back to get gdm to pop up. Also the machine randomly freezes up after some time, so I switched back to 5.6.x

I will test if suspend/hibernation now works.

Is the touchpad working for both of you? I'm still waiting for my machine to be shipped, just asking because several users have reported that it's randomly not detected after a reboot.

Touchpad is working perfectly. People with the 15" model have that Problem(iirc)

I have the 17" model and I also experienced the backlight brightness issue until 5.7.7. That's fixed now but I still have the problem with GDM failing to come up on startup. I got around this by installing LightDM. Suspend works fine and touchpad works fine.

Lenovo seems to update the BIOS DTCN20WW (V1.06) for ideapad 5 14" today. On Lenovo's website, they state that this BIOS updates AMD PI 1004 patch D to fix S0i3 issue. To my knowledge, the S0i3 is the suspend to idle mode.

I update to this new version BIOS, fresh install Linux, then update to the newest stable kernel 5.7.7. It seems that this BIOS patch doesn't fully fix my suspend problems. I still encounter some "no response while trying to wake from suspend".

After several brief tests, my current suspend situations are:

  • Manually suspend -> do no close lid -> wait for 10 minutes -> press keyboard -> lock screen shows up and able to type login password -> successfully resume
  • Manually suspend -> close lid -> wait for 10 minutes -> reopen the lid -> still black screen -> press keyboard -> still no response -> unable to resume from suspend and forced to shut down the power
  • Close the lid to enter suspend -> wait for 10 minutes -> reopen the lid -> show login screen -> press keyboard -> no response -> able to move the cursor, but cursor turns into a square-ish graphics broken shape -> can't click anything -> unable to resume from suspend and forced to shut down the power

I am still wondering why there are differences between these suspend situations. I will test these different suspend circumstances for longer period (like overnight), and see what are the results.

Are there any good ways of flashing a new BIOS without deleting my current Install?

I don't know if there is any way to flash BIOS directly, since the BIOS file that Lenovo provided is the .exe file.

Also, I would like to update my further experiment on suspend. With this new DTCN20WW BIOS and kernel 5.7.8, I have following result:

  • Manually suspend -> do no close lid -> wait overnight -> press keyboard -> lock screen shows up and able to type login password -> successfully resume
  • Manually suspend -> close lid -> wait overnight -> show login screen -> press keyboard -> no response -> able to move the cursor, but cursor turns into a graphics broken shape -> can't click anything -> can't get into TTY by CTRL + ALT + F3 -> unable to resume from suspend and forced to shut down the power

After browsing more articles, I found several people with same laptop all have such suspend issue. One of them have resorted to hibernation. Although hibernation might function correctly, I still want to be able to utilize the normal suspend mode (no matter suspend to idle or suspend to memory).

Did you find any improvement in suspend after updating the BIOS or Kernel? I have tried the newest 5.8-rc5 and more different settings, but still can't fix the suspend problem.

I also found that some users of HP Envy X360 with 4500u also have same suspend issue. They are missing the S3 suspend to memory mode in their ACPI DSDT table. Which seems that it may be a common issue for these new laptop Ryzen processors.

Closing the lid seems to immediately causing problems with suspend but not closing the lid works fine

I've got my Ideapad 14ARE05 properly going into S3 sleep now. The same fiddle with ACPI tables that has worked on other laptops works on mine too.

I did a write up over on Reddit: https://www.reddit.com/r/linuxhardware/comments/i28nm5/ideapad_14are05_s3_sleep_fix/

Posting a link here because this was one of the threads that came up on Google when I was searching for a solution.

Closing the lid doesn't cause any issues when you're in S3 sleep.

1 Like

As I am not that technical, I have to ask. Is it possible to create a simple script to do this?

Well, kind of.

A script would need to handle all the different ways people might have their distro configured. That's why my walkthrough pretty much says "figure out this step for yourself" at step 7 when it comes to getting your bootloader to read the cpio archive.

I followed the instructions on the arch wiki (in the entry for the 14ARE05), which seem to work well for my Manjaro installation.

A solution is here:

Type this command to install the needed programs.

sudo pacman -Syu acpica cpio

First create a new directory and dump the acpi files.

 mkdir ~/acpi/
 cd ~/acpi/
 sudo acpidump -b

The next command will de-compile some files, so you can apply the patch.

iasl -e *.dat -d dsdt.dat

You will then need to download this file. If only text shows up for you, you should copy the text and safe the file as dsdt.patch.
The next step is to apply the patch.

patch -p1 < dsdt.patch

You will now need to compile the files again.

iasl -ve -tc dsdt.dsl

You need to make a cpio archive.

mkdir -p kernel/firmware/acpi
cp dsdt.aml kernel/firmware/acpi
find kernel | cpio -H newc --create > acpi_override

and then copy it to boot.

sudo cp acpi_override /boot

For this patch to work you will need to edit your grub config
/etc/default/grub and add the following lines

GRUB_CMDLINE_LINUX_DEFAULT="mem_sleep_default=deep"
GRUB_EARLY_INITRD_LINUX_CUSTOM=acpi_override

the last step is to update the GRUB config.

sudo update-grub

Reboot and check with this command if it worked:

dmesg | grep ACPI | grep supports

The command output should look like the following:

[    0.195933] ACPI: (supports S0 S3 S4 S5)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by