Lenovo P52 hybrid graphics can't setup Nvidia/external graphics

Hello everybody!
I'm trying very hard to set up hybrid graphics on my Lenovo P52 with a Quadro P1000 (HDMI is wired directly to the graphics card as far as I read); I got it running once (Kernel 4.14, nvdia hybrid graphics driver 390xx bumblebee, but with Askannz' optimus-manager as far as I remember) but had no reason to use it a lot. Now, I got the necessity to use my GPU for an external Display and later for CUDA as well, so I realized, after updating Manjaro to version 20 and graphics driver to video-hybrid-intel-nvidia-440xx-prime that I am not able to use my GPU anymore. The problem seems to be that, no matter what I do, graphics driver with inxi -G````stays N/A```. I tried quite hard for days to get my setup working, so did i follow (or only read, if they are outdated) different tutorials, as
Guide: Install and configure optimus-manager for hybrid GPU setups or [HowTo] Set up PRIME with NVIDIA proprietary driver and another one which I cannot find anymore at the moment, showing all the oportunities for the hybrid setup, as only PRIME and optimus to mention. I tried different combinations of kernels and drivers to preclude any compatibility-issues, as: Kernels 4.14, 4.19, 5.5 and 5.6 with the drivers 390xx, 435xx and 440xx, always the hybrid-versions and every combination of each. Driver stays n/a, and prime-run, nvidia-smi and nvidia-setting not being able to load or communicate with the nvidia-driver.
I am aware that there might be some issue with gdm (-prime) or some config-files I missed (in directories /etc/X11/ and /etc/X11/xorg.config.d/but I can't see the forest for the trees at the moment.
After reboots i mainly get stuck in a black screen and have to reinstall the former drivers via tty to be able to start to graphics mode again.
My head is stuck but I want to and need to get this working. If I missed something, just advice me, any help is appreciated. I know that there are a lot of similar-reading issues in the forum and I think I read the most of them but nothing could help me.
Thank you very much in advance for your help.

System:
  Host: H Kernel: 5.5.19-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.3.0 Desktop: Gnome 3.36.2 wm: gnome-shell 
  dm: GDM 3.34.1, LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: LENOVO product: 20MAS03N00 v: ThinkPad P52 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: LENOVO model: 20MAS03N00 serial: <filter> UEFI: LENOVO 
  v: N2CET29W (1.12 ) date: 09/03/2018 
Battery:
  ID-1: BAT0 charge: 85.3 Wh condition: 85.3/90.0 Wh (95%) volts: 12.7/11.2 
  model: SMP 01AV496 type: Li-poly serial: <filter> status: Full cycles: 331 
CPU:
  Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP 
  arch: Kaby Lake rev: A L2 cache: 9216 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 52815 
  Speed: 900 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 900 2: 900 
  3: 900 4: 900 5: 900 6: 900 7: 900 8: 900 9: 900 10: 900 11: 900 12: 900 
Graphics:
  Device-1: Intel UHD Graphics 630 vendor: Lenovo driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:3e9b 
  Device-2: NVIDIA GP107GLM [Quadro P1000 Mobile] vendor: Lenovo driver: N/A 
  bus ID: 01:00.0 chip ID: 10de:1cbb 
  Display: wayland server: X.Org 1.20.8 driver: none alternate: nvidia 
  compositor: gnome-shell resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.0.6 
  direct render: Yes 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus ID: 00:1f.3 chip ID: 8086:a348 
  Sound Server: ALSA v: k5.5.19-1-MANJARO 
Network:
  Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi 
  v: kernel port: 3000 bus ID: 00:14.3 chip ID: 8086:a370 
  IF: wlp0s20f3 state: up mac: <filter> 
  Device-2: Intel Ethernet I219-V vendor: Lenovo driver: e1000e v: 3.2.6-k 
  port: efa0 bus ID: 00:1f.6 chip ID: 8086:15bc 
  IF: enp0s31f6 state: down mac: <filter> 
Drives:
  Local Storage: total: 238.47 GiB used: 104.00 GiB (43.6%) 
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB256HAHQ-000L7 
  size: 238.47 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 0L2QEXD7 
  scheme: GPT 
Partition:
  ID-1: / size: 28.71 GiB used: 26.22 GiB (91.3%) fs: ext4 
  dev: /dev/nvme0n1p5 
  ID-2: /home size: 86.01 GiB used: 77.78 GiB (90.4%) fs: ext4 
  dev: /dev/nvme0n1p6 
  ID-3: swap-1 size: 4.00 GiB used: 0 KiB (0.0%) fs: swap 
  dev: /dev/nvme0n1p7 
Sensors:
  System Temperatures: cpu: 41.0 C mobo: 34.0 C 
  Fan Speeds (RPM): cpu: 0 
Info:
  Processes: 325 Uptime: 26m Memory: 15.39 GiB used: 3.94 GiB (25.6%) 
  Init: systemd v: 245 Compilers: gcc: 9.3.0 clang: 10.0.0 Shell: bash 
  v: 5.0.16 running in: gnome-terminal inxi: 3.0.37 

I would start with different kernel 5.4 or 5.6 your 5.5 is end of life.
I have P50 for me the easiest solution was in BIOS choose only dGPU.

Hello VoDo,
thank you for your reply. I forgot that I tried 5.4, too, I now changed following your advice, but still no nividia...
As far as I understand, setting dGPU in BIOS means, that the GPU is always on, right? This was not an opportunity in terms of battery life since I work remotly quite often...
But thanks again!

Hello everyone.
Just an update:
Switching to dGPU in BIOS results in a black screen (tty possible) - I wanted to give it a try but expected it, since I'm seeming to not being able to install the NVIDIA-Driver properly....
I went on reading the forum but still couldn't find any solution...
Any further help or hint is very appreciated!

This is my cheatsheet how I did it, I use just NVIDIA not prime not bumblebee, there is no reason to use it because you need to restart anyway to have the effect of switching GPU's and it works and second day it does not. Remove everything related NVIDIA in mhwd.
Clear all the junk related to nvidia from etc/X11, there should be just Xinit folder and xorg.conf.d where only keyboard setting sits. This worked month ago when I got new SSD and was reinstalling and I have an older M1000M
/etc/modprobe.d get rid off what inside
/etc/modules-load.d get rid off what inside
Install nvidia 430 thru mhwd

After that check that in modules-load.d is a new file mhwd-gpu.conf

##

## Generated by mhwd - Manjaro Hardware Detection

##

nvidia

nvidia-drm

and in modprobe.d mhwd-gpu.conf

##

## Generated by mhwd - Manjaro Hardware Detection

##

blacklist nouveau

blacklist ttm

blacklist drm_kms_helper

blacklist drm

Thank you very much - but my problem remains since it is the nvidia driver which I can not install, so your otherwise very helpful cheetsheet can not help me.
I now tried installing only the nvidia - not the hybrid drivers, but no luck at all. Continuing reading I found out about some relationship with wayland, but I am not lucky with trying...

Did you install gdm-prime as shown on the guide? gdm is notoriously problematic with graphic switching. Also, check out optimus-manager and gdm logs from the moments when you tried switching - that is, if you still have optimus-manager installed.

I did install gdm-prime. At the moment I haven't installed optimus (neither -manager nor -switch) since I want to get installed and working nvidia-driver. I think, there are maybe some files messed up which avoid the drivers from being installed properly but I have no clue which files could be related...

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by