Libreoffice-Fresh 6.1.0-2 missing Menu Bar (File Edit View ...)

Editing /etc/profile.d/libreoffice-fresh.sh shows the following contents ...

# to force a certain look'n feel

#export SAL_USE_VCLPLUGIN=gen
#export SAL_USE_VCLPLUGIN=gtk3_kde5
#export SAL_USE_VCLPLUGIN=gtk
#export SAL_USE_VCLPLUGIN=gtk3

I first tried removing the # in front of the second line and restarted LibreOffice. The problem persists.

Then, I tried editing to ...

# to force a certain look'n feel

#export SAL_USE_VCLPLUGIN=gen
#export SAL_USE_VCLPLUGIN=gtk3_kde5
export SAL_USE_VCLPLUGIN=gtk
#export SAL_USE_VCLPLUGIN=gtk3

... and rebooted Manjaro. Still no File Edit View ..

image

right click a grab handle of any toolbar visible. then click customise toolbar. click on the Reset button and see if that restores the menus to view. It should do as they are a customisable option in that dialog window.

@anon71843593 Thanks for the directions. The customize and Reset doesn't have any impact.

Is there any chance that you have accidentally enabled the [ghastly, IMO] Global Menu? If yes, removing it from your KDE Settings should resolve this hassle for you. If no, though i don't expect this will help you [i suspect there's a deeper problem with your LO config], you might try activating the KDE Application Menu tool:

20180829_004

...after which...

20180829_001

...and thence...

20180829_003

Assuming this also does not help you, maybe you'll have to solve this the ugly way by nuking your current LO config & thus creating a virgin one?

1 Like

@Kadee the Global Menu isn't something that I heard of, and I don't think I had set it.

Your suggestion to activate the KDE Application Menu tool is a temporary workaround, so I can at least work with LibreOffice until a longer-term fix resolves.

It's taken me a few steps to figure out how to navigate to the screenshots you've sent.

The Look and Feel that I have set is Breeze. (Under the Manjaro default, was it originally set to Breath?)
image

I hadn't changed the Widget Style for Breeze.
image

The Window Decoration options that I've got are for Breeze, Oxygen and Plastrik.
image

Selecting on the Buttons pane, the Application Menu isn't in the Titlebar.
image

I can drag-and-drop the Application Menu into the Titlebar.
image

This now gives me an Application Menu in the Titlebar of LibreOffice.
image

Thanks for that guidance. I had been rebooting into Kubuntu 18.04 for a day. With this workaround, I can at least stay in Manjaro KDE.

Since I have a Asus M5A88-N tower beside my Thinkpad X230T laptop, I've done the most recent updates there. The LibreOffice problem of not showing the Application Menu isn't there, so there must be some deeply-hidden incompatibility on the Thinkpad.

After a week of working in Manjaro KDE with LibreOffice, I've found not having the application menu immediately visible to be a major productivity hit. For now, I'm changing over to the Kubuntu multi-boot option, so I can get work done.

If upgrades don't resolve this soon, what are the options? I have a shared /home partition across four Linux distros, so the problem must be a configuration that is either on, or impacts, the Manjaro partition. If I do a reinstall of Manjaro KDE without formatting /home, would the problem still persist?

As i suggested earlier…

I hope you mean with different users/folders.
If you use the same user/folder on several distros, especially if mixed Arch-Debian, you have high probability of a conflict..
I suggest you create a new user in Manjaro and try again.

1 Like

Does this mean more than an uninstall and reinstall? Should I try installing libreoffice-still (which I presume means that libreoffice-fresh would be removed in conflict?

Or are you suggesting that I manually delete the .config files off /home? (Or both).

I said nothing about uninstalling anything... nor LO-Still, nor all your personal config files. All i suggested was directed specifically & only at your current config files for LO.

Find your LO user profile path. If you don't already know it, look in LO like this:

20180907_001

Then, depending on your preference for command line or GUI tool [eg, Dolphin], either delete or [probably better] rename say the LO directory within, or the 4 directory, or the user directory [with LO closed of course]. Then relaunch LO, which will automagically create a new virgin suite of LO config directories & files. If LO is now good for you, then you had some error/corruption in your original config. If LO is still bad for you, the root cause lies elsewhere, hence more diagnostics would be needed.

I'm simply suggesting a logical measured step by step approach to try to uncover where the root cause lies.

EDIT:
When i wrote my initial iteration of this reply i had not noticed either your

nor the very salient advice by @AgentS Libreoffice-Fresh 6.1.0-2 missing Menu Bar (File Edit View ...), which i thoroughly endorse. Please can you action that, otherwise we might be chasing shadows. For the duration of the ongoing diagnostics, i also suggest that you return /etc/profile.d/libreoffice-fresh.sh to default, ie, with each option commented-out to deactivate. That might muck up your decorations, but will ensure the cause of the missing menu bar is not one of those options [as i'd discovered & reported in that earlier thread post you referenced in your OP].

While in Kubuntu, I followed the directions to ...

... and moved the 4 directory out, leaving .config/libreoffice/ empty. I rebooted into Manjaro KDE, and I still don't have an application menu.

Yes, I had reset those before.

In Manjaro, I created a new user "guest". I logged out of my usual desktop, and logged in as guest. This worked! The application menu bar is back.

Unfortunately, this diagnosis now interferes with the way that I work, since the option to use the same /home across multiple distros allows me to work relatively uninterrupted when I hit a bug in one environment that isn't in another.

So, I then logged out of guest, back into my main user ID. From the fix before ...

... I dragged that feature out. Then, starting LibreOffice again, I ran into an error:

Error loading BASIC of document file:///home/daviding/.config/libreoffice/4/user/basic/Standard/script.xlb/:
General Error.
General input/output error.

I renamed the 4 directory in .config/libreoffice and restarted. The error message is now gone, and the application menu bar is still missing.

So, we're one step ahead in diagnosis, but using the same /home across multiple distros is the way I work. I'm not having an application menu bar problem in anything other than LibreOffice. I've been using LibreOffice in Kubuntu 18.04 for a week. Is this something that is buried in LibreOffice-Fresh? Should I try LibreOffice-Still instead?

But not how things work.
Can you provide a link or a paper book title and page, where it is said this is a viable way of inter-operating between distros, even DEs?

I'm sorry but i have an antithetical opinion on this. I claim zero personal expertise, so will gladly stand corrected by more knowledgeable Manjaroos, but as i recollect, over the years i've read many webpages, posts & opinions on the question of unique /home per distro in a multiboot environment, vs single /home shared across all the distros. AFAIR a preponderance of opinion sided with NOT sharing a common /home... but instead if desired, sharing a common /Data partition. The rationale for this always made sense to me... different distros [even if all one DE, but only compounded when there's other DEs too] will almost certainly NOT use identical versions of individual programs & all their dependencies, NOR all the DE's "system" packages [eg KDE Frameworks, Applications...]. Yet having a common /home presupposes-away all those latent conflicts & incompatibilities [ie, one distro's &/or program's user config files might be incompatible with what another distro expects those files to be]. IMO the probable outcome of this mish-mash arrangement is distros &/or individual programs misbehaving in weird ways that resist "standard" troubleshooting diagnostics. In other words, your way that I work might well result in none of us here being able to help you.

In an earlier reply i asked you about Global Menu, & your reply was ambiguous. I'd just like one more opportunity to positively rule out any chance that you might have it activated, even without you meaning to [at least one time i installed Manjaro KDE, i was surprised to discover that the GM was active "out of the box"... i had to specifically disable/remove it]. If you launch, say, Kate, or Konsole, are their Menu Bars present within their windows [as opposed to being transplanted to the Plasma Panel]?

Go ahead & try LO-Still if you wish. I suspect the problem will continue, but seeing is believing. Just be aware that, afaik, installing Still will remove Fresh.

Yes, I had said ...

You've now asked a clearer diagnostic question.

This helps. There is no menu bar in Kate. There is no menu bar in Konsole.

When I was looking into question before, I had seen " How to Activate the Global Menu in Kde Plasma 5.9" | Francesco Mondello | Feb. 5, 2017 at http://fasterland.net/activate-global-menu-kde-plasma-5-9.html . I went looking for "The Widget Style panel" that he had posted, that seems to be under "Widget Style and Behaviour" ... "Fine Tuning", and looks like ...

On my installation, I don't see the Menubar pane that Francesco shows. Mine looks like ...
image

Wondering if it's the Widget style I'm using, the tab on Applications is set to Breeze.
image

Further searching turns up a "Menubar style option missing from Widget style?" started around March 2018 at https://www.reddit.com/r/kde/comments/844rwn/menubar_style_option_missing_from_widget_style/ .

So, my question, now, is: where is the screen where I set the Menubar style?

I don't either. Have you seen that in the new user's Settings?
Distros create new configuration setups, on will.
Have you seen this setting in Manjaro?
If yes, then create a bug report on Manjaro Gitlab .
Your original problem is solved and now you start a complain of Manjaro not having a setting that another distro has.
Is this what you want to do?

Ah, thanks for the passive-aggressive tone. It's always pleasant receiving implied insults whilst earnestly endeavouring to assist someone.

Nor do i in mine [& i do not use Breeze, ugh]. Curious, I checked my...

  • Neon VM [Plasma 5.13.4] - not present.
  • KaOS VM [Plasma 5.13.4] - not present.
  • openSUSE Tumbleweed VM [Plasma 5.13.4] - not present.
  • openSUSE Leap 42.3 VM [Plasma 5.8.7] - Yes it IS present.
  • Maui VM [Plasma 5.10.2] - Yes it IS present.
  • KFedora 26 VM [Plasma 5.10.5] - Yes it IS present.
  • Kubuntu 16.04 VM [Plasma 5.8.7] - not present.
  • Mint 18.3 VM [Plasma 5.8.9] - not present.

That is significant. I suspect that you still have the Application Menu widget activated, judging by all your latest pics, eg:
20180912_001
...which if true explains the missing menu bar in those Qt apps. Please remove the AM again in Plasma Settings, recheck Konsole & Kate... then recheck LO [which i still suspect will be no good, given i still suspect your root cause problem is systemic from the shared /home]. Let's not overlook the fact that you yourself have already proven implicitly your standard User profile is corrupt, via creating your virgin new user “guest”:

I know you don't want to hear it, but that important discovery is consistent with what @AgentS & i have been saying...

I'm sorry if I stated the progress we've been making in a passive-aggressive way. I do appreciate the responsiveness you've been giving in the responses. There's been multiple solution threads going along different directions, and your most recent question was a cognitive jump for me.

Your pointing out the missing Application Menu in Konsole and Kate wasn't something that I had noticed earlier. The conclusion that this brings -- which may have been clear to you, but wasn't to me -- is that the problem is not with LibreOffice per se, but something else.

The Application Menu that appears in the screenshots that I took were the result of having made the changes in Application Style ... Window Decorations ... Buttons ... dragging and dropping "Application menu" into Titlebar, as you had directed. In removing that (back to the original state so that it's not in the Titlebar), neither Kate nor Konsole have an Application Menu. And yes, starting LibreOffice now still doesn't have an Application Menu.

On my bringing up the example from Francesco, I trying to respond to your question about the Global Menu. I thought that the Menubar pane on Francesco's KDE setting was where the Global Menu gets set. If I'm wrong, then I really still don't understand where the GlobaLMenu gets set. Since Manjaro has a rolling release, and I didn't have this problem in my system from April through July, I thought that location of this Menubar style setting might be something that had moved to another place in KDE settings in the August update/upgrade.

I now don't understand what you mean by the "standard User profile". When we were dealing with LibreOffice only, I thought that you meant the "4" directory as the User profile. Now, it seems like we're dealing with a bigger issue.

My tone may be one of frustration, because I've really liked Manjaro KDE, since I switched to it from Kubuntu, a few months ago. I'm working on a deadline where I'm using LibreOffice, so I've had to resort back to Kubuntu in order to get work done. I'm now booting into Manjaro ONLY to do the diagnosis and changes in this thread.

I appreciate that a shared /home partition has risks. The "real" data for my work isn't on the /home partition (which is an mSATA SSD), but actually on an NFTS-mounted SATA partition that is physically separate. The standard installed directories (e.g. Documents, Music, ....) don't have working data in them. This allows me to make changes (i.e. reformat if necessary) the /home partition when I'm updating or changing between different distros, if there's a problem. The use of a shared /home partition is quite old for me -- it started with Ubuntu 8.04, then 10.04, 12.04, 14.04, 16.04 and now 18.04 -- but my crossing over from Debian-based distros to the Arch-based distro is something that I've only been doing for the past few months.

I would like to use Manjaro KDE as my primary desktop and distro, because I've found the community forums to be responsive, and I like the AUR. I can live with the missing Application Menu in Kate and in Konsole, because they're not mission-critical for me, and there are other alternatives that could be installed. I cannot, however, work with a missing Application Menu in LibreOffice. I even tried installing OpenOffice yesterday, to see if I could use that within Manjaro KDE until something gets resolved, but the position of objects in Impress presentations appeared as shifted, so that's not going to work.

If your opinion is that there is no alternative to wiping the /home partition and reinstalling Manjaro, I can do that. However, since I've been using a shared /home directory as a way of working with multiple distros since 2008, if this is an incompatability across Debian and Arch distros, then I'll probably have to revert to using Kubuntu as my primary distro, and come over to Manjaro KDE when I really need something that is only available in AUR.

Thanks again for responding to this thread. I apologize that the response is so long, but now appreciating that the missing Application Menu isn't just a LibreOffice issue raises all sorts of questions and complications.

Re the Global Menu ... fyi to positively definitely be certain that it is not enabled: How to DISable Plasma 5.12 Global Menu?

Yes i acknowledge that you applied the Application Menu as a consequence of my earlier workaround suggestion, & i meant no criticism at all on that in my last post. It's just that IMO if we're now back in troubleshooting mode rather than workaround mode, that setting is best removed again, so we aren'r unnecessarily muddying the waters. You have now removed it, so that's good.

However, if both GM & AM are disabled / inactive / not present, AND if /etc/profile.d/libreoffice-fresh.sh is back at default [ie, with each option commented-out to deactivate], AND if you do not have a Menu Bar in any of your windows [not just LO-Fresh], then i fear that:

  1. Your User "daviding" KDE account might not be corrupt but there's another factor beyond my knowledge causing this aberrant behaviour, OR...
  2. Your User "daviding" KDE account likely is corrupted.

Either way, it seems to me now that i am just wasting your time, & others more knowledgeable than me would need to advise you a logical next step.

Just being cautiously pedantic, but have you tried logging out & back in, since you made that change?

That is interesting & important, as it potentially contra-indicates @AgentS's & my concern about your multi-boot shared /home being the root cause...??? If so, then my #1 above seems applicable [though clearly unhelpful to you, sadly].

Sorry for any confusion. At different parts of this troubleshooting to date, i have alluded to only the dedicated LO profile within the ~/.config directory, but at other times i have meant your entire active User KDE account [ie, not "guest", but "daviding"].

To me it remains significant that your "guest" user account apparently behaves correctly. I've not done it personally, & pragmatically it would entail a degree of pain for you, but i wonder if you applied the elsewhere-documented procedure to move your KDE user to a fresh login account, you might then be good again?

Wholeheartedly agree.

I'm not saying it is, but i certainly cannot rule it out. Once again, others more experienced than me would need to advise.

1 Like

Solved! The problem of the missing Application Menu in LibreOffice isn't with LO per se.

Searching on how to reset the user KDE account further, I found instructions at Kde reset by @bogdancovaciu

I restarted Manjaro KDE from a USB key. Starting Dolphin, I showed the hidden files. I then renamed ...

  • .config --> 20180915.config
  • .cache --> 20180915.cache
  • .local --> 20180915.local

I shut down Manjaro KDE on the USB key, and rebooted into the regular installation on the hard disk. The Application Menu bar is back on LibreOffice, Kate and Konsole. Hooray!

Of course, all of the customizations that I had done on the Plasma Desktop are gone. This is a small price to pay, and I can restore them over time.

For good measure, since I have a multi-boot computer, I rebooted the computer in Kubuntu. The Plasma desktop looks pretty much the same over there. I'll be glad to again be using Manjaro KDE as my primary distro, and Kubuntu as a backup.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by