Lightdm-greeter change resolution

wondering why there isnt such a basic feature like changing this resolution or at least it should by default get the desktop resolution..

i am on the latest manjaro xfce release with a 3200x1800 13'' laptop screen and there is no way possible or articles that explain how can i change the greeter resolution, changed the grub res to 1280x800 successfully but I can not even read anything in the greeter and the windows to place the password is super small.. I know it is possible as linux mint xfce greeter resolution works fine ... could someone point me in the right direction to change this setting? I mean we are in 2018 close to 2019 and screens and resolutions are getting higher and higher every second ... this things are getting way behind.. thanks

  • Edit /etc/lightdm/lightdm.conf as root
    sudo mousepad /etc/lightdm/lightdm.conf
  • Uncomment this setting
    change #display-setup-script=/etc/lightdm/Xsetup to
  • edit /etc/lightdm/Xsetup as root
    sudo mousepad /etc/lightdm/Xsetup
  • type in a xrandr command suitable to your needs i.e.
    xrandr --output LVDS1 --mode 1280x800 --dpi 96
    xrandr --output LVDS1 --dpi 144

Change the values to your setup and preference and logout your session to see the changes.


I have the same problem. I tried the xrandr-based script:

$ grep display-setup /etc/lightdm/lightdm.conf
$ cat /etc/lightdm/
xrandr --output eDP1 --mode 1920x1080

but that fails with:

[+0.76s] DEBUG: XServer 0: Got signal from X server :0
[+0.76s] DEBUG: XServer 0: Connecting to XServer :0
[+0.77s] DEBUG: Launching process 6708: /etc/lightdm/
[+0.77s] DEBUG: Process 6708 exited with return value 1
[+0.77s] DEBUG: Seat seat0: Exit status of /etc/lightdm/ 1
[+0.77s] DEBUG: Seat seat0: Stopping display server due to failed setup script

I have DELL XPS 13 and with uses 3200x1800 resolution - too small to work.
Similarly grub shows its options in this resolution, but that is OK since I do not reboot often. With lightdm the problem is that it is used for locking and thus it flickers the screen when locing / unlocking.

Any help would be really appreciated. Thanks!

Output from xrandr:

$ xrandr
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
eDP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 290mm x 170mm
   3200x1800     59.98 +  59.94    47.99  
   2880x1620     59.97  
   2560x1600     59.99    59.97  
   2560x1440     59.96    60.00    59.95  
   2048x1536     60.00  
   1920x1440     60.00  
   1856x1392     60.01  
   1792x1344     60.01  
   2048x1152     60.00    59.90    59.91  
   1920x1200     59.88    59.95  
   1920x1080     59.96*   60.00    59.93  
   1600x1200     60.00  
   1680x1050     59.95    59.88  
   1400x1050     59.98  
   1600x900      60.00    59.95    59.82  
   1280x1024     60.02  
   1400x900      59.96    59.88  
   1280x960      60.00  
   1368x768      60.00    59.88    59.85  
   1280x800      59.81    59.91  
   1280x720      59.86    60.00    59.74  
   1024x768      60.00  
   1024x576      60.00    59.90    59.82  
   960x540       60.00    59.63    59.82  
   800x600       60.32    56.25  
   864x486       60.00    59.92    59.57  
   640x480       59.94  
   720x405       59.51    60.00    58.99  
   640x360       59.84    59.32    60.00  
DP1 disconnected (normal left inverted right x axis y axis)
DP1-1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 510mm x 290mm
   1920x1080     60.00*+  50.00    59.94  
   1680x1050     59.88  
   1280x1024     75.02    60.02  
   1440x900      74.98    59.90  
   1280x960      60.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    72.81    66.67    60.00    59.94  
   720x400       70.08  
DP1-2 disconnected (normal left inverted right x axis y axis)
DP1-3 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

output from inxi

$ sudo inxi -Fxm                                                                                                                     
System:    Host: kathmandu Kernel: 4.14.47-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.1.0 Console: tty 0
           Distro: Manjaro Linux 17.1.10 Hakoila
Machine:   Type: Laptop System: Dell product: XPS 13 9360 v: N/A serial: 166SYF2
           Mobo: Dell model: 0D4J15 v: A00 serial: /166SYF2/CNCMK0076IA009/ UEFI: Dell v: 2.4.2
           date: 11/21/2017
Battery:   ID-1: BAT0 charge: 56.0 Wh condition: 58.0/60.0 Wh (97%) model: SMP DELL TP1GT61 status: Charging
Memory:    Array-1: capacity: 16 GiB slots: 2 EC: None max module size: 8 GiB note: est.
           Device-1: System Board Memory size: 8 GiB speed: 2133 MT/s type: LPDDR3
           Device-2: System Board Memory size: 8 GiB speed: 2133 MT/s type: LPDDR3
CPU:       Topology: Dual Core model: Intel Core i7-7560U bits: 64 type: MT MCP arch: Kaby Lake rev: 9
           L2 cache: 4096 KiB
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19204
           Speed: 501 MHz min/max: 400/3800 MHz Core speeds (MHz): 1: 500 2: 501 3: 500 4: 500
Graphics:  Card-1: Intel driver: i915 v: kernel bus ID: 00:02.0
           Display: server: 1.19.6 driver: intel unloaded: fbdev,modesetting,vesa tty: 142x41
           Message: Advanced graphics data unavailable for root. Old System?
Audio:     Card-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel v: kernel bus ID: 00:1f.3
           Card-2: Realtek USB Audio type: USB driver: snd-usb-audio bus ID: 3:3
           Sound Server: ALSA v: k4.14.47-1-MANJARO
Network:   Card-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter driver: ath10k_pci v: kernel
           bus ID: 3a:00.0
           IF: wlp58s0 state: up mac: 9c:b6:d0:db:13:49
           Card-2: Qualcomm Atheros type: USB driver: btusb bus ID: 1:2
           Card-3: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 bus ID: 4:3
           IF: enp57s0u1u2 state: up speed: 100 Mbps duplex: full mac: a4:4c:c8:aa:4d:9f
Drives:    HDD Total Size: 2.29 TiB used: 17.10 GiB (0.7%)
           ID-1: /dev/nvme0n1 model: PM961 NVMe SAMSUNG 512GB size: 476.94 GiB
           ID-2: /dev/sda type: USB vendor: Seagate model: Expansion size: 1.82 TiB
Partition: ID-1: / size: 451.32 GiB used: 17.10 GiB (3.8%) fs: ext4 dev: /dev/dm-0
           ID-2: swap-1 size: 17.11 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-1
Sensors:   System Temperatures: cpu: 51.5 C mobo: N/A
           Fan Speeds (RPM): N/A
Info:      Processes: 182 Uptime: 35m Memory: 15.55 GiB used: 2.71 GiB (17.4%) Init: systemd Compilers:
           gcc: 8.1.0 Shell: bash v: 4.4.19 inxi: 3.0.10

A quick update. Right after I wrote the last post, I decided to tweak the script to store the output to file to see why xrandr complains. It was "Cannot find resolution 1920x1080". So I decided to add there a line which will output what xrandr knows:

cat /etc/lightdm/                                                                                                   ✓

xrandr -q > /var/log/lightdm/xrandr-all.log
xrandr --verbose --output eDP1 --mode 1920x1080 > /var/log/lightdm/xrandr.log 2>&1

and issued systemctl restart lightdm. Surprisingly, it started to work - I was presented by lightdm greeter instead of blinking cursor. It works even after reboot.

Is there anyone that understands what is going on?


1 Like

Try adding sleep 3 before xrandr command

1 Like

So you are sating that before the display-setup-script is ran the X server is not fully initialized? Isn't that a lightdm bug?

1 Like

So for me this worked:

  1. identify primary output and resolution:
    xrandr -q

  2. build the command for the script from this output
    part of the output is like:
    eDP1 connected primary 1920x1080+0+0
    script command is like:
    xrandr --output eDP1 --mode 1920x1080 --dpi 96

  3. set display-setup-script path:
    sudo mousepad /etc/lightdm/lightdm.conf
    go to section [Seat:*]
    change #display-setup-script= to display-setup-script=/etc/lightdm/Xsetup

  4. insert the command for setting the resolution in the script:
    sudo mousepad /etc/lightdm/Xsetup
    insert command from step 2 and save:
    xrandr --output eDP1 --mode 1920x1080 --dpi 96

  5. make it executable:
    sudo chmod +x /etc/lightdm/Xsetup

  6. reboot

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by