Linux 4.12

Yes, it works on my main machine as i mentioned but i have no idea why only after the update to the linux412-virtualbox-host-modules Version 5.1.22-3.
If i downgrade to the previous one nothing works regarding VBox and suspend ... Instant crash.
Also i solved the BFQ thing (as you did) and now i'm a bit more happier ... You also updated the linux412-virtualbox-host-modules to 5.1.22-3 ?

1 Like

I'm already with (unstable branch).
I don't have issues with VB anymore but the problem with freezing system after suspend remains. :joy:

That's a ■■■■■■■■■ :sob:
One thing i will mention, my machine has only a legacy BIOS and is set to suspend to ram. I don't use swap at all. Does this help somehow?

1 Like

Maybe this, I have a swap file...I don't know...I never had this problem before with any kernel.

I posted about the issue I am having on my KDE install on my Intel laptop:

[Stable Update] 2017-07-16 - Kernels, Deepin, Palemoon, KDE-Framework, XFCE4-GTK3

Suspend (well actually resume :D) not working for me. I get a circle rotating around my wifi icon and then have to reset. No access to VT, ctrl+alt+bkspace does not work. Have removed 4.12.

Intel everything here:

1 Like

Now with the stable - update

comes the driver nvidia 340xx to the kernel 4.12 and works fine. :grin:


Suspend issues aren't present for me with 4.13-rc1. Looks like 4.12 might be a miss for my systems (even-numbered releases seem to do this regularly for me...).

After upgrading to kernel 4.12.1-1 my computer freezes when I try to resume from suspend. I can type in my password and press enter then it freezes. I have to power down and start the computer again. I have reverted to kernel 4.11.10-1 which does not exhibit the problem.

I am running xfce and here is the oupt from inxi:

System:    Host: manjaro Kernel: 4.12.1-1-MANJARO x86_64 (64 bit gcc: 7.1.1)
           Desktop: Xfce 4.12.4 (Gtk 2.24.31) Distro: Manjaro Linux
Machine:   Device: portable System: Dell product: Inspiron 5521 v: A04
           Mobo: Dell model: 0K08H3 v: A00
           UEFI [Legacy]: Dell v: A04 date: 11/21/2012
Battery    BAT1: charge: 35.5 Wh 86.2% condition: 41.1/42.0 Wh (98%)
           model: SDI DELL PT43699R status: Discharging
CPU:       Dual core Intel Core i5-3337U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 7186
           clock speeds: max: 2700 MHz 1: 2499 MHz 2: 2499 MHz 3: 2694 MHz
           4: 2700 MHz
Graphics:  Card: Intel 3rd Gen Core processor Graphics Controller
           bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.3) driver: intel
           Resolution: 1366x768@60.04hz
           OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile
           version: 4.2 Mesa 17.1.4 Direct Render: Yes
Audio:     Card Intel 7 Series/C216 Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.12.1-1-MANJARO
Network:   Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: 2000 bus-ID: 01:00.0
           IF: enp1s0 state: down mac: <filter>
           Card-2: Intel Centrino Wireless-N 2230
           driver: iwlwifi bus-ID: 02:00.0
           IF: wlp2s0 state: up mac: <filter>
Drives:    HDD Total Size: 1000.2GB (56.2% used)
           ID-1: /dev/sda model: WDC_WD10JPVT size: 1000.2GB
Partition: ID-1: / size: 908G used: 516G (60%) fs: ext4 dev: /dev/dm-0
           ID-2: swap-1 size: 9.45GB used: 0.00GB (0%) fs: swap dev: /dev/dm-1
Sensors:   System Temperatures: cpu: 48.0C mobo: N/A
           Fan Speeds (in rpm): cpu: 2600
Info:      Processes: 199 Uptime: 2 min Memory: 1026.5/7863.1MB
           Init: systemd Gcc sys: 7.1.1
           Client: Shell (bash 4.4.121) inxi: 2.3.23

Thanks in advance.

@jonathon - Just tested 4.13 - exactly the same problems

1 Like

Same problem gnome-shell freezes (but still draws whatever was on before) after resume from suspension. Linux Kernel 4.12 problem. nvidia proprietary drivers.

λ ~/ inxi -v1
System:    Host: Centaur Kernel: 4.12.1-1-MANJARO x86_64 (64 bit)
Desktop: Gnome 3.24.2 Distro: Manjaro Linux
CPU:       Quad core Intel Core i7-4790K (-HT-MCP-) speed/max: 1283/4400 MHz
Graphics:  Card: NVIDIA GM204 [GeForce GTX 970]
Display Server: x11 (X.Org 1.19.3) driver: nvidia
Resolution: 1680x1050@59.97hz, 1920x1080@59.94hz
OpenGL: renderer: GeForce GTX 970/PCIe/SSE2
version: 4.5.0 NVIDIA 375.66
Drives:    HDD Total Size: 1000.2GB (76.5% used)
Info:      Processes: 228 Uptime: 9 min Memory: 2496.9/15981.3MB
Client: Shell (zsh) inxi: 2.3.23

My manjaro under VirtualBox hangs with a black screen on startup with this Kernel. Doesn't boot. Suspend is disabled on my system btw.

Extra confirmation I suppose. Virtualbox doesn't support kernel 4.12 yet (though test builds apparently do).

In KDE Plasma the suspend freeze is also happening

I have just updated to newest Virtualbox 5.1.24 but I still get black screen on startup with this kernel.

are you using virtual box sir?

This is also a issue with bare metal installs. I have KDE installed on a Dell laptop with Intel graphics. After opening the laptop lid, I get the black screen with a mouse cursor, and a hard reset seems the only resolution.

Sorry, never thought, Clevo laptop KDE installed - linked to an old inxi without thinking.

And the 5.1.24 extramodules? Otherwise it's not going to work anyway. (I don't think they were built/available 21h ago)

If you mean guest additions, then yes, I installed 5.1.24 guest additions along the virtualbox upgrade. Still black screen on manjaro startup with this kernel. 4.11 works fine. Blacks screen happens after a couple boot messages so my guess is something on video, xorg, wayland or whatever it is on display.

Forum kindly sponsored by