Linux 4.9-rc2 does not boot

I could make the kernel work. If you are building the kernel from source make sure that the following CONFIG is disabled in .config


See arch forum link

1 Like

Still No Boot with kernel 4.9rc2 ...
Depending on the machine I get the "Manjaro dots" screen or more recently I get the message "Loading Initial RamDisk" the system is locked frozen ...
Only a forced power supply disconnection / button solves such lock.

How can I help debugging this ?

Linux 4.9-rc3 Kernel released with various fixes:

4.9-rc3 doesn't run any better on my baytrail, YMMV. The LTS destined kernels seem to take longer to stabilize. 4.8.5 does run pretty well - it must be getting close to EOL!

Don't worry about v4.8.x series getting any time EOL soon. Since Canonical is using it for their Ubuntu 16.10 series, they will adopt that kernel also as ESS-kernel.

Confirm. 4.9rc3 does not boot (inxi) just like rc2 and rc1 did not boot before.

The virtually mapped stack does not seem to be the culprit after all.

yes. does not boot. waiting patiently for rc4

I get this error if i boot with Linux 4.9-rc3 my Vbox-VM:

It's the same error since rc1.

The same UUID's are in my fstab and will be found with Linux 4.8.5.

Waiting for a RC with no booting problems, because i see that the 4.9 kernel fixes some ACPI (but minimal) problems that i have in my ASUS notebook, and i want to see if this is true

i686 seems to be fine, though.

phil@manjaro ~/Arbeitsfläche $ inxi -S
System:    Host: manjaro Kernel: 4.9.0-1-MANJARO i686 (32 bit)
           Desktop: Xfce 4.12.3 Distro: Manjaro Linux
phil@manjaro ~/Arbeitsfläche $ uname -a
Linux manjaro 4.9.0-1-MANJARO #1 SMP PREEMPT Sun Oct 30 16:52:22 UTC 2016 i686 GNU/Linux
phil@manjaro ~/Arbeitsfläche $ pacman -Q linux49
linux49 4.9rc3-1
phil@manjaro ~/Arbeitsfläche $ cat /etc/lsb-release

True, i have an old netbook that i have installed manjaro and the 4.9 kernel boots, is there a way to try this kernel in livecd? because i want to confirm that this kernel fixes some problems with ACPI that i have in previous kernels with my ASUS notebook

Well, sure. You have to spin it yourself though. Here are the quick steps on doing it:

sudo pacman -S manjaro-tools-iso git
git clone
cd manjaro-tools-iso-profiles
git checkout 16.10-Profiles
sudo buildiso -p xfce-minimal -k linux49 -b stable -a i686 -qv
sudo buildiso -p xfce-minimal -k linux49 -b stable -a i686

Is there any way to get make the kernel recognising the root device? I got the same error with the current 4.9.

Here is the diff between the i686 config and its 64bit version. Here the diff between 4.8 and 4.9 series. Maybe we find the ■■■■■■ ...

Seems there might be a fix for this issue. We will see ...

I can't build the ISO

==> ERROR: 4.9/manjaro-tools-iso-profiles is not a valid iso profiles directory!

What version of manjaro-tools is installed? It should be v0.13.8. What is the content of your profile folder?

phil@manjaro ~/dev/git/manjaro/basic/manjaro-tools-iso-profiles $ cat .buildiso

Also check if you have it set properly in your configs:

phil@manjaro ~/.config/manjaro-tools $ cat *profiles.conf

When i install manjaro-tools-iso, pacman says that there are two versions, the "normal" and "dev" i first tried with normal and gives the "not a valid iso profiles directory" error, i tried to reinstall but automatically installs the normal version, so i tried in other computer with "dev" version and now problems :slight_smile: now is building the iso.

Hmm, this makes it boot. We have no proper fix yet, however a working workaround.

1 Like

49rc3-3 fixes booting for me. Thank you very much!

1 Like

Forum kindly sponsored by