Linux Breakout 2

I've been playing this game for about a month and it was fine, then all of a sudden it started pausing itself for no reason. I run it, play for like 30 seconds and the game pauses (same way as by pressing "P" on the keyboard) and I can't do anything. Can't unpause, can't quit, I can only close the window. I reinstalled, removed config, but it didn't help.

You will need to provide more information if anyone is to help you. :smile: For example, is there any output in the terminal when this happens (after launching from the terminal)? Also you might want to look at How to provide good information in your posts.

I can confirm that the game locks up if I miss the ball. I'll run it in a terminal later.

Here it is:

LBreakout2 2.6.5
Copyright 2001-2011 Michael Speck
Published under GNU GPL
Looking up data in: /usr/share/lbreakout2
Looking up highscores in: /var/games/lbreakout2
Looking up custom levels in: /home/william/.lgames/lbreakout2-levels
Loading theme 'AbsoluteB'
Write permission for '/var/games/lbreakout2/lbreakout2.hscr' denied.
Unable to access highscore chart in '/var/games/lbreakout2'.
Trying to use config directory '/home/william/.lgames'.
Saving highscore chart in: /home/william/.lgames
ERROR: cannot open slot 0!
ERROR: cannot open slot 0!
LBreakout2 v1.00: 31 levels
Time: 28.46, Frames: 25259 -> FPS: 887.65
Client finalized
GUI finalized
Audio finalized
STK finalized
SDL finalized

Yeah, I forgot to mention that - terminal doesn't really show anything, looks the same as above. The longer you play, the more lines with "1" appear. When the game pauses, nothing happens. It pauses if you play for about 30 seconds or immediatly when you lose the ball.

Well kbreakout works fine if you need your breakout fix for today.:grinning:

Output tells me that the game cannot access the highscore file in /var/games. This is a permission fault. I assume either you should be member of the group "games" or the file permission got changed somehow. Pls post output of

sudo ls -lR /var | grep games

Here is my output:


Does this help?

no, because you forgot the "l" option in ls -lR. (lowercase L)

drwxrwxr-x  5 root games  4096 Aug 22 13:09 games
-rw-r--r-- 1 root root   5899860 Aug 22 13:58 libkdegames-18.04.3-1-x86_64.pkg.tar.xz
drwxrwxr-x 3 root games 4096 Feb  5  2016 glhack
drwxr-xr-x 2 root games 4096 Aug 22 13:09 lbreakout2
drwxrwxr-x 3 root games 4096 May 17 18:20 nethack
-rw-rw-r-- 1 root games  103 Jun  1 12:49 logfile
-rw-rw-r-- 1 root games    0 Jun  1 12:49 perm
-rw-rw-r-- 1 root games  103 Jun  1 12:49 record
drwxrwxr-x 2 root games 4096 Feb  5  2016 save
-rw-rw---- 1 william games 19345 Feb  5  2016 1000william
-rwxrwxr-x 1 root games 229 Jun 17  2016 lbreakout2.hscr
-rw-rw-r-- 1 root games    4875 May 13 14:07 license
-rw-rw-r-- 1 root games       0 May 13 14:07 logfile
-rw-rw-r-- 1 root games 1375800 May 13 14:07 nhdat
-rw-rw-r-- 1 root games       0 May 13 14:07 perm
-rw-rw-r-- 1 root games       0 May 13 14:07 record
drwxrwxr-x 2 root games    4096 Dec  9  2015 save
-rw-rw-r-- 1 root games   14744 May 13 14:07 symbols
-rw-rw-r-- 1 root games    5513 May 13 14:07 sysconf
-rw-rw-r-- 1 root games       0 May 13 14:07 xlogfile
drwxr-xr-x 2 root root 4096 Aug 22 13:58 libkdegames-18.04.3-1

Well your l looked a 1.

ok, permissions for your specific game looks right. Are you part of group games?

cat /etc/group | grep games

this should show a line with your user name somewhere (probably at the end).

This is what I get:


Something is wrong, but I don't know what.

Now add your user name to this group:

sudo usermod -G games -a yourusername

and run

cat /etc/group|grep games

again. If your username shows up, logout, login, and try your game again.

My user name shows up but that didn't work. The game still pauses if I miss a ball.

Did you logout of your desktop session?

Yes. Should I reboot?

Actually this should not be necessary but cannot hurt. Just reboot.

Still doesn't work. I just had a hunch to to reboot again but with Kernel 4.17 instead 4.18. I'm trying that out.

no not yet. there is still another problem to fix with your .lgame directory

Saving highscore chart in: /home/william/.lgames
ERROR: cannot open slot 0!
ERROR: cannot open slot 0!

do a

cd .lgames
ls -l

There could be a corruption in the highscore file there.

Forum kindly sponsored by