Livedvd boots to black screen on desktop but boots fine on 2nd machine

Ah - I see where you are going. Sorry - I obviously have not made myself clear. The installed graphics card is an nvidia GTX 750. The manjaro livedvd will not boot with that card installed, that's why I tried the GT440. That did not work either, so I now know the problem is not card-specific. Hope that is clear. I will see if I can edit the post title. Also relevant:

  1. This PC currently runs several linux distros (all deb based). They all boot fine with both those nvidia cards.

  2. The dvd player will boot just fine if I try several previous DVD-burned iso's that I have still around the place. So it is not a problem with the dvd drive.

  3. I have just downloaded Chakra and the iso of that boots fine when burned to a dvd - both free and non-free options. I noted that the first boot entry using the free option gave the same Nouveau MMIO fault as the Manjaro boot attempt but still booted OK, so it doesn't look relevant.

  4. The dvd I made of Manjaro boots and installs just fine on another similar PC but will not even boot on this PC.

See my problem?

Thanks for the tip about inserting code in a post


I edited the thread title to (hopefully) make it clearer, feel free to change it again yourself if not happy. :smiley:

Thanks for that - but no advice yet.

Trying Chakra at the moment but not as happy as I am with Manjaro, running perfectly on the wrong machine!

I may not be alone - see this post in same forum in last few days

Can you obtain /var/log/Xorg.0.log from the system which boots to black screen? From Chakra as well.
Also provide
hwinfo --gfxcard
inxi -Fxxxz
from Chakra and Manjaro.

Hi and thanks for helping me.

I can post all your requests for Chakra which I have installed sucessfully to my HD. But not sure how I can get the Manjaro data for you. Just to be clear, I am trying to boot from the Livedvd for Manjaro which boots to a completely unresponsive black screen - no cursor and no prompt.

The last instruction echoed to the screen is something like "A start job is running for LiveMedia MHWD Script". Then it goes to a black screen. Interestingly, the DVD player goes on churning for another minute or two as if it is finishing setting up the desktop.

If I then reboot without the DVD, obviously it boots into the first item in my Grub menu which is Ultimaye (deb) distro. Presumably there will be no record of the old Xorg log file?

BTW - I have now also tried to boot the DVD from another external DVD drive. Still no luck although it will boot in another PC.

1 Like

You can try to pass the boot parameter 3 (just enter the number three where you wrote nomodeset etc.).
The pipe the terminal output to text files.

sudo mount /dev/sdb1 /mnt
inxi -Fxxxzc0 > /mnt/inxi.txt
cp /var/log/Xorg.0.log /mnt
hwinfo --gfxcard > /mnt/hwinfo.txt

There is also the possibilty to copy the ISO to the HDD and boot the ISO with Grub. Just copy the ISO to a place on the disk, create an entry in /etc/grub.d/40_custom

menuentry "Manjaro KDE ISO" {
    set isofile="/path/and/name_of_the.iso"
    set archi="x86_64"
    set dri="free"
    search --no-floppy -f --set=root $isofile
    probe -u $root --set=abc
    set idev="/dev/disk/by-uuid/$abc"
    loopback loop $isofile
    probe -l (loop) --set=mlabel
    linux  (loop)/boot/vmlinuz-$archi  img_dev=$idev img_loop=$isofile  isobasedir=manjaro misolabel=$mlabel nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 logo.nologo driver=$dri
    initrd  (loop)/boot/initramfs-$archi.img

and run sudo update-grub (or the Arch or Debian equivalent).
But it is probably the video driver, the method DVD or USB or HDD will make no difference.


Would you mind to look at to try to disable MHWD live service. Thanks.

1 Like

Thanks for the suggestion. I tried adding the parameter 3 but boot still did not get to a prompt. It halts at "Started TLP system startup/shutdown" whatever that means.

I am going to try your next suggestion re booting from a copy of the iso on the HDD and reply below

please try @yerri suggestion first.

1 Like

Since I run a Manjaro pc with the Nvidia 750Ti I tested the newest KDE 17.1.1 and it boots just fine here, matter of fact typing this in from the live usb right now.

Now there is a point as you say it seems to stall at the LiveMedia MHWD Script
BUT if you have patience after some seconds (15-30s maybe longer on slower hardware) it starts to come to life and eventually you get the KDE desktop.
This acts exactly as the symptoms you describe and I have repeated here.

I think it should work with your hardware based on my findings, not a GPU issue or an installer issue either.

[manjaro@manjaro ~]$ inxi -b
Resuming in non X mode: xrandr not found. For package install advice run: inxi --recommends
System:    Host: manjaro Kernel: 4.14.11-3-MANJARO x86_64 bits: 64
           Desktop: KDE Plasma 5.11.5 Distro: Manjaro Linux
Machine:   Device: desktop Mobo: ASRock model: Z77 Extreme4-M serial: N/A
           UEFI: American Megatrends v: P1.50 date: 12/10/2012
Battery    hidpp__0: charge: N/A condition: NA/NA Wh
CPU:       Quad core Intel Xeon E3-1270 V2 (-MT-MCP-)
           speed/max: 3500/3900 MHz
Graphics:  Card: NVIDIA GM107 [GeForce GTX 750 Ti]
           Display Server: N/A drivers: nouveau (unloaded: modesetting)
           tty size: 77x24
Network:   Card: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169
Drives:    HDD Total Size: NA (-)
Info:      Processes: 197 Uptime: 17 min Memory: 1669.9/15998.3MB
           Init: systemd Client: Shell (bash) inxi: 2.3.53 
[manjaro@manjaro ~]$
1 Like

OK Success!!!! I modified the boot script as suggested, inserting


and have now been able to boot to a working desktop. I will install on a spare partition while I am winning and get back to you if there are any issues.

A big thank you to all those that took time and trouble to help me - especially with patience and none of that (in)famous arch treatment. What a nice forum. It makes all the difference.



Oooops - my attempt to enclose the command in code brackets seems to have gone wrong. The code I added to the boot script as suggested was: systemd.mask=mhwd-live.service, should anyone come looking.

In case people do come looking.
I doubt this is even needed see post #15.

Well - you're the expert. Only thing I observed was it finally at least got me to a desktop.

Anyway, it is still no good, spoke too soon. I installed to a spare partition but on boot it still does not get to a desktop. Stalls at the same place as with the LiveDVD before I added the mask command:c "Started TLP system startup/shutdown"

Tried both the options under Advanced Manjaro in the boot menu but just went like the first effort.

Not only very frustrating but I am running out of time to get this operational. Actually I have this other life to lead and it takes my main PC out of service unless I boot back and forward between a working deb distro and this broken install of Manjaro...

Please start a new thread with the new problems, I am going to mark this as solved on my post.

On your new thread you may want to include more details.

bit difficult to give more info when you cannot even get to a desktop or a prompt :wink:

Try another TTY with Ctrl+Alt+F3
Then exec startx
Maybe your DM needs configuration.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by