LiveUSB: not booting when entering the "Boot to Manjaro"

1 - log to tty terminal
2 - boot without X
3 - chroot auto (with manjaro-chroot)
4 - chroot (with manjaro-chroot)
5 - chroot older way (with mhwd-chroot)
6 - chroot into encrypted system (with manjaro-chroot)
7 - chroot into encrypted system (without manjaro-chroot)

I'd like to try all the mentioned steps, but:

  • 1 doesn't work
  • 2 doesn't help
  • currently trying all the following, but the liveUSBs I tried don't work either.
    |
    -> that is why I created this thread.

Maybe quit doing all that preconfig stuff and just hit the "Boot" part with free drivers?

1 Like

I also tried not touching any parameters at all, no luck either.

All that was nice in your first post :wink:

but I am :man_shrugging:

hmmmm, only the restoration of the backup remains. :slight_smile:

I truly have had problems with LiveUSB.

I don't know what is happening or what I'm doing wrong, but every liveUSB of Manjaro ever failed on my workstation. The only way I managed to install Manjaro was via architect.

So it always eliminates some possibilities for repair if I can't boot to a live environment.

Me too, 2012 PC failed often, 2009 PC (AMD) is easy and work.
But that dos not help.
2012 PC has before win and mint on it then I start with Manjaro and I got crazy :wink:
The motherboard has intel GPU but I use nvidia GPU, I think that was the main problem.

Try an Xfce installation and put i3wm on it, that's how it worked for me, but it's been a while since I did it

Secure boot/Fast boot off?
Hard drives in AHCI and not raid?

Is this dual booting?

What was on the machine before?

1 Like

And why don't you use architect again?
Whatever troubleshooting you would do with GUI LiveISOs, you can do with Architect.

1 Like

Ah! I tested and apparently the Architect liveUSB has the same problem.
Black screen after some [ OK] initialization.

Secure boot/Fast boot off.
Everything in AHCI.

Dual booting with Windows 10. (My Manjaro and W10 installs are both on different SSDs).

Ok so I also tried with some Boot Repair and Ubuntu live ISO, nothing working.
Everytime I get a black screen.

What are your graphics units? I used to run into problems on my old laptop with the discrete GPU and the integrated graphics. For me the non-free driver option worked like a charm - until I needed a different driver configuration. Just checking, if you already tried the non-free option. I can't find wether you did that.

Refer this topic

Use the {More Complicated Setup Section} to boot and boot with '3' (as you did above)
Fix at prompt login.
Start with
sudo pacman-mirrors -f3
sudo pacman -Syyuu

1 Like

@gohlip, your solution did not work (same black screen problem via chroot).

Now I've got another problem.

First, an update on my situation:

  • I tried to boot to my installed system, but this time with the nomodeset option, and now I can access a TTY.
  • I did the pacman-mirrors -f3 and pacman -Syyuu, and there's the nothing left to do prompt.
  • I tried to startx, and I get a (EE) no screens found error.

Ok, understood.
This is definitely a graphics problem, can somebody please help the OP.
Good luck.

1 Like

Meaning you need to do your graphics commands after these...
You had earlier not able to get to tty or have problems after getting to tty.
So this method is to get to to prompt and you can fix it from there.

I prefer others to help you with graphics, and provide (from prompt) {others are much better than I on this}

mhwd -li
mhwd -l
inxi -G

But here's how I fix my graphics problem
from 'mhwd -li ' I remove all drivers shown there.
mhwd -r

sudo mhwd -r pci  <**all** shown at mhwd -li>
sudo pacman -Syu
sudo mhwd -a pci free 0300
sudo pacman -Syu

If you are certain you need non-free above command should be
sudo mhwd -a pci nonfree 0300

But if you have dual graphic cards or some fancy stuff, that's where I would not be able to help.
Others will need to jump in.
And after getting the help from others, you will need to go to prompt and do the commands.
Better than from tty. (That's where I came in).

Hope this is clear.

1 Like

Ok so I've not been able to fix all my problems.
Situation so far: the only way I can boot any liveUSB is with the nomodesetoption.
So I try a complete reinstall, with the Architect ISO (run with nomodeset).
The install done, I tried to boot and... black screen.
The one and only way I can boot is with nomodeset.
I tried 3 installs, with the free and non-free drivers. Nothing.

I really think it's a graphics drivers problem, and if someone could help me fix it, I'll be very grateful.


GPU: AMD Sapphire Radeon RX580 8GB

Only a short train of thought. I once heard that Windows10 has an option that does not completely shut down the PC, so it starts faster. Is this feature turned off in your Win10 settings?

I ask because a friend had similar problems. However, after changing this setting in Win10, he was able to boot and use his Linux USB stick without errors. Unfortunately, I can not say exactly what did not work for him back then.

The fast boot is not enabled in Win10 and I've absolutely no problem booting with nomodeset.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by