Load kernel after update...

Typing on mobile.... as I can't boot.
Apologies for markdown, typos... spelling, commas...
After update I am left unable to boot.
Some 'vmlinuz4.9-x86_64' cannot be found.
thinkpad lenovo t450s.
tried following this advice:

grub> search.file /etc/manjaro-release  root
grub> configfile /boot/grub/grub.cfg
grub> boot

It actually reboots after the second command and gives no output to the first. but just the same loopasking to load kernel first...

I also don't know whether my installation is legacy or uefi.. I guess it's basic, but I don't know which. (How can I find out?)
When I change settings to uefi, or uefi first I get access only to 'grub rescue' which is very limited.
Tried both grub on my manjaro and on installation disc, both give only 'pc' for 'echo $grub_platform'
And nothing to get out of the loop.
Help appreciated!
Thanks

From a live manjaro usb chroot into your installed system and (re)install the kernel. Here is how to chroot into your system:

https://wiki.manjaro.org/index.php?title=GRUB/Restore_the_GRUB_Bootloader#Use_manjaro-chroot

Once chrooted, run

mhwd-kernel -l

to list available kernels. Install a couple of them, like for example:

sudo mhwd-kernel -i linux49

Then run:

sudo mkinitcpio -P

to rebuild all the kernel images.

sudo update-grub

and after

exit

to exit the chroot environment.

Now reboot. Hope this will resolve the issue.

1 Like

After you've followed @Marte's excellent advice, start making crash-proof backups:

(I did one before and after the major update of earlier today and wiped the "before" after I checked everything worked afterwards...)

:innocent:

1 Like

Once chrooted, i manage to get the list from mhwd-kernel -l , but chosing to install returns errors....

Would be informative to see what those error messages are. You could login to the forum from the live usb and post those error messages. They could give someone some idea of what might be wrong.

Thanks @Marte ...
forgot that I have an environment now..
the errors I get are that the hosts cannot be found:

sh-5.0# sudo mhwd-kernel -i linux316
:: Synchronizing package databases...
error: failed retrieving file 'core.db' from ftp.vectranet.pl : Could not resolve host: ftp.vectranet.pl
error: failed retrieving file 'core.db' from mirror.ufro.cl : Could not resolve host: mirror.ufro.cl
error: failed retrieving file 'core.db' from mirror.inode.at : Could not resolve host: mirror.inode.at
,,,

refreshing the packagemanager db now...

Sleep first! You're bound to make mistakes when you're tired...

:netherlands: :first_quarter_moon_with_face:

¯\_(ツ)_/¯

:zzz: :bed: :zzz:
:exclamation: :wave:

(alleszins: dat is wat ik nu ga doen!) :stuck_out_tongue_winking_eye: :crazy_face:

1 Like

very kind @Fabby ... I am hoping to have this machine ready for work in the morning... I'll give it a few more minutes... the db updates slowly and with many connection timeouts... your advice might be wise...

package manager is now stuck on:

Refreshing multilib.files...

I will let it rest till the morning... good night!

Did you update your mirrorlist first?

Trying again. refreshed the mirrorlist ( thanks @anon11646911 ) .
updated the packages...
I am using the gui package manager and it gets stuck on "Refreshing multilib files" ...
and so mhwd install linux out of the list returns same errors.

You are doing this in the live environment? For installing the kernels you should be in the chroot-environment, that is you are accessing your installed system via terminal from the live environment. No gui in there.

Make sure you are connected to the web (wired/wireless). If you are not chrooted, follow the instruction in the link previously posted to get int the chroot-environment. Run:

sudo pacman-mirrors -f5 && sudo pacman -Syyu

Then try to install a couple of kernels as described before.

thanks @Marte . chrooted mirrors are returned fine but sudo pacman -Syyu returns:

 [manjaro-i3 /]# sudo pacman -Syyu
:: Synchronizing package databases...
error: failed retrieving file 'core.db' from mirror.catn.com : Could not resolve host: mirror.catn.com
error: failed retrieving file 'core.db' from mirror.terrahost.no : Could not resolve host: mirror.terrahost.no
,,,

For some reason the chrooted environment can't access the internet.

I am not sure if the following will work any better but perhaps worth a try.
Still in chroot:

sudo pacman-mirrors -c all

and

sudo pacman -Syyu

If still no luck (I'm shooting in the dark here), run at least:

sudo mkinitcpio -P

Perhaps it will rebuild the kernel images just fine and thereby resolves the initial issues. If it runs fine do a:

sudo update-grub

followed by:

exit

and the reboot and see if it works. If not I'm afraid I am running out of ideas and should retire myself and let more advanced users to step in and assist you on this. Good luck!

no luck...
I get

==> ERROR: No presets found in /etc/mkinitcpio.d

to sudo mkinitcpio -P...

I have seen this error message before around the forum. I'm afraid I haven't followed thorough those threads to know the solution :slightly_frowning_face:

looks like the problem I am facing at the moment is that the chroot environment doesn't seem to have a network connection. it returns error from requests to all hosts. It actually does return a mirror list, so I am not sure ...

Yes, I just saw that you had edited your post. I don't know why refreshing the mirror list works but not refreshing the databases. I am sure someone will come along with some explanation/solution.

Sorry @manandearth for not being able to assist you any further than this. I will watch and learn. Good luck!

restarted and it works ( I did restart a couple of time before...)
installing nhwd-kernel linux... now

Forum kindly sponsored by