Local time doesn't follow me

When I go to the settings to change the time so that it follows me automatically the option is greyed out so I can not select the option. I read that there is the process of going to manjaro settings menu and changing the timezone there, but I want this to happen automatically and not have to change it all the time since I am using this on a travelling laptop and don't want to have to do this every time

Enable the timesync daemon

sudo systemctl enable --now systemd-timesyncd

Also be aware of problems if you are dual booting Windows/Manjaro.

That option is still greyed out

Have you logged off or restarted your system?

Yes.. it's still the same

That is only possible if your laptop has a GPS receiver built in just like your phone.

If not, changing the time zone manually is the only option you've got.

1 Like

it used to work in the previous version of manjaro

Thank you very much for that information, but that doesn't help us help you...

Which GPS chip do you have or would IP Geolocation be a good solution as well? (if you use a VPN, IP Geolocation won't be a good solution)

Please also read this:


and post some more information so we can see what's really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies...

:innocent:

P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you're using, which CPU/GPU you have, ...

https://wiki.archlinux.org/index.php/System_time#Update_timezone_every_time_NetworkManager_connects_to_a_network

I guess he is not using gnome as the option is built into gnome date and time settings.

Edit: his profile say gnome.. and he say the option is greyed out.. as I'm not a gnome user.. I don't know which setting could affect the option.

GNOME supports automatic time zone selection (can be enabled in Date & Time section of the system settings, given that location services are enabled (see Privacy section of the settings).

@phoniclynx did you check location service was enabled? If you don't want the location service to be enabled.. you can use the other ways explain in the Arch wiki link above.

1 Like

A similar issue happens in Cinnamon too. In the date/time settings applet I can toggle a switch to use network time, but every time I open the applet, it is switched to off.

I have enabled systemd-timesyncd manually and that works, but the DE controls don't work.

not really... the OP issue is not about automatic date time settings..
but about automatic TimeZone settings depending on its location and MSM don't and can't set it.
As long I am aware of.. only gnome (maybe deepin) has this option.

  1. NTP or systemd-timesyncd get the UTC time from internet. (Universal time)
  2. Linux translate the UTC time to local time using the TimeZone

The OP want the timezone to be updated too to his current location as he often travel. and always want the local time to be correct..

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by