Lock screen and wifi are broken

Haven't had an issue so far. I'll mark your answer as the solution if I don't have any more for a couple hours :stuck_out_tongue_winking_eye:

You can give the credit back to @Fabby if you figure things are all working better. I've got plenty of credits for solves already and Fabby deserves the credit as he is always super helpful.

I just toss a crumb or two out there these days as I'm not posting anywhere near as often as I used to.

Hopefully everything is resolved for you now.

2 Likes

Ok so they didn't improve ;(
The same issue actually worsened. now bluetooth is completely disabled after a lock screen for a long period of time

Oh wait lol - I replied at the exact same time!?
Also, I think your help is pretty useful

Post the service you wrote along with the output of lsusb.

I didn't write any services, simply ran echo 'options bt_coex_active=0' | sudo tee /etc/modprobe.d/iwlwifi.conf, unless you are talking about the iwlwifi service I wrote earlier, which was simply the one in Closing lid cause network deactivation

Here's the output of lsusb:

~ ❯ lsusb

Bus 003 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 006: ID 5986:02d2 Acer, Inc 
Bus 001 Device 005: ID 0a5c:21e6 Broadcom Corp. BCM20702 Bluetooth 4.0 [ThinkPad]
Bus 001 Device 004: ID 147e:2020 Upek TouchChip Fingerprint Coprocessor (WBF advanced mode)
Bus 001 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Oooh Broadcom bluetooth. :sob:

Did you install any firmware from the AUR for your bluetooth?

If so which package did you install.

Did you not write the service @Fabby recommended for your wifi. You originally said that fixed your wifi issue.

What logitech device is using the unifying reciever?

Did you install any firmware from the AUR for your bluetooth? If so which package did you install.

Nope. I tend to not install firmware from the AUR whenever possible, since it's usually much less stable than the repositories' firmware.

Did you not write the service @Fabby recommended for your wifi. You originall said that fixed your wifi issue.

I did, and right now I realized something strange. for some reason the line /etc/systemd/system/iwlwifi.service wasn't commented, but it did the trick anyways for WIFI at least. your post had it commented, so I commented it again. Maybe I didn't copy paste the first character? Could this have an impact?

Please post:

systemctl status iwlwifi.service

What is the logitech device using the Logitech unifying reciever?

● iwlwifi.service - Network Suspend/Resume Service
     Loaded: loaded (/etc/systemd/system/iwlwifi.service; enabled; vendor preset: disabled)
     Active: inactive (dead)

Mar 30 16:54:51 robotic systemd[1]: /etc/systemd/system/iwlwifi.service:1: Assignment outside of section. Ignoring.
Mar 30 16:55:53 robotic systemd[1]: /etc/systemd/system/iwlwifi.service:1: Assignment outside of section. Ignoring.

I'm not sure what you mean by that. I'm gonna try a reboot because of the service issue I mentioned in my last post and try again.

Status now is the same but without warnings

● iwlwifi.service - Network Suspend/Resume Service
     Loaded: loaded (/etc/systemd/system/iwlwifi.service; enabled; vendor preset: disabled)
     Active: inactive (dead)

Please post:

cat /etc/systemd/system/iwlwifi.service
#/etc/systemd/system/iwlwifi.service
#sudo systemctl enable iwlwifi.service
#sudo systemctl start iwlwifi.service
#sudo systemctl stop iwlwifi.service
#sudo systemctl disable iwlwifi.service
#systemctl status iwlwifi.service
#sudo systemctl daemon-reload

[Unit]
Description=Network Suspend/Resume Service 
Before=sleep.target
StopWhenUnneeded=yes

[Service]
User=root
Type=oneshot
RemainAfterExit=yes
ExecStartPre=-/usr/bin/sudo -u $USER /bin/bash -lc 'nmcli networking off'
ExecStart=/usr/bin/sleep 1
ExecStart=-/usr/bin/systemctl stop NetworkManager
ExecStart=/usr/bin/sleep 1
ExecStart=-/usr/bin/ip link set wlo1 down
ExecStart=/usr/bin/sleep 1
ExecStart=-/bin/bash -c "lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs sudo rmmod"
ExecStop=/usr/bin/sleep 5
ExecStop=-/usr/bin/modprobe iwlwifi
ExecStop=/usr/bin/sleep 2
ExecStop=-/usr/bin/ip link set wlo1 up
ExecStop=/usr/bin/sleep 2
ExecStop=-/usr/bin/systemctl start NetworkManager
ExecStop=/usr/bin/sleep 2
ExecStop=-/usr/bin/sudo -u $USER /bin/bash -lc 'nmcli networking on'
ExecStop=/usr/bin/sleep 1
ExecStop=-/usr/bin/sudo -u $USER /bin/bash -lc 'nmcli r wifi off'
ExecStop=/usr/bin/sleep 1
ExecStop=-/usr/bin/sudo -u $USER /bin/bash -lc 'nmcli r wifi on'

[Install]
WantedBy=sleep.target

Note that the first line was uncommented, I just recommented it before reboot. I dunno if this will solve my issue

You must reboot after changing any service.

The first line of the service is intended to be commented.

I meant 'before' not 'without' :sweat_smile:
anyways those warnings said 'Ignored', so will this fix this?

You did not modify the service as per my directions on the linked post to reflect your network configuration.

Please edit the service with the changes as follows below:

#/etc/systemd/system/iwlwifi.service
#sudo systemctl enable iwlwifi.service
#sudo systemctl start iwlwifi.service
#sudo systemctl stop iwlwifi.service
#sudo systemctl disable iwlwifi.service
#systemctl status iwlwifi.service
#sudo systemctl daemon-reload

[Unit]
Description=Network Suspend/Resume Service 
Before=sleep.target
StopWhenUnneeded=yes

[Service]
User=root
Type=oneshot
RemainAfterExit=yes
ExecStartPre=-/usr/bin/sudo -u $USER /bin/bash -lc 'nmcli networking off'
ExecStart=/usr/bin/sleep 1
ExecStart=-/usr/bin/systemctl stop NetworkManager
ExecStart=/usr/bin/sleep 1
ExecStart=-/usr/bin/modprobe -r btusb
ExecStart=/usr/bin/sleep 1
ExecStart=-/usr/bin/ip link set wlp3s0 down
ExecStart=/usr/bin/sleep 2
ExecStart=-/bin/bash -c "lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs sudo rmmod"
ExecStop=/usr/bin/sleep 5
ExecStop=-/usr/bin/modprobe iwlwifi
ExecStop=/usr/bin/sleep 2
ExecStop=-/usr/bin/ip link set wlp3s0 up
ExecStop=/usr/bin/sleep 3
ExecStop=-/usr/bin/modprobe -r btusb
ExecStop=/usr/bin/sleep 2
ExecStop=-/usr/bin/systemctl start NetworkManager
ExecStop=/usr/bin/sleep 2
ExecStop=-/usr/bin/sudo -u $USER /bin/bash -lc 'nmcli networking on'
ExecStop=/usr/bin/sleep 2
ExecStop=-/usr/bin/sudo -u $USER /bin/bash -lc 'nmcli r wifi off'
ExecStop=/usr/bin/sleep 2
ExecStop=-/usr/bin/sudo -u $USER /bin/bash -lc 'nmcli r wifi on'

[Install]
WantedBy=sleep.target

Then restart and test a suspend cycle.

1 Like

How would I test this? only way i know how is to keep it in sleep mode for a long time

If the newly created configuration file was causing issues for bluetooth then remove it:

sudo rm /etc/modprobe.d/iwlwifi.conf

For the 3rd time:

Are you using a logitech keyboard or mouse. The Logitech unifying reciever is not a bluetooth device,

What bluetooth devices are you using?

After modifying the service and restarting, please post:

systemctl status iwlwifi.service -l --no-pager 

Forum kindly sponsored by