Logitech C270 webcam resetting every second in dmesg

Every second or so, when I have my webcam plugged in to my computer, I get the below message in dmesg:

usb 5-1.3: reset high-speed USB device number [n] using xhci_hcd

That device number corresponds to my webcam, which is a Logitech C270. I've tried now unplugging the webcam and plugging it into other known-good USB ports, both on the front and the rear of the computer, and the same thing occurs. Other devices don't have this issue in the same ports, it's only the webcam.

Can this be solved with different drivers, or is it a case of "the hardware is kaput"? I can't find any other drivers for it, so I'm not quite sure what to do beyond warranty RMA to Logitech. The webcam does actually work when it's plugged in, but it seems to slow down and eventually crash Discord when it's plugged in, and even faster if it's in use.

inxi output:

System:    Host: curtis-desktop Kernel: 4.19.114-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: Deepin 15.11 
           Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: Gigabyte model: H81M-S2H v: x.x serial: <root required> BIOS: American Megatrends v: F2 
           date: 08/11/2015 
CPU:       Topology: Quad Core model: Intel Core i5-4460 bits: 64 type: MCP arch: Haswell rev: 3 L2 cache: 6144 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 25543 
           Speed: 3193 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 3193 2: 3193 3: 3193 4: 3193 
Graphics:  Device-1: NVIDIA GP106 [GeForce GTX 1060 3GB] vendor: ZOTAC driver: nvidia v: 440.82 bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.8 driver: nvidia resolution: 1920x1080~60Hz, 1366x768~60Hz, 1440x900~60Hz 
           OpenGL: renderer: GeForce GTX 1060 3GB/PCIe/SSE2 v: 4.6.0 NVIDIA 440.82 direct render: Yes 
Audio:     Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: Gigabyte driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 
           Device-2: NVIDIA GP106 High Definition Audio vendor: ZOTAC driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           Sound Server: ALSA v: k4.19.114-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8168 v: 8.048.00-NAPI 
           port: d000 bus ID: 03:00.0 
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: 40:8d:5c:c0:57:77 
           IF-ID-1: br-732318f09f60 state: down mac: 02:42:d2:7e:89:54 
           IF-ID-2: docker0 state: down mac: 02:42:1a:95:ab:05 
Drives:    Local Storage: total: 3.09 TiB used: 2.50 TiB (81.0%) 
           ID-1: /dev/sda vendor: Seagate model: ST2000DM001-1ER164 size: 1.82 TiB 
           ID-2: /dev/sdb vendor: Crucial model: CT1000MX500SSD1 size: 931.51 GiB 
           ID-3: /dev/sdc vendor: Samsung model: HD400LD size: 372.61 GiB 
Partition: ID-1: / size: 898.97 GiB used: 768.12 GiB (85.4%) fs: ext4 dev: /dev/sdb1 
           ID-2: swap-1 size: 17.19 GiB used: 177.8 MiB (1.0%) fs: swap dev: /dev/sdb2 
Sensors:   System Temperatures: cpu: 30.0 C mobo: 29.8 C gpu: nvidia temp: 34 C 
           Fan Speeds (RPM): cpu: 1461 fan-2: 768 fan-3: 0 fan-4: 0 fan-5: 0 gpu: nvidia fan: 54% 
           Voltages: 12v: N/A 5v: N/A 3.3v: N/A vbat: 3.12 
Info:      Processes: 274 Uptime: 4h 28m Memory: 15.63 GiB used: 7.72 GiB (49.4%) Init: systemd Compilers: gcc: 9.3.0 
           clang: 9.0.1 Shell: bash v: 5.0.16 inxi: 3.0.37

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by