Logitech G533 microphone not working in discord

Hello everyone,

I'm new to Manjaro (at least Manjaro i3-version) and I'm having trouble getting the microphone on my new headset Logitech G533 to work in discord. The audio playback works (i can watch youtube videos or hear other people speaking in discord), but the audio capture (microphone) doesn't work.

I'm using Manjaro i3.

I installed Discord through Octopi and AUR.

I selected the headset as the input device in the discord settings.

I selected non-free drivers on installation.

I also have a webcam plugged into my PC, and I can use it as a microphone for Discord. However, the quality is very bad and I want to use the microphone in the headset for better quality.

I would highly appreciate any help. If you need additional information, please ask!

Thank you very much, domisum

Try this

  • Launch Discord
  • Go in Settings > Voice & Video
  • Disable “Noise Suppression”.

Hope this help.

This didn't work, unfortunately. I also tried disabling Echo Cancellation and Automatic Gain Control, but the mic still doesn't work.

Backup and remove:

mv ~/.config/pulse ~/.config/pulse.old


1 Like

Didn't work. I still got the same issue.

Does it work in any other applications? (e.g. Audacity).

Open alsamixer in a terminal and check it is not muted.

Open pavucontrol and check there.

1 Like

Thanks for the continued help! So this happened:

I tried to open pavucontrol, as you suggested. It wasn't installed, so I fired up octopi and installed it. After the installation of the application the mic just started working. I don't have any issues now. I'm unsure what exactly fixed the problem, but everything works now, so I'm happy :wink:



This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by