Logout of openbox, shutdown from dm very fast; 'shutdown' within openbox very slow

I'm building up an openbox system, which was originally an LXQT install, and encountering a strange problem.

If I shutdown within openbox, in any way including the terminal, the shutdown is extremely slow -- minimum of 2 minutes, usually longer. But if I exit openbox and shutdown from the dm, the machine shutdown in about 3 seconds.

Before I realized this, I thought it maybe watchdog, which I blacklisted to no effect.

Other than that, I removed a lot of LXQT functionality, including the session itself. This may very well be related, but I can't figure out how. I know I'm hacking around and things would be a lot simpler if I had started with the Openbox edition! But hindsight is 20/20 and I pretty much have this openbox running great otherwise!

Any input would be greatly appreciated.

This is pure guessing as I have no idea.

It could be the lxqt-session used by lxqt but as you are no longer using lxqt you should use openbox-session instead.

Or there could be an environment variable related to lxqt.

Check /etc/lxdm/lxdm.conf - look for the session property

Thank you for taking the time.

It's an interesting fact, that /etc/lxdm/lxdm.conf no longer exists. Indeed, there is no /etc/lxdm directory at all.

I did find /home/tom/.config/lxqt/lxqt.conf, but that was completely innocuous, I believe:

[General]
__theme_updated__=1590419003223
__userfile__=true
icon_follow_color_scheme=true
icon_theme=Adwaita
theme=dark
tool_button_style=ToolButtonTextBesideIcon

[Qt]
font="Roboto,12,-1,5,50,0,0,0,0,0"
style=kvantum

I should have mentioned, I did install such packages as manjaro-openbox-common, manjaro-openbox-config, manjaro-openbox-desktop-settings, manjaro-openbox-scripts, etc. in the hopes of correcting this problem. It had no effect and I didn't even notice any difference in the least. They probably need some manual configuring.

Thanks again.

The openbox edition is using the lxdm display manager - but lxqt uses lightdm - I forgot.

So you would have to dissect the /etc/lightdm/lightdm.conf to verify if lxqt-session is mentioned there.

And you do know - I presume - that installing the configuration packages (openbox) - do not copy the files to your home? This has to be done manually from /etc/skel

OK. /etc/lightdm/lightdm.conf did indeed contain:
user-session=lxqt

Which I changed to
user-session=openbox

Unfortunately, this had no effect.

This isn't a huge problem, obviously. I can just exit the session first. However, I'm curious as to what it could be.

I also wonder why the shutdown processes are not displayed on the screen. It's just blank during the shutdown process. This was true in the original LXQT sessions as well. If I could see what it was doing when it hangs, that would be helpful.

Thanks again.

I do believe my computer has been trolling me.

It seemed the slow shutdown times only happened from within openbox, however, upon further evidence, this is not the case.

It occurs randomly, and does NOT seem to have anything to do with how or when I shutdown. This actually makes much more sense to me. Anything I'm doing in openbox as a regular user should not have had any effect on shutdown anyway.

This gives me hope it's solvable. I'm hunting around /var/log, but I can't find anything useful, doubtlessly because I can't figure out where to look. None of the logs are in the usual Debian places. I'm new to the whole Manjaro/Arch paradigm (and loving it).

Manjaro uses a couple of kernel command line options to minimize the amount of text displayed on screen.

Those are defined in /etc/default/grub and is quiet and udev.log_priority=3.

Edit the file and remove the options - then rebuild the grub configuration and restart your system

sudo grub-mkconfig -o /boot/grub/grub.cfg

Logs can be read using journalctl (using a less type pager) - example listing newest entries first - adding explanations

journalctl -xr

You can grep the output for a timestamp when you shut down your system e.g. June 9. at 17:42

journalctl -xr | grep 'jun 09 17:42`

Thank you very much. GRUB quiet. Yeah. I knew that... :flushed:

I'm not seeing anything at all relevant from the journalctl, but I can now see during shutdown the cause is a stop job of 1m30sec.

A stop job is running for Session 2 of user Tom

So the session does in fact seem to be related, at least in this reboot.

I did some searching around and it seems this problem started to crop up at kernel > 4.14ish, but the solutions vary widely and usually the message contains additional info, like video drivers, etc, for those folks which I'm not seeing.

Thanks for taking the time.

You could continue your search by disabling the display manager and setting the default target to multi user. This changes default behavior to TTY then login and run startx.

sudo systemctl disable lightdm
sudo systemctl set-default multi-user.target
reboot

If you still experience the behavior you need to look at the configuration for the session. And as you have remove lxqt you can safely uninstall everything lxqt related and remove the configurations from your ~/.config.

When you want to get back to a graphical login

sudo systemctl set-default graphical.target
sudo systemctl enable lightdm

EDIT

  • check your fstab
  • check your .config/autorun
  • check your /etc/xdg/autorun

Maybe you can spot something you know you don't use

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by