Low screen resolution after installing nvidia driver

I was using bumblebee but wanted to change, so I changed to the video-nvidia driver using mhwd. But after rebooting my notebook, the screen resolution become 960x540, when it should be 1920x1080. I tried many things, but nothing works.

What was your investigation when you did that?
On all dual GPU systems, this are the variants available at the moment, and should be followed accordingly, only one, and as described:
1.


2.

3.

4.

2 Likes

I followed exactly the second tutorial you showed, the prime one. But still the resolution is wrong.

I had to make sure, but now ... share inxi -Fxxxz from terminal
Did you installed the system in Legacy mode or UEFI mode ?
Is this issue specific to only Deepin DE ?

1 Like
System:    Host: quasar Kernel: 4.19.28-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 
           Desktop: i3 4.16.1 info: polybar dm: LightDM 1.28.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: Inspiron 15 7000 Gaming v: N/A serial: <filter> Chassis: 
           type: 10 serial: <filter> 
           Mobo: Dell model: 0KD43Y v: A01 serial: <filter> UEFI: Dell v: 1.6.0 date: 03/27/2018 
Battery:   ID-1: BAT0 charge: 68.5 Wh condition: 68.5/74.0 Wh (93%) volts: 12.5/11.4 
           model: SMP DELL 71JF453 type: Li-poly serial: <filter> status: Full 
CPU:       Topology: Quad Core model: Intel Core i5-7300HQ bits: 64 type: MCP arch: Kaby Lake rev: 9 
           L2 cache: 6144 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19972 
           Speed: 1100 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 1113 2: 1100 3: 1100 4: 1100 
Graphics:  Device-1: Intel HD Graphics 630 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:591b 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Dell driver: nvidia v: 418.43 
           bus ID: 01:00.0 chip ID: 10de:1c8d 
           Display: x11 server: X.Org 1.20.4 driver: modesetting,nvidia compositor: compton 
           resolution: 960x540~60Hz 
           OpenGL: renderer: GeForce GTX 1050/PCIe/SSE2 v: 4.6.0 NVIDIA 418.43 direct render: Yes 
Audio:     Device-1: Intel CM238 HD Audio vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a171 
           Sound Server: ALSA v: k4.19.28-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell driver: r8168 
           v: 8.045.08-NAPI port: d000 bus ID: 02:00.0 chip ID: 10ec:8168 
           IF: enp2s0 state: down mac: <filter> 
           Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Dell 
           driver: ath10k_pci v: kernel port: d000 bus ID: 03:00.0 chip ID: 168c:003e 
           IF: wlp3s0 state: up mac: <filter> 
           Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 1-4:3 chip ID: 0cf3:e007 
Drives:    Local Storage: total: 931.51 GiB used: 22.11 GiB (2.4%) 
           ID-1: /dev/sda vendor: Toshiba model: MQ02ABD100H size: 931.51 GiB speed: 6.0 Gb/s 
           rotation: 5400 rpm serial: <filter> rev: 1D scheme: GPT 
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 port: f060 
           bus ID: 00:17.0 chip ID: 8086.282a rev: 31 
Partition: ID-1: / size: 239.68 GiB used: 22.11 GiB (9.2%) fs: ext4 dev: /dev/sda8 
           ID-2: swap-1 size: 5.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda6 
Sensors:   System Temperatures: cpu: 46.0 C mobo: 40.0 C sodimm: 43.0 C gpu: nvidia temp: 44 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 147 Uptime: 1h 37m Memory: 7.66 GiB used: 1.38 GiB (18.0%) Init: systemd v: 241 
           Compilers: gcc: 8.2.1 alt: 7 Shell: bash v: 5.0.0 running in: urxvtd inxi: 3.0.32 

My system was installed in UEFI mode and I use i3wm not Deepin DE

Edit: I realized now that my account says I use Deepin DE, that was a while ago and I forgot to change it when I started using i3, sorry

the easiest way if it works is to just delete
~/.config/monitors.xml
and reboot, and if the monitors info can be read properly it will regenerate a new one. if that fails, then:

use xrandr to list monitors, laptop screen when using nvidia is usually eDP-1-1, just check and make sure. you can do something like this but you should really add the modeline to xorg configuration.

xrandr --listmonitors
xrandr --newmode "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
xrandr --addmode eDP-1-1 1920x1080
xrandr --output eDP-1-1 --mode 1920x1080

https://wiki.archlinux.org/index.php/Xrandr#Adding_undetected_resolutions

edit: corrected the xrandr commands, i forgot --newmode

3 Likes

Might want to update the user description then :wink:
And now i think you will be able to mark the proposal from @dglt as solved solution :smiley:

2 Likes

Thanks! It worked, the only thing I changed from your commands is that since the created mode is "1920x1080_60.00", when I added the mode and set the output, I only had to add "60_00" to the end.

xrandr --addmode eDP-1-1 1920x1080_60.00
xrandr --output eDP-1-1 --mode 1920x1080_60.00

You guys are really awesome! And sorry for my bad english, I am not a native speaker

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by