LSI Steam unable to launch

Yes. Exactly.

So.. That doesn't seem to do any good... Saddly..

Could it have something to do with my GPU drivers?
They have been making some problems with shadow of mordor and blender....

have you run a full update lately?

sudo pacman-mirrors -f5 ; sudo pacman -Syyu

which kernel/s do you have installed?

mhwd-kernel -li

Jup. I just built this computer this week.
And i just made another full update telling me, that there's nothing to be done.

mhwd-kernel -li
Currently running: 4.19.59-1-MANJARO (linux419)
The following kernels are installed in your system:
   * linux419

try a newer kernel

sudo mhwd-kernel linux52

reboot and select new kernel from the grub advanced options menu

allready tried that before.
But personally i'd prefer sticking to an LTS kernel.

But let'S try it out.

if this is all new hardware, the latest kernels what you want

So tried the 5.2 kernel and it still doesn't work...
And for some reason my GPU still has a way to old OpenCL version...

So you would recomend me using the newer kernels?
Doesn't that make my system unstable?
BEcause i use this system for my studies, i need it to be as stable as possible...

You can always change the kernel on boot from grub.
Also, minimum are two kernel, LTS + rc ...


1 Like

Okay. Thanks!
What is rc?

And for some reason with the new kernel my GPU has way lower performance..

release candidate, early version :slight_smile:

How exactly do i do that?

Use arrows key down, second position, enter, then you see all installed kernel. choose one and enter.

you mean in the boot menu?
If yes: How do i get there. My motherboard is only showing it's logo and not the typical manjaro grub.

On boot press ESC.

Do i have to do that every time it boots, oe does it remember, which kernel i last used?

You can set settings in grub, remember last OS, last kernel....
But I think it is time for you to read and search the web , forum.
These questions are 1,000,000,000,000 times answered :slight_smile: .

Thanks. Allot.:relaxed:

But somehow that still doesn't fix my problem with XCOM2 and Deus Ex MD...
COuld it have anything to do with my video drivers?
I just can't seem to upgrade them...

start with
inxi -Fxxxz

1 Like


System:    Host: BlueBehemoth Kernel: 4.19.59-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 Desktop: Cinnamon 4.2.2 
           info: polybar wm: i3 4.16.1 dm: LightDM 1.30.0 Distro: Manjaro Linux 

Machine:   Type: Desktop Mobo: Micro-Star model: B450 GAMING PLUS (MS-7B86) v: 1.0 serial: <filter> UEFI: American Megatrends 
           v: 1.70 date: 03/06/2019 
CPU:       Topology: 6-Core model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+ rev: 2 L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 81617 
           Speed: 2538 MHz min/max: 1550/3400 MHz boost: enabled Core speeds (MHz): 1: 2714 2: 3505 3: 3797 4: 3797 5: 2463 
           6: 1519 7: 3796 8: 3800 9: 2604 10: 3734 11: 2230 12: 1519 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] vendor: XFX Pine 
           driver: amdgpu v: kernel bus ID: 1c:00.0 chip ID: 1002:67df 
           Display: x11 server: X.Org 1.20.5 driver: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa 
           compositor: compton resolution: 2560x1080~60Hz 
           OpenGL: renderer: AMD Radeon Graphics v: 4.6.13568 Core Profile Context compat-v: 4.6.13568 direct render: Yes 
Audio:     Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] vendor: XFX Pine driver: snd_hda_intel 
           v: kernel bus ID: 1c:00.1 chip ID: 1002:aaf0 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel 
           bus ID: 1e:00.3 chip ID: 1022:1457 
           Sound Server: ALSA v: k4.19.59-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8168 
           v: 8.047.02-NAPI port: f000 bus ID: 18:00.0 chip ID: 10ec:8168 
           IF: enp24s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 4.77 TiB used: 1.93 TiB (40.4%) 
           ID-1: /dev/sda vendor: Kingston model: SV300S37A240G size: 223.57 GiB speed: 6.0 Gb/s serial: <filter> rev: BBF0 
           scheme: GPT 
           ID-2: /dev/sdb vendor: Seagate model: ST1000DM010-2EP102 size: 931.51 GiB speed: 6.0 Gb/s rotation: 7200 rpm 
           serial: <filter> rev: CC43 
           ID-3: /dev/sdc type: USB vendor: Western Digital model: WD My Passport 25E2 size: 3.64 TiB serial: <filter> 
           rev: 4005 scheme: GPT 
Partition: ID-1: / size: 201.80 GiB used: 50.85 GiB (25.2%) fs: ext4 dev: /dev/sda2 
           ID-2: swap-1 size: 17.24 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 73.5 C mobo: N/A gpu: amdgpu temp: 58 C 
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 2851 
Info:      Processes: 295 Uptime: 18m Memory: 15.67 GiB used: 2.73 GiB (17.4%) Init: systemd v: 242 Compilers: gcc: 9.1.0 
           alt: 8 clang: 8.0.0 Shell: zsh v: 5.7.1 running in: gnome-terminal inxi: 3.0.34 

But for some reason my opencl version is really old...

missing full sytem ..

System:    Host: mx Kernel: 5.2.2-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 Desktop: i3 4.16.1 info: i3bar 
           dm: LightDM 1.30.0 Distro: Manjaro Linux 

Forum kindly sponsored by