LXQT not booting after install: error you need to load the kernel first

Hi, I'd really appreciate some help with this. Back story: I have an old Asus 1001 pxd netbook with an Atom processor that I bought in 2012. Never worked well with Windows. Installed Lubuntu years ago and it worked passably. I've been very happy with Manjaro XFCE on my old Thinkpad, so I decided to try Manjaro on the netbook. I found LXQT on the Majaro site. It installed without a hitch and the netbook worked better than ever before. I was delighted! Problem was that the hard disk on the netbook was dying! So, I decided to buy and install a new SSD and reinstall LXQT.

Here's the problem. When I reinstall LXQT, and restart after reboot I get the following message: " /boot/vmi i nuz-5.2-x86_64 not found error: you need to load the kernel first: press any key to continue."

If I press a key it gives me 3 options: manjaro linux, advanced options for Manjaro Linux and Memory test. The adanced options gives me a choice of two kernels5.2.11-1-M and 5.2.11.1-MA. If I press on either it sends me back to the error message.

I'd really like to use LXQT as it seems lightweight and appropriate for an Atom netbook. But how do I get it to boot? Thanks!

Hello,

See here


or here

Thanks for the response. Are you talking about reinstalling? I have a live image on USB. What do I do first?

I'm not talking about reinstalling, i was pointing you to topics related on how to fix grub.

OK, this is all new to me. It appears I am in bios legacy.

You say "If it is not in uefi, use the install media boot menu grub, and again make sure it is in uefi." Can you explain what that is and how exactly I do that? Thanks

hi Bogdancovaciu, I really appreciate your help. I've looked at the links you sent me, but I'm afraid I don't understand what I need to do now. How do I set for uefi boot? What do I do next?

That you set in BIOS settings. In case you dual boot Manjaro and Windows, both have to be installed either in legacy if you set your BIOS that way, or UEFI if the BIOS is set that way.
For each case, the way you approach the GRUB BOOT fix has the same logic, but different steps because of the difference between them. I can't explain it better that those i linked in my first comment.

I don't see any setting in bios of my asus eee netbook for uefi. I've looked hard and I've also googled. What am I missing? Remember, before I replaced the SSD I'd installed LXQT without problem and it worked flawlessly. I also checked the USB stick and that IS set for fat 32 and UEFI.

"You need to load kernel first Technical Issues and Assistance, post:9, topic:117932"]
If it is not in uefi, use the install media boot menu grub, and again make sure it is in uefi"
I still don't know what to do here. I guess I'm a bit stupid about this, but I don't see anything about how to change to UEFI in the links.

Back when you installed it, maybe you used this how to
https://wiki.archlinux.org/index.php/ASUS_Eee_PC_1001px
so you kept the EFI partition.
Now with the new SSD, maybe you did not created it during install, so the links i provided are a bit confusing ...

1 Like

If output is pc , you've booted up in bios-legacy.
If output is efi , you've booted up in uefi.
If you're in the wrong mode, reboot livecd in the right mode.

  1. If you are in the right mode, continue.

Ok so I'm in the wrong mode, but I don't see instruction for how to fix that. The second link you send me doesn't go anywhere...


Where do you click on it? All links i provided are working.

There's no link

Have you click on the GREEN text ?

I think this is the heart of the problem. I just did a clean erase install so maybe I deleted the efi partition. If so, what can I do??

In that arch wiki there is this part:

1 Like

Look on the eeePC-Forum for it .

I don't see such a forum and a google search got me nowhere. Is it possible that by doing an install of LXQT in erase mode I've ruined the netbook?? I just paid $60 for the new SSD.

I see the second link by clicking on the green highlight, but the instructions make no sense to me at all. I really would appreciate some step by step help.

eeePC-Forum is a generic/universal/common description of multiple places where people discuss about eeePC ... is not a dedicated forum as this Manjaro forum is. For example, this would be one of those places

1 Like

I don't think the eee pc actually has efi capability. I came across this:

The eeePC is NOT an EFI system. Those are basically Apple Macs and some servers.

The "EFI" partition has nothing to do with the Extensible Firmware Interface . It just reuses the EFI partition id. and is used by the "Boot Booster" functionality.

So, can I return to my initial question please. What do I need to do, step by step, so that LXQT will boot. Is it something about the GRUB? I'm afraid I'm really lost here. Would another OS make a difference? I appreciate your patience but I guess I need some hand holding.

so can you boot on USB stick manjaro ,
open a terminal , and returns

inxi -Fxxxza 
parted -l 
efibootmgr
1 Like

Thanks Stephane. What is that supposed to do?

Forum kindly sponsored by