MA 20.0.2 and KDE Minimal - no network support

Got a laptop with RTL8821CE WiFi adapter. When running MA, adapter is detected and Internet connection works perfectly. However, after installing KDE Minimal (with 5.4 LTS kernel), adapter is not found in OS.

No big deal, I know this adapter usually needs additional drivers (available in AUR), but here's the problem - networking is not available at all. I have 2 more laptops using the same WiFi adapter, and my solution was always to connect Android phone via USB, enable USB tethering (so Manjaro detects new "wired" connection) and download Realtek drivers.

Not this time. It looks network support is completely not available - when I connect Android phone, Manjaro doesn't detect wired connection. I know USB works because other operations (charging, file copy, etc.) work fine. The worst part is that this particular laptop has no LAN port, so I can't just connect some cable to download drivers.

Tried 2 times, got the same result. Since Internet works during installation, I have 2 guesses:

  1. The issue is caused because I install KDE Minimal. However, I also installed KDE Minimal on other machines and both wired/wireless adapters worked fine. But these machines had LAN ports, and this one doesn't, so maybe Minimal installation doesn't install any networking packages at all? Should I go with Full?
  2. It's because of kernel. I guess MA 20.0.2 is initialized with 5.6 kernel, isn't it? But I choose kernel 5.4 during setup. Maybe that's the problem?

I understand a possible solution is to download drivers using other machine, copy them to USB stick, and install manually. But I'm wondering if someone else had similar issues and found the exact cause of this.

In addition, I tried installing KDE Full + Kernel 5.4, and KDE Full + Kernel 5.6 - no results. In all situations, WiFi works in MA itself, but once system is installed, WiFi adapter is not found, which is strange. What's even more strange, that in all situations Android USB tethering doesn't work at all (wired connection is not detected), so I'm stuck.

Any suggestions what should I try next?

There appears to be an issue with the architect installer not starting the NetworkManager service after installation.
To check if it is started:

sudo systemctl status NetworkManager

If it is not started:

sudo systemctl enable --now NetworkManager
2 Likes

Yes, that was it! Meanwhile, I started running inxi -IN, ip link and nmcli device show commands to include the results in this post, and the last one returned error about NetworkManager, then I saw your post and the issue was solved.

Once I enabled NetworkManager, tethering started working instantly. Thank you very much for the assistance!

P.S. Is it very recent issue? The last time I used MA was about a month ago (can't tell which version exactly, but it was 20.x for sure) on 2 machines, and had 0 problems with network.

1 Like

Yes. Some users noticed it within the last week. The Manjaro Team is working on it. Search the forum you will find a few topics.

Thanks for posting all, that solves my issue after an MA install without even searching :+1:

Just want to add that the bug in Architect that doesn't automatically start NetworkManager also doesn't start Bluetooth, so you'll have to systemctl enable --now bluetooth.service to get it going.

1 Like

Forum kindly sponsored by