Macbook Air 2013 5ghz wifi connection problem

Hi!

I installed Manjaro Linux onto my Macbook Air 2013, which has a bcm4360 wifi network controller. I've two routers, one from the ISP, and a Linksys EA8500 with latest dd-wrt. I can connect to the ISP's router, on channel 36, so 5 Ghz connection is working with the broadcom wl driver, but I'm unable to create an 5 Ghz connection with the Linksys router, only 2.4 Ghz is working. At first, I used the router with auto channel settings (the 5 Ghz connection appears on the scanning list, but during connect, NetworkManager reports that connection took too long and drops it), but I've googled the problem, and found that lower channels are preferred by the broadcom wl driver. but changing to channel 40 didn't fix the problem. From the same machine, MacOS, Windows 10 connects perfectly to the 5 Ghz channel in auto channel setting and manual channel setting too. I've tried manually connecting with netctl, but the result is the same. I tried the wifi channels from 36 to 64, I've tried without security, but it won't connect. The ISP router uses the same encryption type as the Linksys router (WPA2 PSK AES). I'm out of ideas, I use the latest stable version with 4.19 kernel, KDE, NetworkManager. Any help appreciated.

Start here :slight_smile:

1 Like

You didn't mention it, but if your network is hidden, unhide it. Also, check if there is a firmware update for your router. You also may want to reset your router to the factory settings and see if a connection is possible.

Please post:

inxi -Fxxxz

It's not hidden.

System:    Host: sipos-pc Kernel: 4.19.0-4-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: KDE Plasma 5.14.2 
           tk: Qt 5.11.2 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Apple product: MacBookAir6,2 v: 1.0 serial: <filter> Chassis: type: 10 v: Mac-7DF21CB3ED6977E5 
           serial: <filter> 
           Mobo: Apple model: Mac-7DF21CB3ED6977E5 v: MacBookAir6,2 serial: <filter> UEFI: Apple 
           v: MBA61.88Z.0107.B00.1804111137 date: 04/11/2018 
Battery:   ID-1: BAT0 charge: 28.8 Wh condition: 53.6/54.3 Wh (99%) volts: 8.0/7.6 model: SMP bq20z451 type: Li-ion 
           serial: N/A status: Charging cycles: 34 
CPU:       Topology: Dual Core model: Intel Core i5-4250U bits: 64 type: MT MCP arch: Haswell rev: 1 L2 cache: 3072 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 15205 
           Speed: 956 MHz min/max: 800/2600 MHz Core speeds (MHz): 1: 1132 2: 1137 3: 1194 4: 1105 
Graphics:  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Apple driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:0a26 
           Display: x11 server: X.Org 1.20.3 driver: intel unloaded: modesetting alternate: fbdev,vesa compositor: kwin_x11 
           resolution: 1440x900~60Hz 
           OpenGL: renderer: Mesa DRI Intel Haswell Mobile v: 4.5 Mesa 18.2.4 compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel Haswell-ULT HD Audio vendor: Apple driver: snd_hda_intel v: kernel bus ID: 00:03.0 
           chip ID: 8086:0a0c 
           Device-2: Intel 8 Series HD Audio driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:9c20 
           Device-3: Broadcom Limited 720p FaceTime HD Camera driver: facetimehd v: kernel bus ID: 02:00.0 chip ID: 14e4:1570 
           Sound Server: ALSA v: k4.19.0-4-MANJARO 
Network:   Device-1: Broadcom Limited BCM4360 802.11ac Wireless Network Adapter vendor: Apple driver: wl v: kernel port: efa0 
           bus ID: 03:00.0 chip ID: 14e4:43a0 
           IF: wlp3s0 state: up mac: <filter> 
Drives:    Local Storage: total: 233.76 GiB used: 12.69 GiB (5.4%) 
           ID-1: /dev/sda vendor: Apple model: SSD SM0256F size: 233.76 GiB speed: 6.0 Gb/s serial: <filter> rev: EA1Q 
           scheme: GPT 
Partition: ID-1: / size: 220.57 GiB used: 12.69 GiB (5.8%) fs: ext4 dev: /dev/dm-0 
           ID-2: swap-1 size: 8.35 GiB used: 256 KiB (0.0%) fs: swap dev: /dev/dm-1 
Sensors:   System Temperatures: cpu: 59.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 189 Uptime: 2h 45m Memory: 3.79 GiB used: 2.03 GiB (53.5%) Init: systemd v: 239 Compilers: gcc: 8.2.1 
           Shell: bash v: 4.4.23 running in: yakuake inxi: 3.0.27 

As this is a little older machine, you might want to test kernel 4.14. It is a good idea to have a Backup kernel installed anyways. Install kernel 4.14 with Manjaro Setting Manager.

Not that likely to fix things, but you need to cross the kernel off the list as a possibility.

1 Like

Thank you, I've read these earlier during googling, but found no solution to the problem.

If your connection properties are set to "Ad-hoc" change that option to "Infrastructure" in Network Manager.

tried it once more, with no result, activation took too long as usual.

It's in infrastructure mode, by default.

Just checking.

Make sure the 2.4 Ghz network connection does not have the 'Connect automatically when this network is available' option enabled.

Make sure to check the checkbox that is labeled: 'Automatically connect to this network when it is available' is enabled for 5G.

Problem is still pending, any solution is welcome.

HI Frankie.

Just a word of advice, please do not elevate your thread with an empty post. Bumping is against the forum rules, and while not strictly enforced, it is highly discouraged.

If you wish to raise your post the appropriate method is to post all of your troubleshooting efforts and new information you have discovered since your last post.

You did not even mention if you had tested other kernels as I'd suggested earlier, let alone any other things you have attempted. Perhaps search the internet for options that can be used with the broadcom modules. As I am not at home and only on my cell, I do not have my Broadcom notes handy.

I am not going to go looking for this stuff for you as I'm not your internet search assistant. Search for information, post any methods you have attempted, and maybe that will trigger a response that may help your situation.

1 Like

Forum kindly sponsored by