Manjaro 17.0-rc3 Installation fails

Hi, yesterday I tried a fresh install of Manjaro 17.0-rc3 on my Intel NUC7I3BNH.
Installation is not successful, I can't even start X, I'm always getting
"Failed to start login service."

Can you please help?

Bellow I posted what helped to someone who had similar problem. Buy your system may be different. You want to know what service failed and why. "What" part should be easy. Switch to tty: (run Ctrl+Alt+F2) and enter your user name and password. Then type this:

sudo journalctl -b

See the lines with word: "Failed" in it. What service says it is failed? You can redirect output into the file:

sudo journalctl -b > journalctl.txt

Output with errors should give a better clue

Searching the internet I found this, someone was in similar situation and solution was to disable gdm. Link:

First you need to switch to tty (Ctrl+Alt+F2), enter your user name and password and then in the terminal type:

sudo systemctl disable lightdm

Then reboot and try to load GUI with:


Probably after reboot you will need to switch to tty again before trying "startx"

Alternatively if you can't get to tty, then you would need to chroot into your system using your live media you used to install Manjaro with. Steps, how to chroot into your system are here:

Once chrooted you can proceed as before by disabling gdm with systemctl and trying to start gui with startx. Check that link for more details I posted first.

If this doesn't help then there is some graphic driver issue and someone else should help you. If this will help you to at least load gui, then someone else will help you with what to do next to permanently fix your issue

Assuming you have systemd, you didn't post your specifications with:

inxi -Fxzc0

1 Like

Hmm, it may well be a graphics driver issue as the platform is quite recent (Kaby Lake). But there are already firmware files for Linux for Kaby Lake which btw. work flawlessly with Xubuntu, here:

@philm Is it possible to include these firmware files in the dvd installer image? (Maybe also the files for skylake architecture?) That would be great!

Regards, Bernd

The exact system info with inxi would be more than helpful.
Stating something doesn't work won't help much.

Usually a problem with graphic drivers used. Try disable MHWD attempting to handle drivers for you and let X do it's thing, might work out better. You need to add the boot param systemd.mask=mhwd-live.service, on BIOS boot(colour graphics at boot choice) you can just type that and press enter, on UEFI (boot choices are just black/white text, no colour on the screen), press e on free drivers and go to the end of the line, add a space and then type the boot param and press enter.

Hi kwhali,

I tried what you said. These are the errors I get when trying to boot from dvd 17.0-stable:
Failed to start Login Service
Failed to start Avahi mDNS/DNS-SDStack
Failed to start Modem Manager

I can't even boot from DVD. I've tried many other distros, all of them boot just fine.
I've given up hope that manjaro will ever run on this NUC and decided to stay with Xubuntu on this one.

I've already wasted too much time on this.

Thanks for trying to help me! :slight_smile:

@artoo Since I can't boot Manjaro, I can only give you the output when the command is run under Xubuntu. Here it is:

System: Host: NCC-1701-D Kernel: 4.8.0-39-generic x86_64 (64 bit gcc: 6.2.0)
Desktop: Xfce 4.12.3 (Gtk 2.24.28) Distro: Ubuntu 16.10
Machine: Mobo: Intel model: NUC7i3BNB v: J22859-302
UEFI: Intel v: BNKBL357.86A.0036.2017.0105.1112 date: 01/05/2017
CPU: Dual core Intel Core i3-7100U (-HT-MCP-) cache: 3072 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9600
clock speeds: max: 2400 MHz 1: 595 MHz 2: 523 MHz 3: 552 MHz
4: 553 MHz
Graphics: Card: Intel Device 5916 bus-ID: 00:02.0
Display Server: X.Org 1.18.4 drivers: (unloaded: fbdev,vesa)
Resolution: 1920x1080@60.00hz
GLX Renderer: Mesa DRI Intel HD Graphics 620 (Kabylake GT2)
GLX Version: 3.0 Mesa 13.0.2 Direct Rendering: Yes
Audio: Card Intel Device 9d71 driver: snd_hda_intel bus-ID: 00:1f.3
Sound: Advanced Linux Sound Architecture v: k4.8.0-39-generic
Network: Card-1: Intel Ethernet Connection (4) I219-V
driver: e1000e v: 3.2.6-k bus-ID: 00:1f.6
IF: eno1 state: up speed: 1000 Mbps duplex: full mac:
Card-2: Intel Device 24fd driver: iwlwifi bus-ID: 3a:00.0
IF: wlp58s0 state: down mac:
Drives: HDD Total Size: 512.1GB (5.9% used)
ID-1: /dev/sda model: SAMSUNG_SSD_830 size: 512.1GB
Partition: ID-1: / size: 453G used: 13G (4%) fs: ext4 dev: /dev/sda2
ID-2: swap-1 size: 17.06GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 43.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 218 Uptime: 15 min Memory: 1537.5/15936.5MB
Init: systemd runlevel: 5 Gcc sys: 6.2.0
Client: Shell (bash 4.3.461) inxi: 2.3.1

same issues here installing 17.0 xfce x64 from an ISO, after the initial gui screen load, activating the install script and the login service failure messages start coming.

well, 3rd or was it 4th time was a charm, and instead of login service fails in managed to pass and enter the detailed installation phase, unfortunately as soon as the config was finished
/mnt configs

I hit enter and POOF, no more installer. Running task manager and nothing is happening.

Too bad was hoping to try this version out.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by