Manjaro 17.11.1 grub rescue after install

Installing Manjaro on a laptop that is MBR and had Windows 10 and Ubuntu 18.04 on it. I installed Manjaro with manual partition and deleted the Ubuntu BTRFS partition and installed Manjaro btrfs with mount point /. Installation sees fine but after reboot I get grub rescue.
Tried ls (hd#, msdos#) > set boot=(hd#,msdos(#of btrfs) > set prefix=( previous)/boot/grub and fails on insmod normal

How to install Monjaro dual boot on MBR with btrfs? Grub will not install properly. There is a 100mb NTFS partition at the front I think the laptop uses it for the recovery. There is an partition at end of hard drvie 21GB of recovery image of laptop.

Can not get grub to install. Gives me warning in manual partitioning about no FAT32 but I think my system uses MBR. Nothing about UEFI in the BIOS.
Any ideas?

Used dd to install Manjaro onto usb stick

Wishes don't always come true..
You have to be sure. Check:

grub> echo $grub_platform

and about btrfs

What does the live-media say? Does it has the option to search for BIOS entries are EFI entries?

output was efi.
Thanks for your help I was convinced this older laptop was BIOS. Tinkered more in the meantime.

So I made a extended partition as 3 primary partitions already used up by windows 10. Put FAT32 /boot/efi with boot and esp flag partitions and btrfs partition inside. Good news it installed and I was able to boot into Manjaro. However I did not see Windows 10 or Win 7 backup partions showing in grub.
Now I can not boot into win 10. One problem solved and another created. How to get grub to see windows?

Live media was prompting me about UEFI not satisfied. I got it installed as uefi but now win 10 disappeared from grub. One problem solved another still there.

Show some info:

inxi -SMDPI
fdisk -l
inxi -SMDPI
  Host: i2330m Kernel: 4.14.53-1-MANJARO x86_64 bits: 64 
  Desktop: Gnome 3.28.2 Distro: Manjaro Linux 17.1.11 Hakoila 
  Type: Laptop System: SAMSUNG product: 300E4A/300E5A/300E7A/3430EA/3530EA 
  v: 0.1 serial: <root required> 
  Mobo: SAMSUNG model: 300E4A/300E5A/300E7A/3430EA/3530EA v: FAB1 
  serial: <root required> UEFI: Phoenix v: 07QA date: 04/20/2012 
  HDD Total Size: 596.17 GiB used: 5.80 GiB (1.0%) 
  ID-1: /dev/sda vendor: Hitachi model: HTS547564A9E384 size: 596.17 GiB 
  ID-1: / size: 238.95 GiB used: 5.80 GiB (2.4%) fs: btrfs dev: /dev/sda6 
  ID-2: /home size: 238.95 GiB used: 5.80 GiB (2.4%) fs: btrfs 
  dev: /dev/sda6 
  Processes: 201 Uptime: 2m Memory: 5.74 GiB used: 598.4 MiB (10.2%) 
  Shell: bash inxi: 3.0.12 

Disk /dev/sda: 596.2 GiB, 640135028736 bytes, 1250263728 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0xe8a1bf42

Device     Boot      Start        End   Sectors   Size Id Type
/dev/sda1  *          2048     206847    204800   100M  7 HPFS/NTFS/exFAT
/dev/sda2           206848  704849919 704643072   336G  7 HPFS/NTFS/exFAT
/dev/sda3        704849920 1206175743 501325824 239.1G  5 Extended
/dev/sda4       1206175744 1250263039  44087296    21G 27 Hidden NTFS WinRE
/dev/sda5        704851968  705064959    212992   104M  b W95 FAT32
/dev/sda6        705067008 1206175743 501108736   239G 83 Linux

Partition table entries are not in disk order

It has windows 10 installed plus the original windows 7 restore copy that has been seen by Ubuntu as windows 7 but actually starts the restore process on the laptop. Now of course it has Manjaro installed as well.

That 's where I stop, since I have no helpfull experience with BTRFS, I just RTFM.
Last tip, please enclose text/terminal output in code blocks.
Use </> in post edit toolbar and edit your post, to be readable for the next ones.

It may help you reading this post about a custom grub config for getting WinOS at Grub. I can't promise it will work with BTRFS or what changes maybe needed.

Have fun and good luck! :stuck_out_tongue_winking_eye:

Thanks for your help. At least it might be easier fight with grub into a system I can boot in.

Try sudo update-grub from Manjaro install. Windows should be in Grub menu after that.

Tried sudo os-prober > update-grub. Nothing.

Reinstalled my system to preMonjaro state from clonezilla. Then disabled EFI in the BIOS and installed Manjaro in one BTRFS partition with mount point / and after installation Manjaro and all windows partitions are seen and work. I guess it supports EFI but everything was installed as BIOS-BOOT. Manjaro does not like to mix and match I guess.

Morning. Glad you got it solved.

As you've seen, the issue is not installing UEFI on a msdos disk. That's just what it is.
For msdos, install only in bios-legacy.
In gpt, install only in UEFI [1].

[1] - you can install bios-legacy in gpt with a flagged bios_grub partition but it is not (IMO) recommended (>2TB disk notwithstanding).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by