Manjaro 17 boots to grub command

I've spent over 12 hours reinstalling, repartitioning, following useless commands to install the stupid grub over again and again and again. All I get at boot is a grub prompt and no idea which of the thousand entries of gobbledy gook to try to boot it. All I can do is type reboot, hit F12, and reboot the live version from usb. I was able to boot just fine into windows and linux using crappy Fedora and Elemental. Fedora sucked but at least it booted. Is there an older version of this OS that actually works? Obviously a huge bug in this one. Since Arch requires a masters degree in computer science to even attempt to use it, I was thinking this might be a bit easier. So far, it's been a nightmare. Every other version works just fine so I know it isn't this computer that is hosed.

OK, so let's narrow this down a bit.

You can boot the installer image, so that bit works, which should mean your hardware will work.

Installation proceeds and (presumably) completes without saying there's an issue, so that bit seems to be working.

The bit that doesn't seem to be working is bootloader installation, so let's focus on that.

Can you provide some more information about your system and partition layout in case there's something obvious here? If you can load the live installer environment, open a terminal, type these commands, then paste the output in a reply:

inxi -Fxxxz

Just in case this helps, if you install e.g. 17.1.10 and update you don't need to reinstall 17.1.12. The version number matches the installer image release version, not the version of Manjaro itself.

At any grub prompt (Fedora, Elemental ...), can you get to a manjaro grub menu with....

grub> search.file /etc/manjaro-release  root
grub> configfile /boot/grub/grub.cfg

If yes, boot to Manjaro and continue from Step 6 here.

If system is uefi, make sure you do the 2 [Additional UEFI commands]
and provide the information required as stated in the link should you require more help.

If you cannot get to a manjaro grub menu, boot to Fedora and provide from its terminal

sudo efibootmgr -v
sudo parted -l
sudo blkid

(All disks information)
Go to file manager and provide contents of manjaro's /etc/fstab and /boot
State computer make and model.


have you got secure boot disabled

This worked. Thanks so much. I tried step 6 on last night. Difference was I wasn’t booted into the system and even chroot did no good. Your first 2 lines got it booted. Thanks again. Sorry for being so harsh in my post. I was just tired and frustrated.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by