Manjaro 18.04 KDE random freeze


From time to time i have issues with Manjaro, i cant really determine at which point this happens. It freezes completely, only thing i can do is hard reset. I believe that both times i have been running same apps, as it is my workstation, so the list is:

VS code,Postman, Skype, chromium, 2 npm scripts in terminator.

Hardware is AMD Ryzen 1700, Nvidia 970, 16gb ram

I tried googling this issue, but i could not find anything on the topic. Any ideas what might be the problem?

System:    Host: pho7on-pc Kernel: 4.19.49-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.3.0 Desktop: KDE Plasma 5.15.5 
           tk: Qt 5.12.3 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop System: Gigabyte product: B450M DS3H v: N/A serial: <filter> 
           Mobo: Gigabyte model: B450M DS3H-CF v: x.x serial: <filter> UEFI: American Megatrends v: F2 date: 08/08/2018 
CPU:       Topology: 8-Core model: AMD Ryzen 7 1700 bits: 64 type: MT MCP arch: Zen rev: 1 L2 cache: 4096 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 95844 
           Speed: 2046 MHz min/max: 1550/3000 MHz boost: enabled Core speeds (MHz): 1: 2046 2: 1637 3: 1291 4: 1357 5: 1298 
           6: 1344 7: 1365 8: 1782 9: 1694 10: 2000 11: 1287 12: 1343 13: 1470 14: 2191 15: 3341 16: 3399 
Graphics:  Device-1: NVIDIA GM204 [GeForce GTX 970] vendor: Gigabyte driver: nouveau v: kernel bus ID: 07:00.0 
           chip ID: 10de:13c2 
           Display: x11 server: X.Org 1.20.5 driver: nouveau unloaded: modesetting alternate: fbdev,nv,vesa 
           compositor: kwin_x11 resolution: 1920x1080~60Hz, 1920x1080~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: NV124 v: 4.3 Mesa 19.0.6 direct render: Yes 
Audio:     Device-1: NVIDIA GM204 High Definition Audio vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 07:00.1 
           chip ID: 10de:0fbb 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel 
           bus ID: 09:00.3 chip ID: 1022:1457 
           Sound Server: ALSA v: k4.19.49-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8168 v: 8.047.01-NAPI 
           port: f000 bus ID: 05:00.0 chip ID: 10ec:8168 
           IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 2.27 TiB used: 15.92 GiB (0.7%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 250GB size: 232.89 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> rev: 1B2QEXE7 scheme: GPT 
           ID-2: /dev/sda vendor: Seagate model: ST1000DM003-1CH162 size: 931.51 GiB speed: 6.0 Gb/s rotation: 7200 rpm 
           serial: <filter> rev: CC47 scheme: GPT 
           ID-3: /dev/sdb vendor: Seagate model: ST1000DM010-2EP102 size: 931.51 GiB speed: 6.0 Gb/s rotation: 7200 rpm 
           serial: <filter> rev: CC43 scheme: GPT 
           ID-4: /dev/sdc vendor: Kingston model: SUV500240G size: 223.57 GiB speed: 6.0 Gb/s serial: <filter> rev: 56RI 
           scheme: GPT 
Partition: ID-1: / size: 218.77 GiB used: 15.92 GiB (7.3%) fs: ext4 dev: /dev/sdc2 
Sensors:   System Temperatures: cpu: 53.4 C mobo: N/A gpu: nouveau temp: 16 C 
           Fan Speeds (RPM): N/A gpu: nouveau fan: 1627 
Info:      Processes: 325 Uptime: 1h 43m Memory: 15.68 GiB used: 4.96 GiB (31.6%) Init: systemd v: 242 Compilers: gcc: 9.1.0 
           Shell: bash v: 5.0.7 running in: yakuake inxi: 3.0.34 

Have you tried forum search ?

Have a look how to provide good information on your help request:

Thanks for the advice. I tried searching forum, did not find solution. Also, since im pretty new to Linux, i have no idea what code should i post, in regards to this problem, so if you have a command that i could input in terminal, i would be happy to provide response

Post the inxi -Fxxxz first, as suggested in the link above, then we move from there.

Oh, i apologize. I edited original post, and pasted inxi output

Things you can try.
First update your system using

sudo pacman-mirrors -f5 && sudo pacman -Syyuu

1 install non free nvidia driver
2 install kwin-lowlatency from aur.
3 update your bios
4 set swappiness to low like 5
5 set CPU governor to performance.

Freezing is mostly related to nvidia

May be you can try this

You could try installing
Package from aur.
It will enable some services.
And have performance settings included.

But you will need to create new user to see the changes

I completed first 5 points, hopefully there wont be an issue from now on. Thanks a lot! Couple of questions though.

  1. Now my cpu average clock is around 3000, even though usage is 0-1%. Is that bad for cpu longevity?
  2. if i install manjarowish-dark-kde-settings can i save all settings and preferences that i currently have, or do i have to start from scratch, since i have to create new user?

Your existing settings will be with your current user.they won't be changed
Only new user will get those settings.

Its okay to use performance governor.
It won't make much difference on CPU life as you are not overclocking it
Just using it without restrictions

1 Like

Ok thanks for the advice.

I have to mention if some other newbie comes here, i had issues after installing nvidia drivers, as apparently they were out of sync with the kernel, so i had to update my kernel from 4.19(which was default i never wanted to touch that) to 4.9.

Now my question is, should i use some newer version, like 5.1 or something like that, and also, which kernel should be a fallback?

Always have two kernels installed
One LTS another latest stable.
You can try kernel 5.2
Use LTS 4.19 as fallback

1 Like

that is what i thought as well. Thanks a lot!

i did al those things you said i should. i am using 5.1 kernel. I had another random freeze. Do you maybe have an idea what should i do, or paste some error log or something

Do you use swap
If so is it on ssd
And is your home on ssd?

this is output of fdsik -l

Disk /dev/sdc: 223.6 GiB, 240057409536 bytes, 468862128 sectors
Disk model: KINGSTON SUV5002
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: C2DBA2F0-97C0-4E94-9F10-268A76155DAD

Device      Start       End   Sectors   Size Type
/dev/sdc1    4096    618495    614400   300M EFI System
/dev/sdc2  618496 468857024 468238529 223.3G Linux filesystem

so i guess i did not enable swap when i installed manjaro

Is your /home separate ??

Also check the output of

free -h

When freezing occurs

Also have you enabled systemd-swap
It should have been enabled if you installed settings package.

i treid looking at these files:


they are empty.

About that command, when my pc freezes, i can only hard restart it, did you mean after restart to try that command or?

I choose default option when i installed Manjaro, which was delet disk, so i assume /home is not separate

It means you are probably using all the ram
And as swap is not enabled.
It causes hard restart.
So you should enable systemd-swap
Read here for its config

It does not cause hard restart, i am forced to hard restart, because system is not responsive. And about full ram usage, i find that unlikely, first of all, i have ram monitor on all the time in my panel, also, i have 16gb of ram, i almost never go over 8gb

Well I'm out of ideas
You probably have to check what's causing freeze.
And I do think its mostly related to nvidia.
If not its ram issue.

You can try resetting bios settings to factory default.

I am also having troubles shutting down pc and rebooting via gui, i have to type poweroff in order for pc to shutdown, otherwise my cpu just keeps running. You think these two things can be related? Thanks anyway for trying to help :smiley:

Forum kindly sponsored by