Manjaro Architect: Can't install grub

Hello,

I am trying to install grub + os-prober (I've tried just plain grub too), but it giving me an error.

These are my options to select a device for grub installation:

/dev/sdb is my Windows Drive

/dev/sdb (GPT)

  • /dev/sdb1 (450 MB Recovery)
  • /dev/sdb2 (100 MB EFI, mounted to /boot/efi)
  • /dev/sdb3 (232.33 GB Windows Main)
    /dev/sdc (GPT)
  • /dev/sdc1 (232.9 GB Manjaro, mounted to /)

Now here... I assume I am supposed to install grub + os-prober in my Manjaro device (/dev/sdc), or am I supposed to select the device with the EFI partition and Windows partition, which is in /dev/sdb?

Either way, whether I select /dev/sdb or /dev/sdc, the below happens:

Does anyone know how to fix this?

You have booted install media in bios-legacy.

See this for more details.

I think your formatting is broken.

Yeah... I thought that was the issue, because I had GPT issue when installing Windows 10, when I didn't boot my USB in UEFI. But the issue is that when I try to boot my live Manjaro in UEFI, this is what happens:

I never had this issue when we had our old boot screen. With the new boot, I keep getting the above when booting in UEFI. New boot being the below borrowed from here:

I created my live boot with rufus as I always do. This happens with both the Manjaro Architect ISO and the Manjaro KDE ISO.

Corrected my formatting. Sorry.
Oh as for rufus, others have reported you need to set to 'dd' not 'iso' in using rufus in this new grub installer.
I don't use any usb boot (other than rarely --> dd bs=4M if=xxxxx of=yyyyyy)

That worked! Thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by