Manjaro-Architect UEFI Installation


i try over two hours now to install Manjaro with Architect :smile:.
I have done that on a virtual machine before and it worked well.

im using the tutorial

i prepared my SSD with gparted as gpt and the following partitions

  • sda1 vfat 750MB
  • sda2 ext4 30GB
  • sda3 swap 8GB
  • sda4 ext4 194,2GB

i have done everything it is written in the tutorial also i started with mounting my sda2 for root.
but i tried to install grub and did not get the option to choose between ‘grub’ or ‘grub + os-prober’. i can choose between grub / refind and systemd-boot. but if i choose grub than he automatically chose grub for efi thats fine than comes the first Error window
[grub-install --target=x86_64-efi][1] Installing for x86_64-efi platform.

than the system ask me to move some files that grub can be set as default bootloader i say yes and than the following error pops up
[Install GRUB][1] cp: cannot stat '/boot/efi/EFI/manjaro/grubx64.efi' : No such file or directory

After the error message the system tells me that GRUB has been set as default bootloader.

If i try to Generate FSTAB as next step the next error appears.
I choose the 3 Option (i dont know if i need 4 for my UEFI system)

[generate_fstab][255] ==> ERROR: /mnt is not a mointpoint

so after that i checked my previous steps. and one thing i saw is that my root partition have the mountpoint /mnt/boot.
i dont know if that is correct or i have done something wrong. i just followed the tutorial step by step :disappointed_relieved:

I'm far from an expert with this stuff, @gohlip is the guru when it comes to boot setups.

I think generally for a UEFI install a fat32 partition of 500MB or more is recommended. With grub installed to /boot/efi/. Looks from the error you haven't done that properly.

As I stated I'm no expert with this stuff, so hopefully the real pros will stop by to help you.

Best of luck

1 Like


i looked around in the forum and i think i made a mistake by choosing the USB-Drive. in my UEFI-System the USB displays 2 Partitions of UEFI. i choosed the second one.

now i am trying the first partition maybe it will work..... :sunny:

okay im stupid. my fault....
it was the partition of the usb stick hmpf...

thanks @oberon for the good guide.
now i can try to work with deepin minimal .-)



801 Mbit memory vs 2 GB + on the normal .iso installation is there any reason for that? :scream:

MA usually provides a much smaller more memory efficient install. You may be missing some components you might want, but there's no junk you don't want. :+1:

800M ram usage for deepin is normal, especially with nvidia. Something is wrong with that iso if it eats 2G

1 Like

so after i installed Deepin with Architect i used rEFInd as bootloader.

i started the computer and switched from left to right and right to left and the rEFInd bootloader freezes. so i made a reinstallation with architect to use GRUB as default bootloader.

so i choose GRUB as bootloader than the system ask to move some files for EFI Boot i say yes. i make the fstab with UEFI UUID

than i will finish the installation and the system tells me that i do not have a bootloader installed.

in my BIOS/UEFI menu of ASUS the SSD is marked as "rEFInd blabla" if i try to boot from the SSD its directly go back to the menu

The $esp should be mounted as /boot/efi; not /boot

1 Like

i have done that.

if i install rEFInd additional to GRUB it find the GRUB Bootloader. i can choose grub to boot and than i see the normal GRUB Bootloader.

but if i do not install rEFInd and try to boot from the SSD it will not boot :-1:

and the boot partition is marked as boot / esp


i booted in my Linux Mint rescue installation :smiley: and updated grub there.

after reboot i tried to select Manjaro

If you can boot into Manjaro (now, I'm not sure), boot into it.
If you cannot boot into Manjaro but into Linux Mint, do that.
But tell us what OS are you are reporting from.

At terminal, provide

sudo efibootmgr -v 
sudo parted -l
sudo blkid
findmnt -s
findmnt /boot/efi

If that is from LM terminal, go to file manager and give contents of Manjaro's /etc/fstab.

ps: refind has that similar ability to 'detect EFI files' as the grub in the Manjaro install media,
Also you can boot manjaro this way or that way, the same way as rEFInd boots yours.
But it's okay any way you boot up Manjaro. And it's also okay if you cannot find a way to boot up Manjaro. Just boot up LM and go from there.

ps: Booting up Manjaro from other OS grub (LM) will result in kernel panic (without modification).
Don't worry about it now.

1 Like

okay thanks i tried it about 4 hours now.

i will give up. i installed rEFInd again and it works directly without installing grub.
i dont know what the problem with GRUB is but rEFInd works directly without problems....

now i will try to autoselect manjaro with rEFInd and boot after some seconds.

we will see.

but the system works well. just the bootloader (GRUB) is a problem

Ok. As long as it works.

ps: I'm still a bit confused.

Does it not autoselect manjaro? What does it auto select? LM? And when you select manjaro, does any grub appears? The output from commands in my previous post from manjaro terminal will help me understand. But if you're happy and it is settled, it's fine with me.

1 Like
sudo efibootmgr -v
BootCurrent: 0002
Timeout: 1 seconds
BootOrder: 0002,0001,0005,0003,0007,0008,0006,0000,0009
Boot0000* Windows Boot Manager	HD(2,GPT,8f0bc46c-18e5-4db8-9a32-13bad3b8fb51,0xe1800,0x32000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}...7................
Boot0001* ubuntu	HD(2,GPT,8f0bc46c-18e5-4db8-9a32-13bad3b8fb51,0xe1800,0x32000)/File(\EFI\UBUNTU\SHIMX64.EFI)
Boot0002* rEFInd Boot Manager	HD(1,GPT,e2e4292b-e3a8-4ab9-98ad-f7d6359b2b85,0x800,0x177000)/File(\EFI\refind\refind_x64.efi)
Boot0003* CD/DVD Drive	BBS(CDROM,,0x0)..GO..NO........o.A.S.U.S. . . . . .D.R.W.-.2.4.F.1.S.T. . . .a....................A...........................>..Gd-.;.A..MQ..L.1.S.L.0.8.6.F.E.0.A.Q.0.R.5. . . . . . ........BO
Boot0005* Hard Drive	BBS(HD,,0x0)..GO..NO........o.W.D.C. .W.D.>..Gd-.;.A..MQ..L. . . . .W. .-.D.C.W.V.A.X.>..Gd-.;.A..MQ..L. . . . . . . . . .W.D.1.0.E.Z.E.X.-.7.5.M.2.N.A.0....................A...........................>..Gd-.;.A..MQ..L. . . . .W. .-.D.C.W.3.C.4.F.H.N.T.X.U.D........BO
Boot0006* UEFI: Generic Flash Disk 8.07	PciRoot(0x0)/Pci(0x14,0x0)/USB(1,0)/CDROM(1,0xfc6f4,0x8000)..BO
Boot0007* UEFI: Generic Flash Disk 8.07, Partition 2	PciRoot(0x0)/Pci(0x14,0x0)/USB(1,0)/HD(2,MBR,0x0,0xfc6f4,0x2000)..BO
Boot0008* USB	BBS(HD,,0x0)..GO..NO........S.G.e.n.e.r.i.c. .F.l.a.s.h. .D.i.s.k. .8...0.7....................A.......................&..Gd-.;.A..MQ..L.7.7.C.B.4.9.F.D........BO
Boot0009* UEFI OS	HD(1,GPT,e2e4292b-e3a8-4ab9-98ad-f7d6359b2b85,0x800,0x177000)/File(\EFI\BOOT\BOOTX64.EFI)..BO
sudo parted -l
Modell: ATA Crucial_CT250MX2 (scsi)
Festplatte  /dev/sda:  250GB
Sektorgröße (logisch/physisch): 512B/4096B
Partitionstabelle: gpt

Nummer  Anfang  Ende    Größe   Dateisystem     Name  Flags
 1      1049kB  787MB   786MB   fat32                 boot, esp
 2      787MB   33,0GB  32,2GB  ext4
 3      33,0GB  41,6GB  8590MB  linux-swap(v1)
 4      41,6GB  250GB   208GB   ext4

Modell: ATA WDC WD10EZEX-75M (scsi)
Festplatte  /dev/sdb:  1000GB
Sektorgröße (logisch/physisch): 512B/4096B
Partitionstabelle: gpt

Nummer  Anfang  Ende    Größe  Dateisystem  Name  Flags
 1      1049kB  524GB   524GB  ext4
 2      524GB   1000GB  476GB  ext4

Modell: ATA WDC WD5000AVDS-6 (scsi)
Festplatte  /dev/sdc:  500GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: gpt

Nummer  Anfang  Ende   Größe   Dateisystem     Name                          Flags
 1      1049kB  473MB  472MB   ntfs            Basic data partition          versteckt, diag
 2      473MB   578MB  105MB   fat32           EFI system partition          boot, esp
 3      578MB   595MB  16,8MB                  Microsoft reserved partition  msftres
 4      595MB   251GB  250GB   ntfs            Basic data partition          msftdata
 5      251GB   252GB  1000MB  fat32                                         boot, esp
 6      252GB   287GB  35,0GB  ext4
 7      287GB   295GB  8000MB  linux-swap(v1)
 8      295GB   500GB  205GB   ext4

Modell: Generic Flash Disk (scsi)
Festplatte  /dev/sdd:  4028MB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: msdos

Nummer  Anfang  Ende   Größe   Typ      Dateisystem  Flags
 1      32,8kB  529MB  529MB   primary               boot
 2      529MB   534MB  4194kB  primary               esp

sudo blkid
/dev/sdb1: LABEL="Speicher" UUID="7ea726d7-ed3e-4dd1-9bb7-cab8c608a648" TYPE="ext4" PARTUUID="3a19f2f6-bfe1-40e3-82e1-5c146b9877ad"
/dev/sdb2: LABEL="Backup" UUID="6fa9cd33-25c0-44d5-b790-0cbf6adb8460" TYPE="ext4" PARTUUID="85abbec5-ba44-482f-a7b8-07fd421728e4"
/dev/sda1: UUID="6069-0FCF" TYPE="vfat" PARTUUID="e2e4292b-e3a8-4ab9-98ad-f7d6359b2b85"
/dev/sda2: UUID="0f036547-898c-45df-9b86-b2b1c9c638fa" TYPE="ext4" PARTUUID="04ca86db-8679-4788-891c-654edd303235"
/dev/sda3: UUID="b9e6ca69-f9aa-4465-8b39-5bd62af5bcde" TYPE="swap" PARTUUID="8f12f283-4971-43ce-a31a-0621c82df011"
/dev/sda4: UUID="a708081f-48fd-454b-abba-f36b4e6e23ba" TYPE="ext4" PARTUUID="b0cad6d3-d94c-4c1d-8eae-1d3eab73bd26"
/dev/sdc1: LABEL="Wiederherstellung" UUID="282A2A4D2A2A17F8" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="a94231a3-b03d-40b2-8c7f-8c97f2ab6e06"
/dev/sdc2: UUID="C82B-D785" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="8f0bc46c-18e5-4db8-9a32-13bad3b8fb51"
/dev/sdc3: PARTLABEL="Microsoft reserved partition" PARTUUID="5477a275-5d87-4de2-a7af-18ca8f81bce0"
/dev/sdc4: UUID="9EB62E37B62E0FF7" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="5a14df8d-35c4-4d5c-a00e-d6438a01a687"
/dev/sdc5: UUID="C221-D150" TYPE="vfat" PARTUUID="b9fd5b16-0684-40b8-8887-d52e79a4ee53"
/dev/sdc6: UUID="94337f53-44c5-43ae-ad1c-99e024c48244" TYPE="ext4" PARTUUID="271baabd-be13-471a-8a28-f07ccc9e87c0"
/dev/sdc7: UUID="ebebd646-fecd-4c52-a088-eabee3e89796" TYPE="swap" PARTUUID="1365c422-b81c-483f-9677-75c3c254287c"
/dev/sdc8: UUID="601404ae-f2fd-4112-9ca8-32277e205ad1" TYPE="ext4" PARTUUID="8a86ee32-7647-458f-b5ec-c8e4e049a0d2"
/dev/sdd1: UUID="2018-03-31-21-00-12-00" LABEL="MJRO1717" TYPE="iso9660"
/dev/sdd2: SEC_TYPE="msdos" LABEL="MISO_EFI" UUID="5A44-D204" TYPE="vfat"

findmnt -s
TARGET    SOURCE                                    FSTYPE OPTIONS
/         UUID=0f036547-898c-45df-9b86-b2b1c9c638fa ext4   rw,noatime,data=ordered
/home     UUID=a708081f-48fd-454b-abba-f36b4e6e23ba ext4   rw,noatime,data=ordered
/boot/efi UUID=6069-0FCF                            vfat   rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro
none      UUID=b9e6ca69-f9aa-4465-8b39-5bd62af5bcde swap   defaults,pri=-2

findmnt /boot/efi
/boot/efi /dev/sda1 vfat   rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro

thank you for your help @gohlip :heart:

Ah.. I get it. Your refind $esp is mounted as /boot/efi. Okay. Thanks for the output.
You have to choose (select) at refind menu what to boot.

My refind $esp is mounted as /boot and I'm sharing this ($esp) with systemd-boot as well.
For your information my details as follows..

 pop  ~  ls /boot/
'System Volume Information'/           initramfs-linux-fallback.img*
 efi/                                  initramfs-linux.img*
 grub/                                 intel-ucode.img*
 loader/                               linux416-x86_64.kver*
 memtest86+/                           linux417-x86_64.kver*
 syslinux/                             refind_linux.conf*
 initramfs-4.16-x86_64.img*            vmlinuz-4.16-x86_64*
 initramfs-4.17-x86_64-fallback.img*   vmlinuz-4.17-x86_64*
 initramfs-4.17-x86_64.img*            vmlinuz-intman*
 initramfs-intman.img*                 vmlinuz-linux*
 pop  ~  ls /boot/efi/
BOOT/  refind/  systemd/  systemd-boot/  tools/
 pop  ~  ls /boot/efi/refind/
icons/         icons-my/  BOOT.CSV*     refind.conf-sample*
icons-backup/  keys/      refind.conf*  refind_x64.efi*
 pop  ~  

Take care, zarbol, enjoy your manjaro and cheers.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by