Manjaro ARM 18.12.1 released!

Manjaro ARM 18.12.1 released!

I am proud to announce the immediate availability of Manjaro ARM 18.12.1.

This release includes the first real release for the Pinebook, which is a $99 ARM laptop based on a Pine64 board.



New images are available.

Torrents are also available from the same location.

User Password
root root
manjaro manjaro


  • New kernels and packages all around.
  • All editions have received a nice facelift.
  • Using Firefox instead of Falkon.
  • Using LibreOffice instead of Calligra
  • Using Featherpad instead of Notepadqq (LXQT only)
  • Using NetworkManager/NMTray instead of Connman/CSMT (LXQT only)
  • Using Pamac instead of Octopi (KDE only)
  • GTK3 themes should now be present and set.
  • Added Baka-Mplayer.
  • Changes to settings regarding sound.

Updating from 18.10:

  • Old releases should just keep on rolling.
  • If you want the 18.12 experience, I recommend re-installing the system.

Known issues:

  • timedatectl can not be used to set timezone and time. Therefore Manjaro Settings Manager can't either. Manually changing the symlink of /etc/localtime does work.
  • localectl does not work either. So I have removed Manjaro Settings Manager from this release, since only user accounts function worked.
  • No lockscreen installed (LXQT only).
  • CSD on some GTK3 apps does not work properly.

What about other devices?
I stopped maintaining armv7h images in general. So many issues relating to it, that I simply won't bother creating the images and packages anymore.

I am working on a few new devices to support. Including the rock64 and the rockpro64.

I might also release some MATE images this cycle. But I am not a MATE user, so it won't be very polished.

Please consider supporting us via Patreon or by our other options.


Great job downloading now. Cant wait for the rockpro64.

1 Like

Great, thank you @Strit :slight_smile: Will you make a post over at PINE64 forums re this realease ? - if not, I can do it on your behalf.


I don't have a user on that forum, but you are welcome to "repost/link" this over there. :slight_smile:

1 Like

So glad you mentioned these issues as a four days before this announcement I had installed 18.10 KDE to run from USB storage (as in my earlier post Root ‘/’ on Btrfs USB storage, how?) but could not get Manjaro Settings Manager to change any settings and thought I had done something wrong with the install. There may have been a couple of other problems too, but...

I plan for a new install of Manjaro ARM 18.12 KDE, also to USB storage and hopefully without problem. Thanks for the new release folks :slightly_smiling_face:

Hm. Just noticed that the resize-fs service is not enabled on these images.

I will have to create new images to get that going...

EDIT: Fixed in 18.12.1!

Knowing that the Pis are widely available and not having proper support for them is somewhat regrettable. As much as I love Manjaro (and its ARM spin off), guess I'll have to switch to Arch for proper support. Thanks for the hard work anyways!

I still do rpi3 images... Those are aarch64 based.

I did it :stuck_out_tongue:

1 Like

Really nice distro. I’m using it daily on my new pinebook


I would like to buy a pinebook to test manjaro on it.

I tried pinebook website and did a build to order subscription but didn't get any reply. So just want to ask if they still selling it?

I'd be happy to do testing of manjaro arm on it. As I am very keen on having linux specially manjaro on arm based devices.. hopefully a mobile phone in future.

They are still selling it.

They are doing the build on order thing, so they will wait until they have a batch ready, for you to get your redeeming code.

I think I read on Matrix that the next batch would be ready somewhere in January.

Oh Great. thats not too far.

I will wait for them to reply to me.

I noticed the other day, that the Odroid C2 images, does not have HDMI output.

So when it is booted, please SSH into it and do the following:

sudo pacman -Syyu amlogic
sudo systemctl enable amlogic
sudo reboot

This will install what is needed, enable it and reboot the device.
HDMI output should now work.
If you use the Odroid headless, this is not needed.

i want to know if the ssh is enabled out off the box?

SSH is enabled by default. So you should be able to just plug it in, find out what IP it has from the router and then SSH in with user manjaro and password manjaro.

1 Like

I'm a little bummed to hear that, I had been waiting for an update to NetworkManager on the next release only to discover that my PI2 isn't supported anymore. I can understand the need to cut out the problematic code base and the need to simplify the project, I'm just disappointed that my hardware is pretty much obsolete for what I wanted to use it for... I can still buy a PI3, but it kinda defeats the point of why I wanted to put Manjaro on my PI2. Ubuntu-Mate is still on 16.04 (Stale) and firefox is completely broken (even updating doesn't fix it.), which has left it entirely unusable. I don't like Raspbian at all and anything else is too specialized or niche to be a day to day OS for me. At least some people can still benefit from the updates though and I'm glad pinebooks are seeing some support. Keep up the good work.

Well, it's not supported anymore in the sense that I don't do images for the rpi2 anymore and I don't build armv7h packages anymore.
The armv7h repo should still update with the packages recieving from Arch Linux ARM.

I've never been able to convert a system from Manjaro to an Arch package base successfully, there are always too many bugs/errors or hoops to jump through to get it functional again.

I am working on a new rpi2 minimal image, so keep an eye out! :stuck_out_tongue:

1 Like

Forum kindly sponsored by