Manjaro ARM 19.08 released!

Manjaro ARM 19.08 released!

I am proud to announce the immediate availability of Manjaro ARM 19.08.

With this release we are proud to add 2 new devices to our offerings.

The long awaited Raspberry Pi 4 and the very powerful Khadas Vim 3.

The Raspberry Pi 3 versions can still be installed with manjaro-arm-installer.

This is also the first release, with an updated XFCE edition!

New eMMC flash image for Pinebook

It's an image for supported laptops designed to flash Manjaro ARM to the built-in eMMC module, so you don't have to fiddle with DD and/or take out the eMMc module yourself.

Right now an image for the Pinebook is available in the download folders linked below, but will be named emmc-installer in addition to the regular filename.

OEM Setup

This release sports the custom install option for all images. This means that at first boot, you will be asked about the following:

All images require keyboard and screen attached on first boot to complete the setup!

  • username
  • additional user groups
  • full name
  • password for that username
  • password for root
  • timezone
  • locale
  • keyboard layout (except on pinebook, that is fixed to us layout)
  • hostname

Then the setup script will set these settings and reboot to the login screen.






Torrents are now avialable again!


  • New kernels and packages all around.
  • XFCE 4.14
  • KDE/Plasma 5.16.4
  • New theme! Now using Matcha from @cscs.
  • Fixed the boot delay on rk3399 with a patch in linux-aarch64-rc. Patch does not work on 5.2.

Updating from 19.06:

  • Old releases should just keep on rolling.
  • If you want the 19.08 experience, we recommend re-installing the system.
  • Please install archlinux-keyring before updating.

Known issues:

  • No audio cards on Pine64-LTS, Odroid-C2, Rock64 and Khadas Vim3.
  • Rock64 rev3 does not boot from SD cards. Need correct uboot patch. (Fixed with uboot-rock64-2019.10-rc3)
  • Wireless is not working properly on the Khadas Vim 3.
  • Raspberry Pi 4 still has no GPU acceleration (waiting on upstream to add that to 64-bit)
  • RK3399 based boards (RockPro64 and Rock Pi 4) has increased boot time (around 3 minutes) due to a kernel bug. Bug is patched in >5.3-rc3.

Supported Devices:

  • Raspberry Pi 4 (tested on B)
  • Raspberry Pi 3 (tested on B)
  • Odroid C2
  • Odroid N2
  • Rock64
  • RockPro64
  • Khadas Vim 3
  • Pinebook
  • Rock Pi 4
  • Pine64-LTS / Sopine (tested on Pine64-LTS board)

What about other devices?

Manjaro ARM no longer supports the armv7h architecture. So if you have/use an armv7h device, you should be looking at other distro's. Some could be:

  • Arch Linux ARM
  • Armbian
  • Raspbian (for the raspberrypi)
  • Ubuntu Mate
  • Parabola

The armv7h repo has been removed from the repo server and mirrors.

I won't be making images for all the supported devices. If your desired image for your desired supported device does not exist, please use manjaro-arm-installer to install it to an SD/eMMC card.


Please consider supporting Manjaro ARM via Patreon, Ko-Fi or to Manjaro's Paypal.


Just a notice that my 'matcha' has been renamed and moved to Matchama due to the new but more directly related


Thanks for the heads up!
It's not in the repo yet, though.

No boot on RockPro64 for all the three images (with a waiting of about 5 min).
Thanks for the help.

Thanks for reporting. We are looking into it.


Manjaro arm 19.08 for odroid n2 kde edition installed on a emmc module, nice job manjaro, congratulation!

it boot without screen (not the c2 for the moment)

feedback :

[nln2@n2 ~]$ lsblk -f
├─mmcblk0p1 vfat BOOT FBC7-FECF 173,8M 19% /boot
└─mmcblk0p2 ext4 ROOT 28bd7a92-0522-468c-9589-404551be0325 43,2G 20% /
[nln2@n2 ~]$ uname -a
Linux n2.19.08 4.9.177-2-MANJARO-ARM #1 SMP PREEMPT Sun Jun 2 21:24:06 UTC 2019 aarch64 G

Enjoy !

1 Like

Manjaro ARM rpi 4, booted only into root user, UI looks very old and also when i used your preview it doesn't heat much but now board gets heated too much.


Can't login to user except root
UI doesn't matches the preview
Heat problem

I just tried the xfce image again on the rockpro64. The boot time still delays of course but it is booting for me. I also tested several of the pre-releases in the past weeks and haven't come across any nonbooting images.

I seriously doubt this would happen but are you sure you downloaded the correct image? Outside of some power supply issues, this is the only thing that I can think is happening.

If you are sure that you have the right image, let me or @Strit know and one of us will gladly build a release image that contains the 5.3 rc kernel. Its pretty solid on the rp64 and contains the boot time patch (we started calling it the BTP) that fixes that annoying 5 minute delay

Did you create another user during OEM setup?
Remember, it has to be all lower case and no special characters.

That's because we don't theme the root users UI, since root shouldn't be used with GUI apps anyway.

1 Like

I tried again with the xfce image of Manjaro ARM 19.08 for RockPro64. I also changed the PSU and no boot again waiting, this time, for 30 min. Than I just changed the microSD with the MrFixit image (debian/ubuntu with old, blob patched, kernel) and it boots. This image after 10-12 sec lights 2 more leds (white and red) on the board located on the opposite side of the PSU connector and the green led. The Manjaro image, after 30 min, no boots and no lights these two more leds. Is that of any help?
If you can kindly prepare an image with the BTP patch I'll try it.

I will make you an image with 5.3. What you want minimal, kde or xfce edition?

I prefer xfce. Thank you.

I have done it, but option of login comes with other user login. i.e just root user login.

If you user got created, you should be able to log into TTY with it.
If that's not the case, your user is not created. And if it's not created, it means you had an error in your username.

Raspberry Pi 4 user here. I like the desktop look of LXQt better than Raspbian Buster, but I am having a hard time configuring audio. With Buster, I at least can see HDMI out, and the audio was in stereo. I am only seeing mono in Manjaro LXQt. Any tips on how to configure it properly. I would love to get 5.1 pass through audio over HDMI if I could.

worked charm...need help to port chrome into aarch64 is it possible in manjaro arm?

Chromium should be in the repo.

Google Chrome is not available for ARM.

1 Like

Thank you for the hard work on getting this put together. I have successfully installed the minimal on my Raspberry Pi 4. I am having an issue though logging in via ssh. systemctl status sshd shows that it is running. From a linux machine on the same network, ssh user@addy will prompt for my password. Once I enter my password it simply stalls out, and then closes the session. I edited the ssh_config to allow root logins with password, and the same happens with the root login.

On the raspberry after the ssh attempt, entering systemctl status sshd returns the fact that the sessions was opened for user root from

Any ideas what I need to adjust?

Thank you again,

tried dolphin emulator - works fine. can I have some other arm emulators if you got any, please mention

It is awesome to see a desktop environment that I actually like, running on my RPi4! I have nothing against Raspbian, but it has its place... But I digress.

I've been trying out the 19.08 xfce image. Generally speaking, awesome so far!

The Settings->Display control panel does not recognize my 4k monitor and defaulted to FHD. I don't know the equivalent commands in this distro, so I used Raspbian (which did not have the same EDID issue) and "tvservice -d blah.dat" and "edidparser blah.dat > blah.txt" to get the correct settings for my monitor and added "hdmi_force_hotplug:0=1", "hdmi_group:0=1", and "hdmi_mode:0=95" to my Manjaro config.txt and it worked fine, although cursor movement and any animation appears choppy. I also tried "hdmi_enable_4kp60" with "hdmi_mode:0=97" and it worked without any noticeable problem.

Playing video on a 4k monitor is not very good compared to where video playback is at on Raspbian at the same 4k monitor resolution, same RPi4. 1080P fullscreen on raspbian is smooth, but playing the same video even with a 1:1 window is choppy. I know it is completely unrealistic to ever expect 4k video to play smoothly (if at all), but raspbian can "kinda not really, but kinda" play 4k video full screen at about 1 frame per 5 seconds. Ish. With periodic artifacts. But once in a while you'll see a clearly rendered 4k frame. Probably not a viable performance benchmark, but I thought it was interesting.

USB Booting on RPi4:
Will Manjaro have an update "package" for the updated boot EEPROM when USB booting gets released, or should I keep a copy of raspbian around for that firmware update?

Anyone heard any updates on USB boot yet? I have the phrase "Are we there yet?" playing in an infinite loop in my head and CTRL-C just doesn't do anything. I don't understand why they started working on PXE boot before USB.

Forum kindly sponsored by