Manjaro ARM 20.06 released!

I use Manjaro on laptops and it's much easier with that. I know arm is more trouble but it would be nice to catch-up x86-64

In what way?

I don't think Manjaro x64 does anything with cups or avahi. They might do with samba, but even that has seen trouble in the last couple of months on x64.

You may be right, but in arm there are some more difficulties, eg: cups printing fails ading printers because drivers are not aarm64 compatible, so we have to use discovered avahi printers with generic raw (airprint) drivers. But than again name resolution in avahi isn't working without installing more packages, and most frustrating is that we mast use systemctl to enable services because there aren't enabled by default on installing them. (Yes, avahi again, and without it printing fails)
Here is what we must do for name resolution from arch wiki for the printer name to be resolved:

Avahi provides local hostname resolution using a " hostname .local" naming scheme. To enable it, install the nss-mdns package and start avahi-daemon.service .

Then, edit the file /etc/nsswitch.conf and change the hosts line to include mdns_minimal [NOTFOUND=return] before resolve and dns

This is an example of many things I had to do for my system to function at a minimum write and print something

This is especially true for brother printer drivers, those are all x86 only (or at least were last time I used one) only some higher end models are supported by gutenprint pcl or generic ps drivers with a ppd from brother.

It's usually not arm's fault.

But even more disappointed I am because of their Android printer drivers, try printing without internet... I wish I could have cups on my phone. Oh wait I just need a pinephone! My dream would be a pinephone with a decent camera :smile:

I have a Cannon Mg3250, old and we'll supported before in Linux, but in arm it fails miserably after cups think it had found drivers but cannot use them. And than follow avahi adventures..

On the cannon driver download page there are rpm drivers for linux 32bit and 64bit, so only x86 not architecture independent. They don't offer arm drivers.

There seems to be an experimental driver though: http://gimp-print.sourceforge.net/p_Supported_Printers.php

Anyone else can use i3 on the new PBP? I spent hours on trying different images. I can do the initial setup normally, then after reboots, black screen. I had to switch try consoles back and forth to see any movements.

The other way around install xfce and i3 manually, buy something buggy. Rofi doesn't work,status bar shows no battery, mouse is just laggy.

I'm running out of options. Should I do KDE and then i3? I honestly do not want anything else besides i3. I jumped on the PBP because I just want the i3. I don't care for any other DE.

We have prepared a Sway profile that might be of interest to you. Sway is a drop-in replacement for i3 based on Wayland. I'm preparing a blog post how to install it, but at the moment we don't have image files ready and you might end up with triggering the manjaro-arm-installer script yourself (from microSD to install on eMMC, or the other way around).
Sources: https://gitlab.manjaro.org/manjaro-arm/applications/manjaro-arm-installer

1 Like

Hi folks, whatever I do, I can't seem to be able to get the new release.

pacman -Q manjaro-system
manjaro-system 20200428-1

Was there any change in mirrors again recently or something?

top of my mirrorlist is:

Server = https://manjaro.moson.eu/arm-stable/$repo/$arch

Also ran:

 sudo pacman-mirrors -g && sudo pacman -Syyu

as was suggested in one of the previous mirror migration posts, but I' still sitting on "there is nothing to do".
Maybe I'm misunderstanding something? Any help appreciated!

edit: yeah, probably just a PEBKAC. "manjaro-release" is version 20.6-1. I guess I should be checking this one right?

1 Like

Yep.
But the images are really just snapshots of the packages. So as long as you are up to date you are good.

Can anyone confirm if the fb turbo is packaged with the i3 image?

See if it is installed:

[ray@pi3b ~]$ pacman -Ss xf86-video-fbturbo-git
community/xf86-video-fbturbo-git 199.f9a6ed7-4.1 [installed]
    X.org MALI video driver

If it is installed this file should exist:

[ray@pi3b ~]$ ls -lah /etc/X11/xorg.conf.d/99-fbturbo.conf 
-rw-r--r-- 1 root root 607 Jan 16 05:18 /etc/X11/xorg.conf.d/99-fbturbo.conf

Can anyone tell me what the partition table looks like on a default 20.06 kde-plasma looks like on a Pinebook Pro? Thanks in advance

This depends on the device.
If it's a Lima device (like Pinebook), then yes.
If it's a panfrost or raspberry pi device (like Pinebook Pro), then no.

The partition layout is the same across all the supported devices.
So you have a BOOT_MNJRO partition 256 MB large starting from 32 MB on the drive and a ROOT_MNJRO partition filling the rest of the drive.
Uboot is in the first 32 MB on the drive.

1 Like

Sadly, this release, like 20.04, results in a black screen on the original Pinebook (the one with 1366x768 display).

Tried so far: KDE Plasma image.

Will try now: i3 image.

EDIT

Result: Not working.

Manually altered the extlinux.conf to change initial screen res and remove bootsplash. Managed to get through the install routine, but just like 20.04, the display powers off at boot completion.

Second EDIT:

OK, I've managed to fix it. For some reason, within the config it was trying to set the correct resolution but a refresh rate of "0.00000000 ...." (this was the xfce image)

I changed that to 60 and all is well.

Last EDIT:

On the KDE image, you'll have to forgive because I'm now tired and cranky... but there's a config file referencing a session or window position or something with a width of 1920. I changed that to 1366. There was another file referencing a background image wallpaper file with 1920x1080 size. I changed that to 1280x720.

When I booted up, it worked.

KDE seems very slow on Pinebook versus xfce.

@Strit, I have the Pinebook Pro and I can confirmed after countless hours. I had to go to TTY2 to remove the xf86-video-fbturbo-git and then everything works.

I tried it on the SD card and also eMMC. Now I am configuring the i3 config file and I can switch focus or move the containers around with the arrow keys, only the JKL; keys are working. Any ideas?

AFAIR you have to install the keyboard updater and run the keyboard patch routine incl. the community update

I forgot to do this. I did this prior to this new installation. Going to have to do it again. Thanks for the reminder

update: it doesn't work. I did both original way and the modded way. I just set both Mod1 and Mod4 as an alternative. Touchpad seems more smoother though

Is there any plane to release Manjaro with Swaywm for Pinebook Pro?

Forum kindly sponsored by