Manjaro ARM Alpha1 with Phosh

Manjaro ARM Alpha1 of Phosh for PinePhone and PineTab!

The Manjaro ARM project is proud to announce the first ALPHA release for the PinePhone and the PineTab running Phosh!

This image are running the 5.7 kernel from gitlab.com/pine64-org/linux, which is designed for the PinePhone.

Thanks for @Spikerguy for putting in all this work!

IMG_20200702_162144

Features:

  • Uses kernel 5.7.0 (pinephone) or mainline 5.7.7 (pinetab).
  • Default branch is arm-unstable. This can be changed by editing /etc/pacman-mirrors.conf.
  • This image uses a Crust enabled uboot.

Download:

Device Phosh
PinePhone Alpha1
PineTab Alpha1

About the devices:
PinePhone:
Perhaps you’re in a line of work where security is a must, or a hard-core Linux enthusiast, or perhaps you’ve just got enough of Android and iOS and you’re ready for something else – the PinePhone may be the next Phone for you. Powered by the same Quad-Core ARM Cortex A53 64-Bit SOC used in our popular PINE A64 Single Board Computer, the PinePhone runs mainline Linux as well as anything else you’ll get it to run.

The purpose of the PinePhone isn’t only to deliver a functioning Linux phone to end-users, but also to actively create a market for such a device, as well as to support existing and well established Linux-on-Phone projects. All major Linux Phone-oriented projects, as well as other FOSS OS’, are represented on the PinePhone and developers work together on our platform to bring support this this community driven device.

PineTab:
The PINETAB is similar in both form, function and underlying ARM64 architecture to the original 11.6″ PINEBOOK. It is powered by the same Quad-Core ARM Cortex A53 64-Bit Processor used in our popular PINE A64 Single Board Computer. The optional keyboard and trackpad – which doubles-up as a screen cover – effectively converts the PineTab into a petite on-the-go laptop with a touch screen functionality. It runs numerous mainline Linux distributions as well as *BSDs and Android.

As a new open source platform, the PineTab development is an ongoing process and represents a great opportunity to get involved with computing on a different level, to customise and personalise the portable computer experience, to understand what is going on beneath the surface.

How to install:

Download the image/xz file from the download location. Verify that the download completed successfully.

After that, install Etcher (sudo pacman -S etcher if on Manjaro) and burn the to an SD card (8 GB or larger).

The PinePhone/PineTab should recognize the SD card as a bootable device and boot from it.

The premade users are:
User: manjaro
Password: 123456

User: root
password: root

Known Issues:

  • Screen autorotation does not work. Manual does.
  • Audio seems to not work.
  • Bluetooth seems to not work.
  • UI becomes unresponsive after a while.
  • Lots of apps are still missing or is not mobile friendly yet.

Donate!

Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.

14 Likes

Looking forward to a ManjaroARM branded batch of PinePhones...:sunglasses:

2 Likes

That is in queue already :smiley:

Audio will work fine after installing alsa-utils

4g and calling will work with ModemManager service enabled
Will be updating some packages soon so this will be fixed.

7 Likes

Does pinephone wake up by call from crust-deep-sleep?

1 Like

Not yet, it will wake up once we update the kernel.

2 Likes

eg25.service needs to be modified so it loads before ModemManager ...

1 Like

And what happens if modemmanager is not present on the system (like on our Plasma Mobile images)? Will it just fail to load eg25 completely?

After installing alsa-utils is there anything else that needs to be done? Installing and enabling ModemManager worked brilliantly for calls; I must be missing something obvious to get audio working.

Thanks for all the hard work!

awesome work on this! really excited about this build

Then we should figure out how we do it. However we should focus on the Phosh version for now to get a proper version out.

1 Like

Seems you do also great with the PurismOS. We might adopt some patches from you.

1 Like

So far we managed to fix some issues we had with alpha1. Here a small tutorial on how to fix them for now, until we have a new IMG available:

  • connect via WIFI to the internet on the phone
  • check your IP of the phone on the phone: nmcli -p device show wlan0
  • ssh to your phone from your PC: ssh manjaro@<IP> (<IP> is your found IP of wlan0; password is 123456)
  • do a system update on your phone: su root (password=root); pacman -Syu
  • enable ModemManager: systemctl enable ModemManager
  • uninstall ofonoctl: pacman -R ofonoctl
  • install alsa-utils: pacman -S alsa-utils
  • move a folder: mv /usr/share/alsa/ucm2/sun50i-a64-audio /usr/share/alsa/ucm2/sun50i-a64-audi
  • remove LightDM: pacman -R lightdm lightdm-gtk-greeter
  • enable Phosh: systemctl enable phosh
  • reboot the phone: reboot
6 Likes

Thank you for the temporary steps, Philm. I have tried following the steps but I am having an issue executing the move command:

mv /usr/share/alsa/ucm2/sun50i-a64-audio /usr/share/alsa/ucm2/sun50i-a64-audio

It doesn't seem to be able to find the path:

mv: cannot stat '/usr/share/alsa/ucm2/sun50i-a64-audio': No such file or directory

UPDATE

I realised what was wrong. In your step the source/destination paths needs to be swapped:

mv /usr/share/alsa/ucm2/sun50i-a64-audi /usr/share/alsa/ucm2/sun50i-a64-audio
1 Like

mozzwald is the real guru but if you have any specific questions feel free to reach out to me!

Pinephone's (default) standard display size is 720x360
Isn't 360x720 correct?
Many installed programs are too wide.

You can download an updated version with some more fixes ...

1 Like

I pushed out another build.

What got improved:

  • We updated the kernel to have sensors information
  • We added more packages to our image

What makes troubles:

  • gnome-usage only works as root (permission issues)?
  • volume-keys don't work yet, I added actkbd-pinephone-volume
  • pinephone-modem-scripts, pinephone-softsleep and alsa-ucm-pinephone don't load the phosh when I disable our old packages
  • pinephone-manjaro-tweaks might need a second look as feedbackd theme doesn't work
  • the usual mic and speaker issue in calls
  • Telegram has still the weird zero issue
  • pinephone-modem-audio still fails, can be replaced with eg25-misc or modem-scripts
2 Likes

Hey @philm @Strit and @spikerguy thanks for the phosh version, I've been super anxiously awaiting it!

However, I should just ask now, cause the signs are starting to pop up. Did you guys do any memory speed increases in uboot? I have been getting random freezes and lock ups that sometimes are small crashes and sometimes require a hard shutdown to fix. Almost every time this happens it's with phosh and it's a distro that is trying a memory speed increase.

The pine64 forum has a test of people with memory speed issues, and I can definitely tell you I am on the bottom of the scale, anything above 500MHz causes freezing and lock ups.

Here is the thread with a poll of RAM overclocking capability from the first run of people if anyone is interested. It's from before they added a 492 option that was the only one mine ran on nicely: https://forum.pine64.org/showthread.php?tid=9832

We use the uboot from gitlab.com/pine64-org/u-boot with crust enabled.

Not sure if it has the speed increase or not. If it's an issue, you should report it to the devs there.

1 Like

Thanks! I'll check it out.

Forum kindly sponsored by