Manjaro ARM Alpha4 for PinePhone and PineTab

Manjaro ARM Alpha4 for PinePhone and PineTab!

The Manjaro ARM project is proud to announce the fourth ALPHA release for the PinePhone and the PineTab!

This image are running the 5.5 kernel from, which is designed for the PinePhone and PineTab devices.

We strongly suggest flashing this image, instead of updating the Alpha3 image.

Thanks for @Spikerguy for putting in all this work!

Changes since Alpha3:

  • Phonebook app can now save contacts
  • Power button now locks the screen.
  • Added Manjaro ARM wallpaper.
  • Added a couple of new apps.
  • Favorites bar now shows.
  • Brightness control now works.
  • New Plasma Mobile interface.
  • The Alpha images are now using Unstable branch.
  • New 2 partition layout with extlinux.conf file.
  • Password changed for default user to 1234.


Plasma Mobile for PinePhone
Plasma Mobile for PineTab

Perhaps you’re in a line of work where security is a must, or a hard-core Linux enthusiast, or perhaps you’ve just got enough of Android and iOS and you’re ready for something else – the PinePhone may be the next Phone for you. Powered by the same Quad-Core ARM Cortex A53 64-Bit SOC used in our popular PINE A64 Single Board Computer, the PinePhone runs mainline Linux as well as anything else you’ll get it to run.

The purpose of the PinePhone isn’t only to deliver a functioning Linux phone to end-users, but also to actively create a market for such a device, as well as to support existing and well established Linux-on-Phone projects. All major Linux Phone-oriented projects, as well as other FOSS OS’, are represented on the PinePhone and developers work together on our platform to bring support this this community driven device.

The PINETAB is similar in both form, function and underlying ARM64 architecture to the original 11.6″ PINEBOOK. It is powered by the same Quad-Core ARM Cortex A53 64-Bit Processor used in our popular PINE A64 Single Board Computer. The optional keyboard and trackpad – which doubles-up as a screen cover – effectively converts the PineTab into a petite on-the-go laptop with a touch screen functionality. It runs numerous mainline Linux distributions as well as *BSDs and Android.

As a new open source platform, the PineTab development is an ongoing process and represents a great opportunity to get involved with computing on a different level, to customise and personalise the portable computer experience, to understand what is going on beneath the surface.

How to install:

Download the image/xz file from the download location. Verify that the download completed successfully.

After that, install Etcher (sudo pacman -S etcher if on Manjaro) and burn the to an SD card (8 GB or larger).

The PinePhone/PineTab should recognize the SD card as a bootable device and boot from it.

The premade users are:
User: manjaro
Password: 1234

User: root
password: root

Known Issues:

  • Phone app works, but not calls.
  • Power savings is not optimized, but better than alpha3.
  • Can't control Bluetooth from Settings, but can be controlled with a widget!
  • Screen rotation does not work. (but will soon)
  • Some scaling is still not right on the PineTab.


Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.


Phone calls will work with this command.

sudo pacman -S libofono-qt qt5-feedback


Audio routing for the call is still now present.


What is the state of SMS?

Eagerly awaiting the PineTab :drooling_face:

Users can try and test
Koko Image Gallery App and Peruse ComicBook reading app :smiley:

sudo pacman -S koko peruse

1 Like

is anyone else seeing issues with wifi in alpha 4 that were not there in alpha 3. the gui for wifi it keeps killing itself and not able to get fully through the connection setup etc. im using the same wifi as i did with alpha 3.

What's the problem with call audio that is preventing it from working?

Last update the info was calls would be coming in next. Now the update is not even mentioning them coming soon. What really is the situation, can i expect to make calls under manjaro in the near future, or should i start evaluating other options?

In the linux world you're always free to evaluate other options.

And as you read in this post Here

I did mention, phone call is working but audio routing needs to be worked on.

The manajro arm team is always working to get a stable img for all the supported devices. So please be patient with the pinephone as not just manjaro but kde plasma mobile is also working on getting more functions to work on the phone.

I haven't faced any issue with the wifi ui during my daily test before the release. Can you share the screenshots. Also are you entering any password in kwallet? Normally if you enter a blank password in kwallet then there is no issue with wifi at all. I have done wifi stability test for hours and ive not faced any wifi drop or not connecting on reboot issue.

Will be doing a detailed debugging tonight to see what's needed for the audio to work on call.


so you can make calls and hear the recipient but not play back audio through loudspeaker mode or a headset? I don't fully understand that statement, so please clarify if I understand this wrong. If it works as a normal handset held up to my ear then that would be good enough for me at this early stage :wink:

I'm tempted to order one.

1 Like

Neither. Making a call simply means you can connect to another phone and call it. Routing to Loudspeakers and Mic currently doesn't work. So the other phone simply hears a buzzing noise. Which means you can call each phone but a discussion is not yet possible.


okay perfect explanation, much appreciated

Only recently PostmarketOS with PlasmaMobile on cracked it. We have to see when we support audio calls with our image.


@cryptolize I think this may be a result of a NULL dereference in the wifi driver upon scan; I see tracebacks and broken wifi in dmesg with the Manjaro 5.5.0-4 kernel. This has been fixed upstream but someone needs to include the patch in the Manjaro package.

1 Like

i have the same experience ,phone call , rings the bell but no sound at all.
have you looked at Debian-Phosh = the settings/power/network / pages ,fit the page ,better info input.
nice work guys

Seems we used a different branch, which doesn't have this fix. We will update the kernel once more.

For Kwallet which appears on first connecting of wifi, i used the blowfish option, with a password matching the login/user so 1234 for this alpha. after the password was accepted etc it just kept attempting to connect, and the GUI become very lagy to the point that when you exit the wifi settings and then go back it would load a grey screen then kill it self taking you back out to the desktop... whatever was happening also made the terminal lag, it took 30 seconds after issuing "shutdown now" command before it even did anything.... i will try it out again today and see what common behavior is at play and see if i can provide a better description...

is there a work around for alpha 4 to be able to use wifi to be able to get the updated kernel etc...

After reboot, wifi was dead and would not turn back on with " nmcli r wifi on " the gui would load but not activate wifi. so i called it a fail, and re-imaged the SD. this time around i set a blank password for the Kwallet... the other thing i noticed the keyboard had a default of uppercase on wifi password entry.... can anyone else confirm this, it would be problematic as people are used to a deliberate effort to enter caps instead of it being the default for wifi password entry etc...

We have noticed this too.
Must be something in the keyboard source.

1 Like

Forum kindly sponsored by